在线检测未来函数

通达信上出下买+三背离主图指标公式

来源:Internet,编辑:股旁网,2011-12-23

A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),COLORWHITE,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;
IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);
IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头}
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1>0,L-0.02,4),COLOR00FFFF;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,L-0.10,5),COLORFF00FF;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(B3>0,L-0.18,6),COLOR0000FF;{RSI底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1>0,H+0.16,4),COLOR00FF00;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2>0,H+0.08,5),COLORFFFFCC;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3>0,H+0.04,6),COLORFF9900;{RSI顶背离};
STICKLINE(C>REF(C,1),H,L,0,1),COLOR0000FF;
STICKLINE(C>REF(C,1),O,C,3.2,0),COLOR000055;
STICKLINE(C>REF(C,1),O,C,2.7,0),COLOR000077;
STICKLINE(C>REF(C,1),O,C,2.1,0),COLOR000099;
STICKLINE(C>REF(C,1),O,C,1.5,0),COLOR0000BB;
STICKLINE(C>REF(C,1),O,C,0.9,0),COLOR0000DD;
STICKLINE(C<REF(C,1),O,C,0.3,0),COLOR0000FF;
STICKLINE(C<REF(C,1),H,L,0,1),COLORFFFF00;
STICKLINE(C<REF(C,1),O,C,3.2,0),COLOR990000;
STICKLINE(C<REF(C,1),O,C,2.7,0),COLORCC0000;
STICKLINE(C<REF(C,1),O,C,2.1,0),COLORFF4400;
STICKLINE(C<REF(C,1),O,C,1.5,0),COLORFF8800;
STICKLINE(C<REF(C,1),O,C,0.9,0),COLORFFCC00;
STICKLINE(C<REF(C,1),O,C,0.3,0),COLORFFFF00;
STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
STICKLINE(C=REF(C,1),O,C,3.2,0),COLOR555555;
STICKLINE(C=REF(C,1),O,C,2.7,0),COLOR777777;
STICKLINE(C=REF(C,1),O,C,2.1,0),COLOR999999;
STICKLINE(C=REF(C,1),O,C,1.5,0),COLORBBBBBB;
STICKLINE(C=REF(C,1),O,C,0.9,0),COLORDDDDDD;
STICKLINE(C=REF(C,1),O,C,0.3,0),COLORFFFFFF;

通达信上出下买+三背离主图指标公式

 

相关文章