在线检测未来函数

通达信北沙三角彩带主图指标公式

来源:Internet,编辑:股旁网,2011-12-25

N:=9;XR:=1;XK:=5;
HH:=HHV(HIGH,XK);
LL:=LLV(LOW ,XK);
OO:=IF(XK<=1,OPEN,REF(OPEN,XK-1));
CCZ:=CLOSE;
XH:=CONST(IF(ISLASTBAR,IF(XR<=1,HH,REF(HH,XR-1)),DRAWNULL));
XL:=CONST(IF(ISLASTBAR,IF(XR<=1,LL,REF(LL,XR-1)),DRAWNULL));
XO:=CONST(IF(ISLASTBAR,IF(XR<=1,OO,REF(OO,XR-1)),DRAWNULL));
XC:=CONST(IF(ISLASTBAR,IF(XR<=1,CCZ,REF(CCZ,XR-1)),DRAWNULL));
AZA:=ZIG(3,10);
JX:=MA(ZIG(3,10),2)>AZA;
SX:=MA(ZIG(3,10),2)<AZA;
JJ:=DRAWLINE(JX,AZA,REF(JX,1),REF(AZA,1),1);
SS:=DRAWLINE(SX,AZA,REF(SX,1),REF(AZA,1),1);
DRAWBAND(AZA,RGB(200,160,0),JJ,RGB(0,0,0));
DRAWBAND(SS,RGB(0,160,200),AZA,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=XR+FLOOR(XK/2) ,XH,XL,XK*4+1,1),COLORWHITE;
MA34:MA(CLOSE,34),LINETHICK3,COLORYELLOW;
GJ:=(C+H+L+O)/4;
日阻力:=L+(GJ-L)+(C-L),LINETHICK0;
支撑:=L+(C-GJ),LINETHICK0;
日压:REF(日阻力 , 1),NODRAW,COLOR00FF00;
日支:REF(日支撑 , 1),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,日压,日压,30,1),LINETHICK2,COLOR00FF00;
STICKLINE(ISLASTBAR,日支,日支,30,1),LINETHICK2,COLORYELLOW;
FC:=C;
A:=EMA(FC,3);
B:=EMA(FC,5);
Z:=EMA(FC,15);
Z2:=MA(A,5);
玄悟斋主:=MA(Z,7);
個:=EMA(Z2,3);
十:=EMA(Z2,5) ;
百:=EMA(Z2,7);
千:=EMA(Z2,9);
万:=EMA(Z2,11);
K1:=BACKSET(個<REF(個,1),2);
谈:IF(K1,個,DRAWNULL),COLOR00AA00,LINETHICK1;
K2:=BACKSET(十<REF(十,1),2);
笑:IF(K2,十,DRAWNULL),COLOR00BB00,LINETHICK1;
K3:=BACKSET(百<REF(百,1),2);
皆:IF(K3,百,DRAWNULL),COLOR00CC00,LINETHICK1;
K4:=BACKSET(千<REF(千,1),2);
鸿:IF(K4,千,DRAWNULL),COLOR00DD00,LINETHICK1;
K5:=BACKSET(万<REF(万,1),2);
儒:IF(K5,万,DRAWNULL),COLOR00EE00,LINETHICK1;
K6:=BACKSET(個>REF(個,1),2);
往:IF(K6,個,DRAWNULL),COLOR0000AA,LINETHICK1;
K7:=BACKSET(十>REF(十,1),2);
来:IF(K7,十,DRAWNULL),COLOR0000BB,LINETHICK1;
K8:=BACKSET(百>REF(百,1),2);
无:IF(K8,百,DRAWNULL),COLOR0000CC,LINETHICK1;
K9:=BACKSET(千>REF(千,1),2);
白:IF(K9,千,DRAWNULL),COLOR0000DD,LINETHICK1;
K10:=BACKSET(万>REF(万,1),2);
丁:IF(K10,万,DRAWNULL),COLOR0000EE,LINETHICK1;
個Z:=EMA(玄悟斋主,3) ;
十Z:=EMA(玄悟斋主,5);
百Z:=EMA(玄悟斋主,7);
千Z:=EMA(玄悟斋主,9);
万Z:=EMA(玄悟斋主,11);
B1:=BACKSET(個Z<REF(個Z,1),2);
禅:IF(B1,個Z,DRAWNULL),COLORFFAA11,LINETHICK1;
B2:=BACKSET(十Z<REF(十Z,1),2);
味:IF(B2,十Z,DRAWNULL),COLORFFBB22,LINETHICK1;
B3:=BACKSET(百Z<REF(百Z,1),2);
闲:IF(B3,百Z,DRAWNULL),COLORFFCC33,LINETHICK1;
B4:=BACKSET(千Z<REF(千Z,1),2);
里:IF(B4,千Z,DRAWNULL),COLORFFDD44,LINETHICK1;
B5:=BACKSET(万Z<REF(万Z,1),2);
得:IF(B5,万Z,DRAWNULL),COLORFFEE55,LINETHICK1;
B6:=BACKSET(個Z>REF(個Z,1),2);
道:IF(B6,個Z,DRAWNULL),COLORF67ACD,LINETHICK1;
B7:=BACKSET(十Z>REF(十Z,1),2);
心:IF(B7,十Z,DRAWNULL),COLORF68ACD,LINETHICK1;
B8:=BACKSET(百Z>REF(百Z,1),2);
静:IF(B8,百Z,DRAWNULL),COLORF69ACD,LINETHICK1;
B9:=BACKSET(千Z>REF(千Z,1),2);
中:IF(B9,千Z,DRAWNULL),COLORF70ACD,LINETHICK1;
B10:=BACKSET(万Z>REF(万Z,1),2);
参:IF(B10,万Z,DRAWNULL),COLORF71ACD,LINETHICK1;
BIAS0:= (C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
SJ6:=CROSS(0.5,SJ5);
JS1:=CROSS(SJ6,0.5);JS2:=BARSLAST(JS1=1);
JS3:=JS2<=5 AND C<REF(C,JS2);
合璧:=SJ6 OR JS3;
斋主:IF(合璧=1,L*0.999,DRAWNULL),CIRCLEDOT,COLORLIGREEN;
中压:=XMA(GJ,20)*(1+80/1000),COLORGREEN,LINETHICK2;
中支:=XMA(GJ,32)*(1-100/1000),COLORMAGENTA,LINETHICK2;
幅度:=100*(中压-中支)/中支;
分水线:=(MA(CLOSE,3)+MA(CLOSE,7)+MA(CLOSE,13)+MA(CLOSE,18))/4;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDD1:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力:=IF(CROSS(D24,DDD1),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD1)))),COLORFFFFFF;
决策:IF(ISLASTBAR,压力,DRAWNULL),COLORMAGENTA;
STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORMAGENTA;
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:IF(ISLASTBAR,底部,DRAWNULL),COLORRED;
STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORRED;
AA:=REF(H,N)=HHV(H,2*N+1); AA1:=REF(L,N)=LLV(L,2*N+1);
QY:=BACKSET(AA,N+1); QY1:=BACKSET(AA1,N+1);
CC:=FILTER(QY,N) AND H=HHV(H,N+1); CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);
DDD:=BARSLAST(CC); DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0); DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS); DDCS1:=CONST(DDTS1);
GDCS13:=CONST(REF(HIGH,GDCS1-1)); DDCS13:=CONST(REF(L,DDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1); DDTS2:=REF(DDTS1,DD1+1);
GDCS2:=CONST(DINGBUTS1); DDCS2:=CONST(DDTS2);
MZ:=INTPART(3*N/5);
AAA:=REF(H,MZ)=HHV(H,2*MZ+1);
QYY:=BACKSET(AAA,MZ+1);
CCC:=FILTER(QYY,MZ) AND H=HHV(H,MZ+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
{www.gUPaNg.com 股旁网_最新股票指标公式}
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,MZ)=LLV(L,2*MZ+1);
QY11:=BACKSET(AA11,MZ+1);
CC11:=FILTER(QY11,MZ) AND L=LLV(L,MZ+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
ZGD:=HHV(H,60)*1.01.00;
ZGD2:=CONST(ZGD);
高点Z:=CONST(HHV(H,100)),NODRAW;
低点Z:=CONST(LLV(L,100)),NODRAW;
高点压力M:=DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1),COLORRED,LINETHICK1;
低点支撑M:=DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1) COLORRED,LINETHICK1;
高点压力1:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) ,COLORBLUE,LINETHICK1;
低点支撑1:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),COLORBLUE,LINETHICK1;
IF(BETWEEN(高点压力M,高点Z,低点Z),高点压力M,DRAWNULL),COLORWHITE,LINETHICK1;
IF(BETWEEN(低点支撑M,高点Z,低点Z),低点支撑M,DRAWNULL),COLORWHITE,LINETHICK1;
IF(BETWEEN(高点压力1,高点Z,低点Z),高点压力1,DRAWNULL),COLORWHITE,LINETHICK1;
IF(BETWEEN(低点支撑1,高点Z,低点Z),低点支撑1,DRAWNULL),COLORWHITE,LINETHICK1;
HHZ:=HHV(HIGH,5);
LLZ:=LLV(LOW,5);
HH1:=BARSLAST((HHZ > REF(HHZ,1)));
LL1:=BARSLAST((LLZ < REF(LLZ,1)));
STICKLINE((HH1 > LL1),CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORGREEN;
STICKLINE((HH1 < LL1),CLOSE,OPEN,2,0),COLORRED;
STICKLINE((HH1 < LL1),HIGH,LOW,0,0),COLORRED;
日均价:=(C*3+H+L+O)/6;
ZIA:=日均价;
裁决:=(REF(ZIA,1)*0.5+REF(ZIA,2)+REF(ZIA,3)*0.5)/2;
VAR1X:=IF(C<裁决 AND BETWEEN(裁决,C,O),1,0);
VAR4X:=IF(C>=裁决 AND BETWEEN(裁决,C,O),1,0);
CO:=(C-O);
STICKLINE(VAR4X,O,O+CO/3,3.6,0),COLORLIMAGENTA;
STICKLINE(VAR1X,O,O+CO/3,3.6,0),COLORGREEN;
MA10:=MA(C,10),COLORGREEN,LINETHICK2;
MA20:=MA(C,20),COLORCYAN,LINETHICK2;
MA30:=MA(C,30),COLORYELLOW,LINETHICK2;
VAR1:=(C- LLV(L,32)) / (HHV(H,32) - LLV(L,32)) * 1.2 * C;
VAR2:=EMA(VAR1,3);
VAR3Z:=EMA(VAR1,5);
VAR4Z:=EMA(VAR1,7);
VARA:=VAR3Z >= VAR4Z AND VAR2 < REF(VAR2,1);
VARB:=VAR3Z < VAR4Z AND VAR2 > REF(VAR2,1);
超短:=MA(VAR2,6);
短线:=MA(超短,2);
STICKLINE(FILTER(VARB,3),低点支撑1,低点支撑1-0.05,2,0),COLORFF00FF;
STICKLINE(CROSS(短线,超短),高点压力1,高点压力1+0.05,4,1),COLORLIGRAY;
DRAWTEXT(CROSS(短线,超短) AND COUNT(CROSS(短线,超短),10)=2,高点压力M-0.05,'跑'),COLORGREEN;
DRAWTEXT(FILTER(VARB,3),低点支撑1-0.02,'醒醒'),COLORFF00FF;
DRAWTEXT(CROSS(短线,超短),高点压力1+0.05,'睡觉'),COLORWHITE;
AAZ:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BBZ:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AAZ AND CLOSE>REF(OPEN,2),低点支撑1+0.05,'三平底'),COLORWHITE;
DRAWTEXT(BBZ AND CLOSE<REF(CLOSE,2),高点压力M-0.05,'三平顶'),COLORCYAN;

通达信北沙三角彩带主图指标公式

 

相关文章