在线检测未来函数

大智慧明日阻力与支撑短线主图指标公式

来源:Internet,编辑:股旁网,2011-12-28

操盘线:EMA(CLOSE,13),COLORRED;
M5:MA(CLOSE,5),COLORWHITE;
黄金线:COST(24),COLORYELLOW,POINTDOT,LINETHICK4;
底线:COST(5),COLORGREEN;
1号线:MA(CLOSE,144),COLORWHITE,LINETHICK2;
4号线:EMA(CLOSE,453),COLORRED,LINETHICK2;
VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD:=EMA(AK,2);
AJ:=3*AK-2*AD;
STICKLINE(CROSS(AK,AD),LOW,LOW-0.09,8,0),COLORRED;{短线买}
AC:=CLOSE;
AH:=HIGH;
AL:=LOW;
AO:=OPEN;
STICKLINE(AC>=AO,AH,AC,1,0),color008899;
STICKLINE(AC>=AO,AH,AC,0,0),color77ffee;
STICKLINE(AC>=AO,AO,AL,1,0),color008899;
STICKLINE(AC>=AO,AO,AL,0,0),color77ffee;
STICKLINE(AC>AO,AC,AO,8,0),COLOR008899;
STICKLINE(AC>AO,AC,AO,7,0),COLOR1199aa;
STICKLINE(AC>AO,AC,AO,6,0),COLOR22aabb;
STICKLINE(AC>AO,AC,AO,5,0),COLOR33bbcc;
STICKLINE(AC>AO,AC,AO,4,0),COLOR44ccdd;
STICKLINE(AC>AO,AC,AO,3,0),COLOR55ddee;
STICKLINE(AC>AO,AC,AO,2,0),COLOR66eeee;
STICKLINE(AC>AO,AC,AO,1,0),COLOR77ffee;
STICKLINE(AC<=AO,AH,AC,1,0),colorff8800;
STICKLINE(AC<=AO,AH,AC,0,0),colorffff33;
STICKLINE(AC<=AO,AO,AL,1,0),colorff8800;
STICKLINE(AC<=AO,AO,AL,0,0),colorffff33;
STICKLINE(AC<=AO,AC,AO,8,0),COLORff8800;
STICKLINE(AC<=AO,AC,AO,7,0),COLORff9900;
STICKLINE(AC<=AO,AC,AO,6,0),COLORffaa11;
STICKLINE(AC<=AO,AC,AO,5,0),COLORffbb11;
STICKLINE(AC<=AO,AC,AO,4,0),COLORffcc22;
STICKLINE(AC<=AO,AC,AO,3,0),COLORffdd22;
STICKLINE(AC<=AO,AC,AO,2,0),COLORffee33;
STICKLINE(AC<=AO,AC,AO,1,0),COLORffff33;
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND f<0,1,0);
p1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND f<0,1,0);
p2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,4,0),COLORRED;{短线进}
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,4,0),COLORBLUE;{短线出}
YC:=REF(CLOSE,1);
止损价位:(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0; { }
DRAWTEXTABS(CLOSE,0,'★ ======================'),COLORRED;
DRAWTEXTABS(CLOSE,80,'操 ----------------------'),COLORRED;
DRAWTEXTABS(CLOSE,160,'盘 ----------------------'),COLORRED;
DRAWTEXTABS(CLOSE,240,'铁 ----------------------'),COLORRED;
DRAWTEXTABS(CLOSE,320,'律 ======================'),COLORRED;
DRAWTEXTABS(CLOSE,40,' 买入条件 E13 CCI'),colorYellow;
DRAWTEXTABS(CLOSE,120,' 买入时间 2:30以后' ),colorYellow;
DRAWTEXTABS(CLOSE,200,' 止损价位 '+NUMTOSTR(止损价位)+'元'),colorYellow;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXTABS(CLOSE,280,' 线上:工作 线下:休息'),color00FFFF;
{ }
gj:=AMOUNT/VOL/100;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXTABS(200,8,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,22,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,36,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,52,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,70,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,86,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,102,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,14,'今日阻力=:'+NUMTOSTR(今日阻力)+''),Color00FFFF;
DRAWTEXTABS(200,30,'今日支撑=:'+NUMTOSTR(今日支撑)+''),Color00FF00;
DRAWTEXTABS(200,46,'明日突破=:'+NUMTOSTR(明日突破)),ColorFF00FF;
DRAWTEXTABS(200,62,'明日阻力=:'+NUMTOSTR(明日阻力)),ColorFFFF00;
DRAWTEXTABS(200,78,'明日支撑=:'+NUMTOSTR(明日支撑)),COLORRED;
DRAWTEXTABS(200,94,'明日反转=:'+NUMTOSTR(明日反转)),COLORGREEN;
N:=13;
A:=HHV(HIGH,N)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,N-1);
B:=LLV(LOW,N)=LOW AND LOW<REF(LOW,1);B1:=FILTER(B,N-1);
TS1:=BARSLAST(A1);
箱顶:REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;
TS11:=BARSLAST(B1);
箱底:REF(LOW,TS11) ,COLORFF8080, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFF8080;
DRAWICON(CROSS(CLOSE,箱顶),HIGH*1.01,4);
DRAWICON(CROSS(箱底,CLOSE),LOW*0.99,5);
DRAWICON(CROSS(箱顶,CLOSE) AND REF(CLOSE,1)>=箱顶,箱顶,12);

大智慧明日阻力与支撑短线主图指标公式

 

相关文章