在线检测未来函数

大智慧量价增减指标公式

来源:Internet,编辑:股旁网,2011-12-30

input:k(3,0,50);
DRAWGBKlast(DATE>900101,strip(RGB(40,0,40),RGB(0,0,0),0));0,ColorFF9900;
JV:=(V-REF(V,1))/REF(V,1)*100;
JVH:=EMA(SUM(JV,k),k);
PARTLINE(JVH,(JVH>REF(JVH,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2,LAYER4;
DRAWTEXT(BARSTATUS=2,0,' 换手:'),ALIGN0,COLOR00ffFF,LINETHICK2,LAYER0;
X:=BARSLAST(DISPSTATUS=1)+1;
ahx:=hhvall(hhv(JVH,X));
VERTLINE(JVH=ahx,4),COLOR00FFFF,LAYER0;
STICKLINE(JV>0,JV,0,5,0),Color000055,LAYER7;
STICKLINE(JV>0,JV,0,4,0),Color000077,LAYER7;
STICKLINE(JV>0,JV,0,3,0),Color000099,LAYER7;
STICKLINE(JV>0,JV,0,2,0),Color0000CC,LAYER7;
STICKLINE(JV>0,JV,0,1,0),Color0000FF,LAYER7;
STICKLINE(JV<0,JV,0,5,0),Color005500,LAYER7;
STICKLINE(JV<0,JV,0,4,0),Color007700,LAYER7;
STICKLINE(JV<0,JV,0,3,0),Color009900,LAYER7;
STICKLINE(JV<0,JV,0,2,0),Color00CC00,LAYER7;
HS:=vol/capital*100;
DRAWTEXT(JV and HS>2 ,-10,''+NUMTOSTRN(HS,0)+'' ),ALIGN1,color00FFff,linethick1,LAYER5;
IF (BARSTATUS=2 and c<200 and HS) THEN
DRAWTEXTABS(450,5, '■可视'+NUMTOSTRN(X,0)+'天累计换手 ' +NUMTOSTRN(SUM(HS,X),1)+'%, 平均换手 ' +NUMTOSTRN(SUM(HS,X)/X,1)+'%: ' ),COLOR00ffFF,LINETHICK3;
DRAWRECTABS(3,0 ,315 ,150 , rgb(0,0,80)),color00FFFF,LINETHICK2,LAYER0;
W1:=IF((V-REF(V,1))>0 AND ABS(C-REF(C,1))/REF(C,1)*100<0.1,1,0);
IF (BARSTATUS=2 and c<200 and W1) THEN
DRAWTEXTABS(0,5,' ◢'+W1+'◣ '),color0000FF,LINETHICK2,LAYER0;
DRAWTEXTABS(0,5,' 【加仓】:-- 1.量增价平,转阳信号。'),color0000FF,LINETHICK2,LAYER0;
W2:=IF((V-REF(V,1))>0 and (C-REF(C,1))>0,2,0);
IF (BARSTATUS=2 and c<200 and W2) THEN
DRAWTEXTABS(0,22,' ◢'+W2+'◣ '),color0055FF,LINETHICK2,LAYER0;
DRAWTEXTABS(0,22,' 【买入】:-- 2.量增价升,买入信号。'),color0055FF,LINETHICK2,LAYER0;
W3:=IF(ABS(V-REF(V,1))/REF(V,1)*100<0.1 and (C-REF(C,1))>0,3,0);
IF (BARSTATUS=2 and c<200 and W3) THEN
DRAWTEXTABS(0,39,' ◢'+W3+'◣ '),color0077FF,LINETHICK2;
DRAWTEXTABS(0,39,' 【加仓】:-- 3.量平价升,持续买入。'),color0077FF,LINETHICK2,LAYER0;
W4:=IF((V-REF(V,1))<0 and (C-REF(C,1))>0,4,0);
IF (BARSTATUS=2 and c<200 and W4) THEN
DRAWTEXTABS(0,56,' ◢'+W4+'◣ '),color0099FF,LINETHICK2;
DRAWTEXTABS(0,56,' 【持有】:-- 4.量减价升,继续持有。'),color0099FF,LINETHICK2,LAYER0;
W5:=IF((V-REF(V,1))<0 AND ABS(C-REF(C,1))/REF(C,1)*100<0.1,5,0);
IF (BARSTATUS=2 and c<200 and W5) THEN
DRAWTEXTABS(0,76,' ◢'+W5+'◣ '),color00FF00,LINETHICK2,LAYER0;
DRAWTEXTABS(0,76,' 【警戒】:-- 5.量减价平,警戒信号。'),color00FF00,LINETHICK2,LAYER0;
W6:=IF((V-REF(V,1))<0 and (C-REF(C,1))<0,6,0);
IF (BARSTATUS=2 and c<200 and W6) THEN
DRAWTEXTABS(0,93,' ◢'+W6+'◣ '),colorFFDD00,LINETHICK2,LAYER0;
DRAWTEXTABS(0,93,' 【卖出】:-- 6.量减价跌,卖出信号。'),colorFFDD00,LINETHICK2,LAYER0;
{www.gUPaNg.com 股旁网_最新股票指标公式}
W7:=IF(ABS(V-REF(V,1))/REF(V,1)*100<0.1 and (C-REF(C,1))>0,7,0);
IF (BARSTATUS=2 and c<200 and W7) THEN
DRAWTEXTABS(0,110,' ◢'+W7+'◣ '),colorFFCC00,LINETHICK2,LAYER0;
DRAWTEXTABS(0,110,' 【卖出】:-- 7.量平价跌,继续卖出。'),colorFFCC00,LINETHICK2,LAYER0;
W8:=IF((V-REF(V,1))>0 and (C-REF(C,1))<0,8,0);
IF (BARSTATUS=2 and c<200 and W8) THEN
DRAWTEXTABS(0,127,' ◢'+W8+'◣ '),colorFF9900,LINETHICK2,LAYER0;
DRAWTEXTABS(0,127,' 【观望】:-- 8.量增价跌,弃卖观望。'),colorFF9900,LINETHICK2,LAYER0;

大智慧量价增减指标公式

 

相关文章