在线检测未来函数

通达信股舞买卖MACD指标公式

来源:Internet,编辑:股旁网,2012-01-04

VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=EXPMA(EXPMA(EXPMA(VAR1,4),4),4);
J: (VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
D: MA(J,3);
K: MA(J,1);
DRAWICON(J>=REF(J,1),J,1);
DRAWICON(J<=REF(J,1),D,2); VC:=(REF(C,2)*REF(V,2)+REF(C,1)*REF(V,1)+C*V)/(V+REF(V,1)+REF(V,2)),NODRAW;
SQX:=(VC-MA(VC,13))*100;
DIF:MA(SQX,5),COLORWHITE;
DEA:EMA(DIF,5),COLORYELLOW;
MACD:(DIF-DEA)*2,COLORSTICK;
低金:IF(CROSS(DIF,DEA) AND DIF<-0.1,15,DRAWNULL),COLORYELLOW,LINETHICK4,CROSSDOT;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二金:IF(CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,DRAWNULL),COLORFF00FF,LINETHICK4,CROSSDOT;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1)),NODRAW;
底背:IF(REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),40,DRAWNULL),COLORRED,LINETHICK4,CROSSDOT;
势:DRAWLINE(A1=0,DEA,底背,DEA,0),COLORGREEN;{,COLORRED;}
{www.gUPaNg.com 股旁网_最新股票指标公式}
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF),COLORWHITE;
顶背_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF
AND CROSS(DEA,DIF),66,DRAWNULL),COLORF08000,LINETHICK4,CROSSDOT;
压:DRAWLINE(A2=0,DEA,顶背,DEA,0),COLORFFBB99;
A3:=CROSS(DIF,DEA) AND DEA<0;
零下二金_:IF(FILTER(COUNT(A3,21)=2,10),53,DRAWNULL),COLORWHITE,LINETHICK4,CROSSDOT;
DRAWICON(J>=REF(J,1),J,1);
DRAWICON(J<=REF(J,1),D,2);

通达信股舞买卖MACD指标公式

 

相关文章