在线检测未来函数

通达信新益萌量能BS主图指标公式

来源:Internet,编辑:股旁网,2012-01-10

P1:=16;
能量:=SQRT(VOL)*(((C-(H+L)/2))/((H+L)/2));
平滑能量:=EMA(能量,P1);
能量惯性:=EMA(平滑能量,P1) ;
BUY2:=CROSS(平滑能量,能量惯性);
BUY3:=CROSS(能量,平滑能量) AND (平滑能量>能量惯性);
DRAWTEXT(BUY2 OR BUY3,L*0.99,'▲ '),COLORF00FF0,LINETHICK5;
SEL2:=CROSS(平滑能量 ,能量);
SEL3:=CROSS(能量惯性 ,平滑能量);
DRAWTEXT(能量<REF(能量,1) AND SEL2 AND 平滑能量>能量惯性,H*1.01,'ㄓ'),COLORGREEN,LINETHICK5;
DRAWTEXT(SEL3,H*1.015,'顶'),COLORGREEN,LINETHICK5;
卖线12:EMA(SLOPE(C,12)*12+C,21),LINETHICK3;
买线:EMA(C,2),COLORRED,LINETHICK1;
卖线:EMA(SLOPE(C,21)*21+C,42),COLORRED;
BUY:=CROSS(买线,卖线);
BUY1:=CROSS(买线,卖线12);
SEL:=CROSS(卖线,买线);
SEL1:=CROSS(卖线12,买线);
DRAWTEXT(BUY ,LOW-0.1,'▲B '),COLORF00FF0,LINETHICK5;
DRAWTEXT(BUY1 AND (CROSS(能量,能量惯性) OR 平滑能量>能量惯性),LOW-0.1,'▲B1 '),COLORGREEN,LINETHICK5;
DRAWTEXT(SEL,HIGH+0.1,'▼S'),COLORWHITE,LINETHICK5;
DRAWTEXT(SEL1,HIGH+0.4,'▼S1'),COLORGREEN,LINETHICK5;
VAR111:=REF(CLOSE,1);
VAR222:=SMA(MAX(CLOSE-VAR111,0),7,1)/SMA(ABS(CLOSE-VAR111),7,1)*100;
DRAWTEXT(FILTER(REF(VAR222,1)<20 AND VAR222>REF(VAR222,1),5),买线*0.99,'↖特准抄底'),COLORGREEN;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9.5,买线*0.96,'↖红柱抄底'),COLORRED;
{www.gUPaNg.com 股旁网_最新股票指标公式}
红柱抄底:=CROSS(BIAS,乖离) AND 乖离<-9.5;
特准抄底:=FILTER(REF(VAR222,1)<20 AND VAR222>REF(VAR222,1),5);
{合成买进}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
买:=IF("KDJ.J"<0,10,0);
条件:=CROSS(9.9,买);
VAR1111:=(2*CLOSE+HIGH+LOW)/4;
VAR2222:=LLV(LOW,5);
VAR3333:=HHV(HIGH,5);
VAR4444:=EMA((VAR1111-VAR2222)/(VAR3333-VAR2222)*100,5);
MA11:=MA(VAR4444,2);
AA:=STICKLINE(VAR4>MA11,VAR4,MA11,3,1),COLORRED;
BBB:=STICKLINE(VAR4>MA11 AND REF(VAR4,1)<30,VAR4,MA11,3,1),COLORRED;
DRAWICON(CROSS(9.9,买),C,1);
STICKLINE(CROSS(9.9,买),H*1.01,H,3,1),COLORYELLOW;
XXX:=STICKLINE(BBB ,H*1.01,H,3,1),COLORYELLOW;
STICKLINE(FILTER(XXX ,5) ,C*0.9,L,3,1),COLORYELLOW;

通达信新益萌量能BS主图指标公式

 

相关文章