在线检测未来函数

通达信牛金趋势指标公式

来源:Internet,编辑:股旁网,2012-01-18

NUM:=13;SHORT:=3;LONG:=5;
LC:=REF(C,1);
WRSI:=SUM(MAX(C-LC,0),6)/SUM(ABS(C-LC),6)*100;
AAA:=CROSS(WRSI,20);
VAR1:=3;
VAR2:=(3)*(SMA(((C-LLV(L,27))/(HHV(H,27)-LLV(L,27)))*(100),5,1))-(2)*(SMA(SMA(((C-LLV(L,27))/(HHV(H,27)-LLV(L,27)))*(100),5,1),3,1));
BBB:=IF(CROSS(VAR2,VAR1),100,0);
YXT:=AAA AND BBB;
牛熊线:(LLV(REF(L,1),2)+(HHV(REF(H,1),2)-LLV(REF(L,1),2))/2),COLOR005BF5,NODRAW;
DRAWTEXT(YXT,-0.8,'*牛*'),COLORFFFFFF;
STICKLINE(YXT,0,15,1,0 ),COLORFFFFFF;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
公式一:=(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)));
DIFF:= EMA(CLOSE,10) - EMA(CLOSE,22);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
公式二:=CROSS(MACD,REF(MACD,1) ) AND REF(MACD,1)<0;
VAR3:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR3-VAR4)/(VAR5-VAR4))*100),4));
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2));
公式三:=CROSS(C1,C2) AND C2<60;
{www.gUPaNg.com 股旁网_最新股票指标公式}
马:(公式一+公式二+公式三)>=2,COLORYELLOW,NODRAW;
STICKLINE(马,0,8,1,0 ),COLORYELLOW;
DRAWTEXT(马,-0.8,'*马*'),COLORYELLOW;
ZF:=(C/REF(C,1)-1)*100;
趋势:SUM(ZF,3),COLORMAGENTA,LINETHICK2;
IF(趋势>REF(趋势,1) AND 趋势>=0,趋势,DRAWNULL),COLORRED,LINETHICK2;
IF(趋势<REF(趋势,1) AND 趋势>0,趋势,DRAWNULL),COLORCYAN,LINETHICK2;
超涨:IF(MA(ZF,3)>=5,15,0),COLOR0000FF;
WK:=趋势=LLV(趋势,4) AND 趋势-HHV(趋势,4)<=0-20 AND HHV(趋势,4)>=8;
挖坑:IF(WK,0-10,0),COLORGREEN;
超跌:IF(MA(ZF,3)<=0-5,0-15,0),COLORBLUE;
CZSJ:=BARSLAST(超涨=15);
CDSJ:=BARSLAST(超跌=0-15);
CZQY:=CZSJ<=8 AND CZSJ<=CDSJ AND COUNT(MA(趋势,3)>=0-5,CZSJ)=CZSJ;
CDQY:=CDSJ<=8 AND CDSJ<=CZSJ AND COUNT(MA(趋势,3)<=5,CDSJ)=CDSJ;
关注期:IF(CZQY,CZSJ+1,0),COLORYELLOW,POINTDOT;
跟踪期:IF(CDQY,0-CDSJ-1,0),COLORWHITE,POINTDOT;
STICKLINE(CZQY,REF(趋势,CZSJ),REF(趋势,CZSJ),3,1),COLORYELLOW;
STICKLINE(CDQY,REF(趋势,CDSJ),REF(趋势,CDSJ),3,1),COLORWHITE;

通达信牛金趋势指标公式

 

相关文章