在线检测未来函数

通达信量变资金趋势指标公式

来源:Internet,编辑:股旁网,2012-01-18

{量变}
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
量变1:= EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
量变2: STICKLINE(量变1>0,0,量变1,4,1);
量变: 量变1;
STICKLINE(量变1>0,0,量变*1.2,8,0) COLOR0000FF;
STICKLINE(量变1>0,0,量变*0.8,8,0) COLOR0066FF;
STICKLINE(量变1>0,0,量变*0.6,8,0) COLOR0099FF;
STICKLINE(量变1>0,0,量变*0.4,8,0) COLOR00CCFF;
STICKLINE(量变1>0,0,量变*0.2,8,0) COLOR00FFFF;
{大单动向}
DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7);
DDX1:=EMA(DDX,60)*60;
DDX2:=MA(DDX1,5);
DDX3:=MA(DDX1,10);
{追击反转}
AA1:=FILTER(LOW=LLV(LOW,13),8);
AA2:=IF(LLV(LOW,3)=LLV(LOW,13) AND CLOSE<REF((HIGH+LOW)/2,1),MAX(REF(LLV(LOW,12),BARSLAST(AA1)+1)-LOW,0),0);
AA3:=EMA(AA2,3)*50;
AA4:=SUMBARS(AA3>0,21);
AA5:=SUM(AA3,AA4)/21;
ISUP:=IF(C>0,1,0);
AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(CLOSE/REF(CLOSE,1)
<0.9025,8)=0 AND ISUP AND LLV(LOW,3)/HHV(HIGH,18)<0.88;
AA7:=(COUNT(DDX>0,5)>0 OR NOT(DDX1<DDX2 AND DDX2<DDX3))
AND COUNT(DDX>REF(DDX,1),10)>=4;
反转:=FILTER(AA6 AND AA7,5);
{www.gUPaNg.com 股旁网_最新股票指标公式}
追突:IF( CLOSE,AA3,0),COLOR0099EE,NODRAW;
追转:IF( 反转,AA3,0),COLORRED,NODRAW;
{深黄}
STICKLINE( CLOSE,0,AA3,2.8,0),COLOR0066BB;
STICKLINE( CLOSE,0,AA3,2.5,0),COLOR0077CC;
STICKLINE( CLOSE,0,AA3,1.5,0),COLOR0088DD;
STICKLINE( CLOSE,0,AA3,0.5,0),COLOR0099EE;
{深红}
STICKLINE( 反转,0, AA3,3,0),COLOR0000CC;
STICKLINE( 反转,0, AA3,2.5,0),COLOR0000DD;
STICKLINE( 反转,0, AA3,1.5,0),COLOR0000EE;
STICKLINE( 反转,0, AA3,0.5,0),COLOR0000FF;
{主力出场}
VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR12:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
VAR13:=EMA(VAR12,10);
VAR14:=HHV(H,33);
VAR15:=EMA(IF(H>=VAR14,VAR13,0),3);
主出场:IF(VAR15<REF(VAR15,1),VAR15,0),COLORGREEN,NODRAW;
出货:IF(VAR15<REF(VAR15,1),VAR15,0),COLOR00BB99,NODRAW;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,0 ),COLOR005500;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.6,0 ),COLOR007700;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.1,0 ),COLOR009900;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,1.5,0 ),COLOR00BB00;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.9,0 ),COLOR00DD00;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.3,0 ),COLOR00FF00;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,0),COLOR005580;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,2.6,0),COLOR007780;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,2.1,0),COLOR009980;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,1.5,0),COLOR00BB80;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.9,0),COLOR00DD80;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.3,0),COLOR00FF80;
{资金进出}
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,89);
ZJLRQD:=ZZLKP-ZZLJJ;
AA:=EMA(ZJLRQD,3);
BB:=EMA(AA,5);
资金进场:IF(CROSS(AA,BB),3,0),STICK,LINETHICK3,COLORMAGENTA;
STICKLINE(资金进场,15,0,0.8,1),COLORMAGENTA;
资金出场:IF(CROSS(BB,AA),3,0),STICK,LINETHICK3,COLORCYAN;
STICKLINE(资金出场,15,0,0.8,1),COLORCYAN;
{资金累计}
MYD:=MIN(LARGEINTRDVOL,60);
资金:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*VOL/CAPITAL;
累计资金:=EMA(资金,MYD)*MYD;
主力资金:=EMA(累计资金,10);
累计主资:CROSS(累计资金,主力资金),COLORBLUE,NODRAW;
DRAWTEXT(累计主资,15,'★'),COLORBLUE,LINETHICK3;
{主力潜伏}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
主力潜伏:COUNT(MACD<0,10)=10,COLORLIMAGENTA,NODRAW;
STICKLINE(主力潜伏,0,MACD*15,8,0),COLORLIMAGENTA;
N:=14;
M:=156;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.15*AVEDEV(TYP,N)),COLORWHITE,NODRAW;
-10,COLOR1C1C1C;
-10,STICK,COLOR1C1C1C;
5,COLOR1C1C1C;
5,STICK,COLOR1C1C1C;

通达信量变资金趋势指标公式

 

相关文章