在线检测未来函数

通达信MACD+KDJ完美同图指标公式

来源:Internet,编辑:股旁网,2012-01-22

STICKLINE(C>0,0,10,5,0),COLOR222222;
STICKLINE(C>0,100,90,5,0),COLOR222222;
DLCL:=CROSS(0.9,"KDJ.J"<0);
STICKLINE(DLCL,9,1,3,0),COLOR353500;
STICKLINE(DLCL,9,1,2.5,0),COLOR454500;
STICKLINE(DLCL,9,1,2,0),COLOR555500;
STICKLINE(DLCL,9,1,1.5,0),COLOR656500;
STICKLINE(DLCL,9,1,1,0),COLOR757500;
STICKLINE(DLCL,9,1,0.5,0),COLOR858500;
DLMC:="KDJ.K">80 AND "KDJ.D">80 AND CROSS("KDJ.D","KDJ.K");
STICKLINE(DLMC,91,99,3,0),COLOR353500;
STICKLINE(DLMC,91,99,2.5,0),COLOR454500;
STICKLINE(DLMC,91,99,2,0),COLOR555500;
STICKLINE(DLMC,91,99,1.5,0),COLOR656500;
STICKLINE(DLMC,91,99,1,0),COLOR757500;
STICKLINE(DLMC,91,99,0.5,0),COLOR858500;
{C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");}
C1:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D1:=REF(C,C1+1)<C AND REF("KDJ.K",C1+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
STICKLINE(D1>0 ,99,91,3,0),COLOR555555;
STICKLINE(D1>0 ,99,91,2.5,0),COLOR777777;
STICKLINE(D1>0 ,99,91,2,0),COLOR999999;
STICKLINE(D1>0 ,99,91,1.5,0),COLORBBBBBB;
STICKLINE(D1>0 ,99,91,1,0),COLORDDDDDD;
STICKLINE(D1>0 ,99,91,0,0),COLORFFFFFF;
{www.gupang.com 股旁网_股票通达信指标公式}
LAW1:=MA(INDEXC,13)/INDEXC;
TJ1:=LAW1>1.05;
LAW3:=(C-MA(C,60))/MA(C,60)*100;
STICKLINE(PERIOD=5 && LAW3<-24 AND TJ1,0,2,3,0),COLOR006600;
STICKLINE(PERIOD=5 && LAW3>24,100,98,3,0),COLOR006600;
N:=9;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1),COLOR444444;
D:=SMA(K,3,1),COLOR666633;
J:3*K-2*D,COLOR444444;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
KX:=BARSSINCE(CLOSE);
HK:=HHV(K,KX);
HD:=HHV(D,KX);
HJ:=HHV(J,KX);
LK:=LLV(K,KX);
LD:=LLV(D,KX);
LJ:=LLV(J,KX);
HKMAX:=MAX(HK,MAX(HD,HJ));
LKMIN:=MIN(LK,MIN(LD,LJ));
KDBL:=(HKMAX+LKMIN)/2;
KDC:=HKMAX-LKMIN;
MHF:=HHV(DIFF,KX);
MHD:=HHV(DEA,KX);
MHM:=HHV(MACD,KX);
MLF:=LLV(DIFF,KX);
MLD:=LLV(DEA,KX);
MLM:=LLV(MACD,KX);
HMAX:=MAX(MHF,MAX(MHD,MHM));
LMIN:=MIN(MLF,MIN(MLD,MLM));
FDBL:=(HMAX+LMIN)/100;
FDC:=HMAX-LMIN;
SH:=(0-FDBL)*(KDC/FDC)+KDBL;
DF:(DIFF-FDBL)*(KDC/FDC)+KDBL,COLORA68064;{COLORWHITE};
DA:(DEA-FDBL)*(KDC/FDC)+KDBL,COLORGRAY{COLORA8A8A8;COLORYELLOW};
MACDA:=(MACD-FDBL)*(KDC/FDC)+KDBL;
CDA:=MACD<REF(MACD,1) AND MACD>0;
CDB:=MACD>=REF(MACD,1) AND MACD>0;
CDC:=MACD>REF(MACD,1) AND MACD<0;
CDD:=MACD<=REF(MACD,1) AND MACD<0;
STICKLINE(CDB,50,(MACDA-SH)+50,1,0),COLOREE00EE;
STICKLINE(CDA,50,(MACDA-SH)+50,1,0),{COLOR00DDDD}COLOR3299CC;
STICKLINE(CDC,50,(MACDA-SH)+50,1,0),{COLORAA11BB}COLORCC3299{COLOR9370DB};
STICKLINE(CDD,50,(MACDA-SH)+50,1,0),COLOR666633;

通达信MACD+KDJ完美同图指标公式

 

相关文章