在线检测未来函数

通达信主力进出增强版指标公式

来源:Internet,编辑:股旁网,2012-01-28

{PP超级资金流}
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*200;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*200;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
散户套牢线1:=INTPART(ZSHTL),COLORFFEEBB,LINETHICK2;
主力控盘线1:=INTPART(ZZLKP),COLOR4D4DFF,LINETHICK2;
DRAWBAND(主力控盘线1,RGB(0,255,255),散户套牢线1,RGB(50,50,50));
{柱状线}
STICKLINE(((主力控盘线1>REF(主力控盘线1,1)) AND (主力控盘线1>100)),主力控盘线1,散户套牢线1,2,0),COLOR8000FF;
{www.gupang.com 股旁网_股票通达信指标公式}
散:INTPART(ZSHTL),COLORFFEEBB,LINETHICK2;
主力:INTPART(ZZLKP),COLOR4D4DFF,LINETHICK2;
{主力监控}
B1:=(HHV(H,35)-C)/(HHV(H,35)-LLV(LOW,35))*100-35;
B2:=SMA(B1,35,1)+100;
B3:=(C-LLV(L,35))/(HHV(H,35)-LLV(L,35))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
控盘程度:(IF(B6>1,B6-1,0))*2.5,COLORRED,LINETHICK2;
控盘度:100,COLORWHITE;
{柱状线}
控盘上:IF(控盘程度>REF(控盘程度,1), 控盘程度,DRAWNULL),
STICK,COLORYELLOW,LINETHICK1;
控盘下:IF(控盘程度<REF(控盘程度,1), 控盘程度,DRAWNULL),
STICK,COLORFF9900,LINETHICK1;
进:IF(控盘程度>REF(控盘程度,1),5,DRAWNULL),CIRCLEDOT,COLORYELLOW;
出:IF(控盘程度<REF(控盘程度,1),5,DRAWNULL),CIRCLEDOT,COLORFF9900;
{PP超大主力吃}
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*20;
超大主力吃:IF(V4>=0,V4,0)+100,COLOR7F00FF,LINETHICK3;
超大主力吐:IF(V4<=0,V4,0)+100,COLOR66FF00,LINETHICK2;
{SAR}
持币:IF(SAR(10,2,20)>=H,100,DRAWNULL),CIRCLEDOT,COLORBLUE;
持股:IF(SAR(10,2,20)<=L,100,DRAWNULL),CIRCLEDOT,COLORRED;

通达信主力进出增强版指标公式

 

相关文章