在线检测未来函数

通达信倍量自动画线主图指标公式

来源:Internet,编辑:股旁网,2012-01-28

N:=3;
DRAWKLINE(H,O,L,C);
黄金柱:=V/REF(V,1)>=1.9;
K1:=SUMBARS(黄金柱,1) ;
K2:=SUMBARS(黄金柱,2);
K3:=SUMBARS(黄金柱,3);
K4:=SUMBARS(黄金柱,4);
K5:=SUMBARS(黄金柱,5);
K6:=SUMBARS(黄金柱,6);
K7:=SUMBARS(黄金柱,7);
K8:=SUMBARS(黄金柱,8);
K9:=SUMBARS(黄金柱,9);
K10:=SUMBARS(黄金柱,10);
AA:STICKLINE(K1,REF(L,K1-1)*1.002,REF(L,K1-1),5,0),COLORYELLOW;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:=R1>REF(R1,1);
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1);
短期压力:DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;
短期支撑:DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
BUY:=ZIG(3,10);
SELL:=MA(BUY,2);
DRAWICON(CROSS(BUY,SELL),L-0.1,7);
DRAWICON(CROSS(SELL,BUY),H+0.1,8);
收盘快线:(10* MA(C,3)+9*REF(MA(C,3),1)+8*REF(MA(C,3),2)+
7*REF(MA(C,3),3)+6*REF(MA(C,3),4)+5*REF(MA(C,3),5)+
4*REF(MA(C,3),6)+3*REF(MA(C,3),7)+2*REF(MA(C,3),8)+
REF(MA(C,3),9))/56 COLORLIGREEN;
收盘快线3:(10* MA(C,3)+9*REF(MA(C,3),1)+8*REF(MA(C,3),2)+
7*REF(MA(C,3),3)+6*REF(MA(C,3),4)+5*REF(MA(C,3),5)+
4*REF(MA(C,3),6)+3*REF(MA(C,3),7)+2*REF(MA(C,3),8)+
REF(MA(C,3),9))/58 COLORD9D919;
收盘快线1:(10* MA(C,3)+9*REF(MA(C,3),1)+8*REF(MA(C,3),2)+
7*REF(MA(C,3),3)+6*REF(MA(C,3),4)+5*REF(MA(C,3),5)+
4*REF(MA(C,3),6)+3*REF(MA(C,3),7)+2*REF(MA(C,3),8)+
REF(MA(C,3),9))/60 COLORYELLOW;
收盘快线2:(10* MA(C,3)+9*REF(MA(C,3),1)+8*REF(MA(C,3),2)+
7*REF(MA(C,3),3)+6*REF(MA(C,3),4)+5*REF(MA(C,3),5)+
4*REF(MA(C,3),6)+3*REF(MA(C,3),7)+2*REF(MA(C,3),8)+
{www.gupang.com 股旁网_股票通达信指标公式}
REF(MA(C,3),9))/63 COLORA67D3D;
高区18:IF(CURRBARSCOUNT<=18, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=18)),0)),DRAWNULL),COLORYELLOW;
低区18:IF(CURRBARSCOUNT<=18, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=18)),0)),DRAWNULL),COLORYELLOW;

通达信倍量自动画线主图指标公式

 

相关文章