在线检测未来函数

大智慧牛股指标公式

来源:Internet,编辑:股旁网,2012-01-31

短线:=9;中线:=9;周期:=15;过滤:=8;选股:=-26;抄底:=-30;
VAR11102:=MA(CLOSE,5);
VAR11103:=MA(CLOSE,10);
VAR11104:=MA(CLOSE,20);
VAR11105:=MA(CLOSE,30);
VAR11106:=(VAR11102 + VAR11103 + VAR11104 + VAR11105)/(4);
VAR11107:=((VAR11106 - REF(VAR11106,周期))/(REF(VAR11106,周期)))*(100);
VAR11108:=((VAR11106 - REF(VAR11106,周期))/(REF(VAR11106,周期)))*(100);
VAR11109:=EMA(VAR11107,过滤);
小买:=IF((TROUGHBARS(3,15,1) = 0) and (HIGH > LOW + 0.01) and (DATE <= 108088515),50,0);
VAR111010:=((CLOSE - MA(CLOSE,58))/(MA(CLOSE,58)))*(100);
VAR111011:=((VAR111010 > (1)*(REF(VAR111010,1))) and (VAR111010 < 选股) and (VAR111010 > 抄底))*(1.5);
VAR111012:=((VOL)/(CAPITAL))*(100);
VAR111013:=LLVBARS(LOW,50);
VAR111014:=SUM(VOL,VAR111013);
VAR111015:=HHVBARS(HIGH,50);
VAR111016:=SUM(VOL,VAR111015);
VAR111017:=((CLOSE - REF(OPEN,VAR111015))/(REF(OPEN,VAR111015)))*(100);
VAR111018:=((VAR111016)/(CAPITAL))*(100);
VAR111019:=((CLOSE - REF(OPEN,VAR111013))/(REF(OPEN,VAR111013)))*(100);
VAR111020:=((VAR111014)/(CAPITAL))*(100);
VAR111021:=MA(CLOSE,3);
VAR111022:=(REF(CLOSE,2))*(0.865);
VAR111023:=(REF(CLOSE,13))*(0.772);
VAR111024:=MIN(VAR111022,VAR111023);
VAR111025:=MA(CLOSE,13);
大买:=(IF(((CLOSE - VAR111024)/(CLOSE) < 0.03) and (VAR111017 < (-35)) and ((SUM(VAR111012,5))/(5) < 1.8) and (DATE <= 108880515),1,0))*(100);
豪买:IF((大买 = 100) and (小买 = 50) and (DATE <= 108880515),168,0),COlorred;
DRAWTEXT((豪买 = 168),175,' 豪买'),COlorred;
VAR111026:=((CLOSE - REF(CLOSE,1))/(REF(CLOSE,1)))*(100);
VAR111027:=(EMA(CLOSE,12) - EMA(CLOSE,26))*(100);
VAR111028:=EMA(VAR111027,9);
VAR111029:=(2)*(VAR111027 - VAR111028);
VAR22:=MA(CLOSE,5);
VAR23:=MA(CLOSE,10);
VAR24:=MA(CLOSE,30);
VAR25:=MA(CLOSE,60);
VAR26:=EMA(COST(85),7);
VAR27:=EMA(COST(15),7);
VAR60:=(SUM(((CLOSE)*(VOL))*(100),4))/(SUM((VOL)*(100),4));
VAR61:=(INTPART((VAR60)*(100)))/(100);
VAR62:=(SUM(((CLOSE)*(VOL))*(100),7))/(SUM((VOL)*(100),7));
VAR63:=(INTPART((VAR62)*(100)))/(100);
VAR64:=(SUM(((CLOSE)*(VOL))*(100),28))/(SUM((VOL)*(100),28));
VAR65:=(INTPART((VAR64)*(100)))/(100);
B:=IF((DATE <= 108880515),EMA(CLOSE,5) - EMA(CLOSE,10),0);
A:=IF((DATE <= 108088515),EMA(B,中线),0);
VAR28:=(((-100))*(HHV(CLOSE,5) - CLOSE))/(HHV(CLOSE,5) - LLV(LOW,5)) + 100;
VAR29:=(((-100))*(HHV(CLOSE,10) - CLOSE))/(HHV(CLOSE,10) - LLV(LOW,10)) + 100;
VAR30:=(((-100))*(HHV(CLOSE,20) - CLOSE))/(HHV(CLOSE,20) - LLV(LOW,20)) + 100;
VAR31:=(((-100))*(HHV(CLOSE,30) - CLOSE))/(HHV(CLOSE,30) - LLV(LOW,30)) + 100;
VAR32:=REF(A,1);
VAR33:=A;
VAR34:=VAR33 - VAR32;
VAR35:=REF(B,1);
VAR36:=B;
VAR37:=VAR36 - VAR35;
VAR50:=OPEN;
VAR51:=CLOSE;
小牛:IF((VAR50 <= VAR22) and (VAR50 <= VAR23) and (VAR50 <= VAR24) and (VAR51 >= VAR22) and (VAR51 >= VAR65) and (VAR34 > 0) and (VAR37 > 0) ,100,0),COlorred;
短买:=(IF(CROSS(B,A) and (B < 0) and (A < (-0.2)) and (VAR29 > 45) and (VAR34 > 0) ,100,0))*(1);
VAR3:=MA(CLOSE,13);
VAR4:=100 - ABS(((CLOSE - VAR3)/(VAR3))*(100));
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6 - VAR5)/(100);
VAR8:=SMA((CLOSE - VAR5)/(VAR7),20,1);
VAR9:=SMA((OPEN - VAR5)/(VAR7),20,1);
VARA:=(3)*(VAR8) - (2)*(SMA(VAR8,15,1));
VARB:=(3)*(VAR9) - (2)*(SMA(VAR9,15,1));
VARC:=100 - VARB;
VARD:=(REF(LOW,1))*(0.9);
VARE:=(LOW)*(0.9);
VARF:=((VARE)*(VOL) + (VARD)*(CAPITAL - VOL))/(CAPITAL);
VAR10:=EMA(VARF,30);
VAR11:=CLOSE - REF(CLOSE,1);
VAR12:=MAX(VAR11,0);
VAR13:=ABS(VAR11);
VAR14:=((SMA(VAR12,7,1))/(SMA(VAR13,7,1)))*(100);
VAR15:=((SMA(VAR12,13,1))/(SMA(VAR13,13,1)))*(100);
VAR16:=BARSCOUNT(CLOSE);
VAR17:=((SMA(MAX(VAR11,0),6,1))/(SMA(ABS(VAR11),6,1)))*(100);
VAR18:=(((-200))*(HHV(HIGH,60) - CLOSE))/(HHV(HIGH,60) - LLV(LOW,60)) + 100;
VAR19:=((CLOSE - LLV(LOW,15))/(HHV(HIGH,15) - LLV(LOW,15)))*(100);
VAR1A:=SMA((SMA(VAR19,4,1) - 50)*(2),3,1);
VAR1B:=((INDEXC - LLV(INDEXL,14))/(HHV(INDEXH,14) - LLV(INDEXL,14)))*(100);
VAR1C:=SMA(VAR1B,4,1);
VAR1D:=SMA(VAR1C,3,1);
VAR1E:=((HHV(HIGH,30) - CLOSE)/(CLOSE))*(100);
VAR1F:=((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100);
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
趋势:=IF((DATE <= 108880515),SMA(VAR21,3,1),0);
人气:=IF((DATE <= 108880515),SMA(趋势,3,1),0);
波买:IF(CROSS(趋势,人气) and (趋势 < 30) and (DATE <= 10880515),100,0),Linethick1,COlorred;
波卖:IF(CROSS(人气,趋势) and (人气 > 75) and (DATE <= 10880515),148,210),Linethick1,COlorFFFFFF;
短买15:=MA(短买,15);
波买15:=MA(波买,15);
小牛15:=MA(小牛,15);
短买和牛15:=MA(小牛,15) + MA(短买,15);
波买和牛15:=MA(小牛,15) + MA(波买,15);
短买和波买5:=MA(短买,5) + MA(波买,5);
大疯牛:IF((短买 - 短买15 = 100 - ((100)/(15))*(2)) or (波买 - 波买15 = 100 - ((100)/(15))*(2)) or (小牛 - 小牛15 = 100 - ((100)/(15))*(2)) or (小牛 - 短买和牛15 = 100 - ((100)/(15))*(2)) or (小牛 - 波买和牛15 = 100 - ((100)/(15))*(2)) or (波买 - 短买和波买5 = 60) and (DATE <= 108880515),168,0),COlorred;
DRAWTEXT((小牛 = 100),100,'小牛'),COlorred;
DRAWTEXT(CROSS(趋势,人气) and (趋势 < 30),100,'波买'),COlorred;
DRAWTEXT(CROSS(人气,趋势) and (人气 > 75),150,'波卖'),COloryellow;
DRAWTEXT((大疯牛 = 168),175,'大疯牛'),COlorred;
VAR81:=100 - (3)*(SMA(((CLOSE - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1)) + (2)*(SMA(SMA(((CLOSE - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1),15,1));
VAR82:=100 - (3)*(SMA(((OPEN - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1)) + (2)*(SMA(SMA(((OPEN - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1),15,1));
VAR83:=(VAR81 < REF(VAR82,1)) and (VOL > REF(VOL,1)) and (CLOSE > REF(CLOSE,1));
主力:IF(VAR83 and (COUNT(VAR83,30) = 1),100,0),Linethick1,COlorFF0000;
DRAWTEXT((主力 = 100),110,'主力'),COloryellow;
豪买和主力10:=MA(豪买,10) + MA(主力,10);
大疯牛和主力10:=MA(大疯牛,10) + MA(主力,10);
顶级牛:IF((主力 - 豪买和主力10 <= 73.2) and (主力 - 豪买和主力10 > 1) or (主力 - 大疯牛和主力10 <= 73.2) and (主力 - 大疯牛和主力10 > 1) or (大疯牛 - 大疯牛和主力10 <= 141.2) and (大疯牛 - 大疯牛和主力10 > 1) or (豪买 - 豪买和主力10 <= 141.2) and (豪买 - 豪买和主力10 > 1) and (DATE <= 108880515),208,0),COlorred;
DRAWTEXT((顶级牛 = 208),215,'顶级牛'),COloryellow;
VAR201:=SUM(MAX(MAX(HIGH - LOW,ABS(HIGH - REF(CLOSE,1))),ABS(LOW - REF(CLOSE,1))),25);
VAR202:=HIGH - REF(HIGH,1);
VAR203:=REF(LOW,1) - LOW;
VAR204:=SUM(IF((VAR202 > 0) and (VAR202 > VAR203),VAR202,0),25);
VAR205:=SUM(IF((VAR203 > 0) and (VAR203 > VAR202),VAR203,0),25);
VAR206:=((VAR204)*(100))/(VAR201);
VAR207:=((VAR205)*(100))/(VAR201);
VAR208:=MA(((ABS(VAR207 - VAR206))/(VAR207 + VAR206))*(100),15);
VAR209:=(VAR208 + REF(VAR208,15))/(2);
{www.gupang.com 股旁网_股票大智慧指标公式}
AA:=(VAR207 > VAR206) and (VAR207 > 25) and (VAR206 < 25);
AB:=(ZIG(3,(50)/(5)))*(100);
AG:=MA(AB,2);
AD:=(CROSS(AB,AG))*(1000);
AW:=(CROSS(AG,AB))*(1000);
AE:=REF(INDEXC,1);
AF:=(SMA(MAX(INDEXC - AE,0),3,1))/(SMA(ABS(INDEXC - AE),3,1));
VAR210:=AF and (AF < 8);
VAR211:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
VAR212:=SMA(VAR211,3,1);
VAR213:=SMA(VAR212,3,1);
VAR214:=VAR213 and (VAR213 < 20);
MM:=AA and AD and VAR210 and VAR214;
决买:IF((AD = 1000) ,68,0),COlorFF0000;
决卖:IF((AW = 1000),138,210),COloryellow;
DRAWTEXT((决买 = 68),75,'决买'),COlorFF0000;
DRAWTEXT((决卖 = 138),130,'决卖'),COloryellow;

大智慧牛股指标公式

 

相关文章