在线检测未来函数

飞狐精准买卖主图指标公式

来源:Internet,编辑:股旁网,2012-02-03

趋势1:EMA(EMA(EMA(EMA(CLOSE,3),3),3),3),COLOR0000FF;
趋势2:EMA(REF(趋势1,1),3),COLOR00FFFF;
趋势3:EMA(EMA(EMA(EMA(EMA(CLOSE,65),3),3),3),3),COLORFF0000;
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20 +CLOSE,42);
BU:=CROSS(买线,卖线) ;
SEL:=CROSS(卖线,买线) ;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VAR21:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100 +(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100 + (CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
大顶:=FILTER(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),5);
VAR1Q:=(OPEN+LOW+HIGH+CLOSE)/4;
MAN:=SMA(HIGH,21,2)*1.05;
短底2:=EMA(VAR1Q,5);
支撑:=HHV(短底2,60);
VAR4M:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR5M:=SMA(VAR4M,5,1);
VAR6M:=SMA(VAR5M,8,1);
VAR7M:=CROSS(VAR5M,VAR6M) AND VAR6M<5;
VAR8M:=CLOSE >(LLV(CLOSE,60)+0.3*LLV(CLOSE,60)) AND VAR7M;
VAR9M:=IF(CLOSE>1000,VAR7M,VAR8M);
黑马起步:=VAR9M;
短期底部:=LLV(HIGH,30)*0.93;
逃:=FILTER((HIGH>支撑) AND (CLOSE<支撑) AND CLOSE/OPEN > (0-1.06) AND CLOSE<OPEN,5) ;
逃命:=黑马起步>0 ;
选逃:=FILTER(逃命 OR 逃 OR CROSS(84,RSI) OR 大顶,3) ;
STICKLINE(买线>=卖线,LOW,HIGH,1,0),COLOR0000FF;
STICKLINE(买线>=卖线,CLOSE,OPEN,4.5,0),COLOR0000AA;
STICKLINE(买线>=卖线,CLOSE,OPEN,4,0),COLOR0000CC;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),COLOR0000EE;
STICKLINE(买线<卖线,CLOSE,OPEN,4.5,0),COLORAAAA00;
STICKLINE(买线<卖线,CLOSE,OPEN,4,0),COLORBBBB00;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORCCCC00;
STICKLINE(买线<卖线,CLOSE,OPEN,2,0),COLOREEEE00;
STICKLINE(买线<卖线,LOW,HIGH,1,0),COLORFFFF00;
DRAWTEXT(选逃,HIGH*1.03,'逃'),COLOR00FFFF;
DRAWTEXT(BU,LOW*0.996,'买'),COLOR0000FF;
DRAWTEXT(SEL,HIGH*1.02,'卖'),COLOR00FFFF;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),5);
主力进场:=FILTER(VAR5>REF(VAR5,1),5);
DRAWTEXT(FILTER(VAR5>REF(VAR5,1),5),LOW*0.995,'↑'),COLORFF0000;
DRAWTEXT(FILTER(VAR5>REF(VAR5,1),5),LOW*0.96,'主力'),COLORFF0000;
STICKLINE(FILTER(VAR5>REF(VAR5,1),5),CLOSE,OPEN,5,0),COLORFF0000;
STICKLINE(FILTER(VAR5>REF(VAR5,1),5),LOW,HIGH,1,0),COLORFF0000;
指數位置:= 3 * SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)- 2 * SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
抄底:=CROSS(指數位置,10) ;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,3,0),COLOR00FFFF;
STICKLINE(BU,MAX(CLOSE,OPEN)*0.995,MIN(CLOSE,OPEN)*1.005,2.5,0),COLOR0000FF;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR9:=CLOSE >(REF(HIGH,1)+REF(LOW,1))/2;
VAR10:=VAR8 AND VAR9;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=LLV(LOW,13);
VAR13:=HHV(HIGH,13);
VAR14:=LLV(LOW,1)=LLV(LOW,35) AND CLOSE>=OPEN*1.04;
VAR15:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
{www.gupang.com 股旁网_飞狐股票指标公式}
VAR16:=EMA((VAR11-VAR12)/(VAR13-VAR12)*100,13);
VARA:=EMA(0.667*REF(VAR16,1)+0.333*VAR16,2);
多:=VAR16;
空:=EMA(0.382*REF(VAR16,2)+0.618*VAR16,12);
A1:=VOL=HHV(VOL,120);
A2:=CLOSE/OPEN>1.05;
TJ:=A1 AND A2;
龙:=VAR10;
买4:=VAR14;
AA1:=AMOUNT/VOL;
BB1:=LOW<AA1*0.9;
CC1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:=LOW<MA(CLOSE,5)*0.921;
EE1:=VOL<MA(VOL,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
买3:=FILTER(FF1,3);
二十天最低跌幅:=HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)) *100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
买1:=CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3;
长期底部:=LLV(HIGH,30);
上:=SMA(LOW,5,2)*0.96;
选底:=FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN/1.03,3) ;
DRAWTEXT(IF(选底,100,0),LOW*0.95,'底'),COLOR399C71;
DRAWTEXT(IF(选底,100,0),LOW*0.995,'↑'),COLOR399C71;
STICKLINE(IF(选底,100,0),CLOSE,OPEN,5,0),COLOR399C71;
STICKLINE(IF(选底,100,0),LOW,HIGH,1,0),COLOR399C71;
选买:=FILTER(买3 OR 选底,3) AND COUNT(买1+ 买4+龙 ,3)>0 ;
STICKLINE(选买,HIGH,HHV(HIGH,90)*0.95,0.2,0),COLORFF0000;
DRAWTEXT(选买,HHV(HIGH,90)*1,'稳赚'),COLORFF0000;
DRAWTEXT(选买,HHV(HIGH,90)*0.97,'10%买'),COLORFF0000;

飞狐精准买卖主图指标公式

 

相关文章