在线检测未来函数

飞狐波神凯线二合一主图指标公式

来源:Internet,编辑:股旁网,2012-02-05

INPUT:最近天(60,1,360);{ 模糊调参数}
{一年时间之窗转折日}
当前月:=FRACPART(ROUND(当前日期/100)/100)*100,LINETHICK;
月:=MONTH;日:=DAY;
VERTLINE(月=1 AND ( 日=25)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=3 AND ( 日=20)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=5 AND ( 日=12)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=6 AND (日=14 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=19 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=6 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=18 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=10 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=28)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=1 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=2 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=3 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=4 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=5 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=6 AND ( 日=6 OR 日=21)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;

VERTLINE(月=10 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='1',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21、*25\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='2',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='3',c,NUMTOSTR(当前月,0)+'月转折日:6、15、*20、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='4',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='5',c,NUMTOSTR(当前月,0)+'月转折日:6、*1 2、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='6',c,NUMTOSTR(当前月,0)+'月转折日:6、*1 4、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='7',c,NUMTOSTR(当前月,0)+'月转折日:8、15、*1 9、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='8',c,NUMTOSTR(当前月,0)+'月转折日:*6、8、15、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='9',c,NUMTOSTR(当前月,0)+'月转折日:8、15、*1 8、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='10',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*31\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='11',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*28\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='12',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*31\n \n \n \n '),COLOR00FFFF,ALIGN5;
N:=最近天;
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
VN:=N;
{LAST1:=DATACOUNT;}
IF VN>DATACOUNT THEN
VN=DATACOUNT+1;
FOR I=DATACOUNT DOWNTO DATACOUNT-VN+1 DO BEGIN
HH[I]:=HH[DATACOUNT];
LL[I]:=LL[DATACOUNT];
END;
TMP:=SETLBOUND(hh,DATACOUNT-VN+1);
TMP:=SETLBOUND(ll,DATACOUNT-VN+1);
阶段高:HH,LINETHICK2,color0000FF;阶段低:LL,LINETHICK2,color00FF00;
中线:(HH+LL)/2;
KKH:=BARSLAST(H=HH);
KKL:=BARSLAST(L=LL);
N低日:=STRTONUM(NUMTOSTR(REF(DATE,KKL),0)),LINETHICK;
N高日:=STRTONUM(NUMTOSTR(REF(DATE,KKH),0)),LINETHICK;
多空:IF(N低日>N高日,2,1),LINETHICK;
多空天:IF(N低日<N高日,kkl,kkh),LINETHICK;
KLINE(O,H,L,C,0);
DATE1:=IF(多空=1,N低日,N高日);{}
hh0:=ref(h,BARSLAST(DATE1=DATE));
ll0:=ref(l,BARSLAST(DATE1=DATE));
H1:=STRTONUM(NUMTOSTR(Hh0,3)),POINTDOT;
L1:=STRTONUM(NUMTOSTR(Ll0,3)),POINTDOT;
PARTLINE(1,H1),,POINTDOT;
PARTLINE(1,L1),,POINTDOT;
LL:=H1 - L1;
VERTLINE(DATE=DATE1),COLORFFAAAA,,LINETHICK2;DRAWTEXT(DATE=DATE1,SYSPARAM(4)*0.95,'起\n \n始\n \n线'),COLORFFFFFF;
起始至今天:BARSLAST(DATE1=DATE),COLORFFFF00,LINETHICK;
涨幅:(C-REF(C,起始至今天))/REF(C,起始至今天)*100COLORFFDDDD,LINETHICK;
IF 多空=1 THEN BEGIN
{看多}
PARTLINE(DATE>=N低日,LL*1.50801 + L1),LINETHICK1,COLOREE99FF,LINEDOT;
PARTLINE(DATE>=N低日,LL*2.00001 + L1),COLOR9999FF,LINEDOT;
PARTLINE(DATE>=N低日,LL*2.40001 + L1),COLORFFFF99,LINEDOT;
PARTLINE(DATE>=N低日,LL*3.05001 + L1),COLOR99FF99,LINEDOT;
PARTLINE(DATE>=N低日,LL*3.75001 + L1),COLORFF9999,LINEDOT;
PARTLINE(DATE>=N低日,LL*4.15001 + L1),COLORMAGENTA,LINEDOT;
PARTLINE(DATE>=N低日,LL*4.80001 + L1),COLORRED,LINEDOT;
PARTLINE(DATE>=N低日,LL*5.50001 + L1),COLORCYAN,LINEDOT;
PARTLINE(DATE>=N低日,LL*6.10001 + L1),COLORGREEN,LINEDOT;
PARTLINE(DATE>=N低日,LL*6.90001 + L1),LINETHICK1,COLORRED,LINEDOT;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*1.50801+0.002,NUMTOSTR(L1+LL*1.50801,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.00001+0.002,NUMTOSTR(L1+LL*2.00001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.40001+0.002,NUMTOSTR(L1+LL*2.40001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.05001+0.002,NUMTOSTR(L1+LL*3.05001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.75001+0.002,NUMTOSTR(L1+LL*3.75001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.15001+0.002,NUMTOSTR(L1+LL*4.15001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.80001+0.002,NUMTOSTR(L1+LL*4.80001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*5.50001+0.002,NUMTOSTR(L1+LL*5.50001,2)),COLORAAAAAA,ALIGN2;DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.10001+0.002,NUMTOSTR(L1+LL*6.10001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.90001+0.002,NUMTOSTR(L1+LL*6.90001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(DATE=DATE1,LL*1.50801 + L1+0.002,'多开门'),color999fff;
DRAWTEXT(DATE=DATE1,LL*6.90001 + L1+0.002,'多关门'),color999fff;
END;
ELSE BEGIN
{看空}
PARTLINE(DATE>=N高日,H1-LL*1.50801),LINETHICK1,COLOREE99FF,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*2.00001),COLOR9999FF,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*2.40001),COLORFFFF99,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*3.05001),COLOR99FF99,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*3.75001),COLORFF9999,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*4.15001),COLORMAGENTA,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*4.80001),COLORRED,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*5.50001),COLORCYAN,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*6.10001),COLORGREEN,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*6.90001),LINETHICK1,COLORRED,LINEDOT;
DRAWTEXT(DATE=DATE1,H1-LL*1.50801+0.002,'空开门'),color3333FF;
DRAWTEXT(DATE=DATE1,H1-LL*6.90001+0.002,'空关门'),color3333FF;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*1.50801+0.002,NUMTOSTR(H1-LL*1.50801,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.00001+0.002,NUMTOSTR(H1-LL*2.00001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.40001+0.002,NUMTOSTR(H1-LL*2.40001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.05001+0.002,NUMTOSTR(H1-LL*3.05001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.75001+0.002,NUMTOSTR(H1-LL*3.75001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.15001+0.002,NUMTOSTR(H1-LL*4.15001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.80001+0.002,NUMTOSTR(H1-LL*4.80001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*5.50001+0.002,NUMTOSTR(H1-LL*5.50001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.10001+0.002,NUMTOSTR(H1-LL*6.10001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.90001+0.002,NUMTOSTR(H1-LL*6.90001,2)),COLORAAAAAA,ALIGN2;
END;
高年:=ref(YEAR,BARSLAST(date=N高日));
高月:=ref(MONTH,BARSLAST(date=N高日));
高日:=ref(DAY,BARSLAST(date=N高日));
低年:=ref(YEAR,BARSLAST(date=N低日));
低月:=ref(MONTH,BARSLAST(date=N低日));
低日:=ref(DAY,BARSLAST(date=N低日));
{www.gupang.com 股旁网_飞狐股票指标公式}
DRAWTEXT(SYSPARAM(2)=BARPOS,H1,'最近'+NUMTOSTR(最近天,0)+'天最高价日期:'+NUMTOSTR(高年,0)+'年'+NUMTOSTR(高月,0)+'月'+NUMTOSTR(高日,0)+'日'+'\n \n'
+'最近'+NUMTOSTR(最近天,0)+'天最低价日期:'+NUMTOSTR(低年,0)+'年'+NUMTOSTR(低月,0)+'月'+NUMTOSTR(低日,0)+'日'),COLORFFAAAA,ALIGN4;
DRAWTEXT(SYSPARAM(2)=BARPOS,H1,'\n \n\n \n \n \n注意 : 随时调整指标参数\n \n 调整过程会自动找到高低点'),COLOR00FFFF,ALIGN4;

飞狐波神凯线二合一主图指标公式

 

相关文章