在线检测未来函数

通达信资金轨迹主图指标公式

来源:Internet,编辑:股旁网,2012-02-06

DRAWTEXT(CROSS(0.94,(L/(MA(CLOSE,14) * 0.9))) AND C>L,L*0.9,'抄'),COLORWHITE;
DRAWICON(CROSS(0.94,(L/(MA(CLOSE,14) * 0.9))) AND C>L ,L-0.03,1);
DRAWTEXT(CROSS(0.94,(L/(MA(CLOSE,20) * 0.9))) AND C>L,L*0.9,'抄'),COLORGREEN;
DRAWICON(CROSS(0.94,(L/(MA(CLOSE,20) * 0.9)))AND C>L ,L-0.03,1);
DRAWTEXT(CROSS(0.94,(L/(MA(CLOSE,30) * 0.9))) AND C>L,L*0.9,'抄'),COLORFF00FF;
DRAWICON(CROSS(0.94,(L/(MA(CLOSE,30) * 0.9)))AND C>L ,L-0.03,1);
DRAWTEXT(CROSS(0.94,(L/(MA(CLOSE,60) * 0.9))) AND C>L,L*0.9,'抄'),COLORWHITE;
DRAWICON(CROSS(0.94,(L/(MA(CLOSE,60) * 0.9)))AND C>L ,L-0.03,1);
N3:=4;N4:=6;
快:=COUNT(CLOSE>REF(CLOSE,2),N3)/N3*100,COLORGREEN;
慢:=COUNT(CLOSE>REF(CLOSE,2),N4)/N4*100,COLORRED;
关注:= IF(慢=0 AND 快=0,60,0),COLORRED,LINETHICK1;
DRAWTEXT( 关注 AND REF(关注 ,1)=0 ,L-0.5,'近'),COLORRED;
资金:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)/4;
外围游资:=IF(资金>23.16,资金,0);
卖:=IF(外围游资,1,0);
DRAWICON( 卖,HIGH,2);
TYP:=(L+H+C)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=(C/MA(C,5)-1)*100<-10;
A2:=(C/MA(C,13)-1)*100<-10;
A3:=(C/MA(C,34)-1)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
底部:=A1 AND A2 AND A3 AND A4 AND A5 AND A6,COLOR00FFFF,LINETHICK2;
CDSJ:=BARSLAST(底部);
ZF:=(C/REF(C,1)-1)*100;
深坑:=IF(BETWEEN(CDSJ,0,5) AND L<=REF(C,CDSJ) AND ZF<=-5,30,0),COLORFF0000,LINETHICK2;
DRAWTEXT( C>O AND REF(深坑 ,1)=30 ,L*0.88,'M'),COLORRED;
MA1:MA(CLOSE,60);
VAR14:=EXPMA(CLOSE,9);
下轨:=EXPMA(VAR14*0.86,5),COLORYELLOW,POINTDOT;
XS:=MA(LOW,5)*(1-5/100),LINETHICK0;
XS1:=MA(HIGH,5)*(1+5/100);
DRAWTEXT(CROSS(XS1,C),H*1.05,'砸'),COLORWHITE;
VA11:=HIGH>=HHV(HIGH,60);
V1:=(REF(VA11,1)>0 AND VA11<1);
VA12:=LOW<=LLV(LOW,60);
V2:=REF(VA12,1)>0 AND VA12<1;
CD:=DRAWLINE(V2,LOW,V1,LLV(LOW,6),1),COLOR0099FF;
{DRAWTEXT(CROSS(C,AB),L*0.98,'B'),COLORGRAY;}
DRAWTEXT(CROSS(CD,L),L*0.98,'Z'),COLORGREEN;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
{www.gupang.com 股旁网_通达信股票指标公式}
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨1:=(1+7/100)*DD,POINTDOT,COLORGREEN,LINETHICK2;
下轨1:=(1-7/100)*DD;
LY:=10;
BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
CJ上轨:=IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05);
DRAWTEXT(CROSS(H,CJ上轨),(H * 1.01),'Z'),COLORYELLOW;
低买:=((L<=下轨1 AND C>=REF(L,1)AND COUNT(H>MA(CLOSE,60),14)>=4));
STICKLINE(O<=下轨 AND (C-L)>(H-C),O,H,3,0),COLORMAGENTA;
DRAWTEXT(O<下轨 AND (C-L)>=(H-C),L*0.95,'D'),COLORGREEN;
STICKLINE(低买,OPEN,CLOSE,3,0),COLORMAGENTA;

通达信资金轨迹主图指标公式

 

相关文章