在线检测未来函数

通达信均线作战主图指标公式

来源:Internet,编辑:股旁网,2012-02-07

M1:=5;M2:=30;M3:=30;M4:=30;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
持股区域:STICKLINE(A>B AND MA(C,5)>REF(MA(C,5),1),A,B,2,0),COLORYELLOW;
MA1:MA(CLOSE,M1)COLORWHITE;
MA2:MA(CLOSE,M2)COLORGREEN;
MA3:MA(CLOSE,M3)COLORGREEN;
MA4:MA(CLOSE,M4)COLORGREEN;
上升MA1:IF(MA1>REF(MA1,1),MA1,DRAWNULL),COLORRED,LINETHICK1;
上升MA2:IF(MA2>REF(MA2,1),MA2,DRAWNULL),COLORRED,LINETHICK1;
上升MA3:IF(MA3>REF(MA3,1),MA3,DRAWNULL),COLORRED,LINETHICK1;
上升MA4:IF(MA4>REF(MA4,1),MA4,DRAWNULL),COLORRED,LINETHICK1;
MA5:=MA(C,5);
MA10:=MA(C,10);
十天线压力:IF(BOLL<REF(BOLL,1) AND MAX(C,REF(C,1))<BOLL,MA10,DRAWNULL),COLORBLUE,LINETHICK1;
BB:=REF(INDEXC,1)<REF(INDEXC,2) AND REF(C,2)*0.95>=REF(C,1) AND REF(O,1)/REF(C,1)>=1.05
AND REF(C,1)<REF(O,1) AND C>O AND C/O>=1.05 AND C>REF(O,1)
AND REF(VOL,1)<REF(VOL,2);
STICKLINE(BB,O,C,4,0),COLORRED;
STICKLINE(BB,O,H,0,0),COLORRED;
STICKLINE(BB,L,C,0,0),COLORRED;
DRAWTEXT(BB,L*0.98,'追!'),COLORYELLOW;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
DRAWTEXT(CC,L*0.98,'买'),COLOR0099FF;
TYP:=(H+L+C)/3;
TYP1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))<=20 AND REF(MA(C,21),1)<MA(C,21);
TJ1:=O<MAX(REF(C,1),REF(O,1));
TJ2:=REF(C,1)>=MA(C,21) AND L/MA(C,21)>=1.015 AND MA(C,144)>MA(C,250) AND V<MA(V,10) AND MIN(REF(V,2),REF(V,1))>V;
TJ3:=REF(MA(C,250),90)<REF(MA(C,144),90) AND MA(C,144)>MA(C,250) AND O>MA(C,250);
TJ4:=MAX(REF(H,10)AND REF(H,9)AND REF(H,8)AND REF(H,7), REF(H,6));
TOUJI:=TYP1 AND TJ1 AND TJ2 AND REF(C,2)/REF(O,2)<1.06 AND C/O<=1.05 AND HHV(H,5)/LLV(L,30)>=1.65 AND REF(H,5)/REF(L,1)>=1.15 AND REF(C,1)/REF(O,1)<=0.995 AND (L<REF(L,2) OR (REF(H,2)-REF(L,2))/(H-L)>=2) AND O/REF(L,1)<=1.04
OR TYP1 AND TJ1 AND O/REF(L,1)<1.05 AND REF(L,1)/REF(O,4)<=0.85 AND REF(C,1)/REF(O,1)<=1.03 AND O<REF(C,1) AND HHV(H,5)/LLV(L,35)>1.35 AND V<MA(V,10);
TOUJI2:=TYP1 AND TJ1 AND TJ2 AND O/REF(L,1)<1.05 AND O/LLV(L,3)<1.1 AND REF(C,1)/REF(0,1)<=1.05 AND HHV(H,4)/LLV(L,16)>=1.35 AND REF(O,4)/REF(C,2)>=1.08 AND REF(C,2)/REF(O,2)<=0.995 AND (REF(L,2)<REF(L,3) OR (REF(H,3)-REF(L,3))/(REF(H,1)-REF(L,1))>=2) AND L<MIN(REF(C,1),REF(O,1))
OR TYP1 AND TJ1 AND HHV(H,10)/LLV(L,25)>=1.3 AND REF(C,5)<REF(H,5) AND REF(C,4)<REF(C,5) AND REF(C,3)<REF(C,4) AND REF(C,2)<REF(C,3) AND REF(C,1)<REF(C,2) AND L<REF(L,1) AND MA5/O<1.1;
DATOUJI:=TYP1 AND TJ3 AND O<REF(C,5) AND O<=REF(C,1) AND REF(H,10)/O>=1.17 AND HHV(H,10)/LLV(L,30)>1.4 AND (MA(V,10)/HHV(V,10)>0.5 AND V/HHV(V,10)>0.2 AND V/HHV(V,10)<0.4 OR REF(V,3)>REF(V,2) AND REF(V,2)>REF(V,1)) AND REF(C,1)/REF(C,2)<=1.02;
DATOUJI1:=TYP1 AND TJ3 AND O<REF(L,6) AND O<MIN(REF(C,5)AND REF(O,5),5) ;
DRAWTEXT(TOUJI OR TOUJI2 OR DATOUJI OR DATOUJI1,L*0.98,'△'),COLORYELLOW;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(CROSS(MA(VOL,10),MA(VOL,20)) AND MA(VOL,5)>MA(VOL,10) AND L<MA(C,20) AND C>=MA(C,20),L*0.98,'量托'),COLORWHITE;
卖出:=CROSS(90,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100);
DRAWTEXT(卖出,H*1.05,'短卖'),COLORGREEN;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破盘整:=W4 AND COUNT(W4,5)=1;
DRAWICON(突破盘整,L-0.10,1);
{CCI84}
TYP84:=(HIGH+LOW+CLOSE)/3;
CCI84:=(TYP84-MA(TYP84,84))/(0.015*AVEDEV(TYP84,84));
{安全涂色K线}
{STICKLINE(CCI84<100 AND C<MA(C,30),O,C,3,0),COLORGREEN;}
N:=30;
BOLL:=MA(CLOSE,N),COLORGREEN,LINETHICK1;
UPPER:BOLL+2*STD(CLOSE,N),COLORGREEN;
LOWER:BOLL-2*STD(CLOSE,N),COLORGREEN;
上升BOLL:IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED,LINETHICK1;
上升UPPER:IF(UPPER>REF(UPPER,1),UPPER,DRAWNULL),COLORRED,LINETHICK1;
上升LOWER:IF(LOWER>REF(LOWER,1),LOWER,DRAWNULL),COLORRED,LINETHICK1;
{安全涂色K线}
STICKLINE(BOLL<REF(BOLL,1),O,C,2.5,0),COLORGREEN;
STICKLINE(MA(C,5)<REF(MA(C,5),1),O,C,2.5,0),COLORGREEN;

通达信均线作战主图指标公式

 

相关文章