在线检测未来函数

飞狐江恩角度+五线布林+黄金分割主图指标公式

来源:Internet,编辑:股旁网,2012-02-08

INPUT:n(13,1,999),n1(2,1,3),上角(11,0,500),下角(11,0,500);
DRAWGBK(CLOSE,COLORRGB(50,100,120),0,1);
DD0:=REF(DAY,(BARSCOUNT(CLOSE) - 1));
■上市日期:REF(YEAR,(BARSCOUNT(CLOSE) - 1)),LINETHICK0,ColorC0C0C0;
年:REF(MONTH,(BARSCOUNT(CLOSE) - 1)),LINETHICK0,ColorC0C0C0;
月:REF(DAY,(BARSCOUNT(CLOSE) - 1)),LINETHICK0,ColorC0C0C0;
日:0,LINETHICK0,ColorC0C0C0;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'板块:'+BLKNAME),Color0095BC,align4;
u1:=SYSPARAM(3);
u:=u1-SYSPARAM(2)+1;
hh:=HHV(HIGH,u);
ll:=LLV(LOW,u);
最高:hh[u1],COLORYELLOW,ColorC0C0C0;
最低:ll[u1],COLORred,ColorC0C0C0;
PARTLINE(CLOSE and n1<>3,最低),COLORred;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.191),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.382),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1<>3,最低+(最高-最低)*0.5),ColorFF8200;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.618),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.809),LINEDOT,COLORWHITE;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(3) and n1<>3,REF(最低,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'最低↓'),ALIGN2,COLORred;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(3) and n1<>3,REF(最高,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'最高↑'),ALIGN2,COLORYELLOW;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.191)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.191↑'+NUMTOSTR(最低+(最高-最低)*0.191,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.382)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.382↑'+NUMTOSTR(最低+(最高-最低)*0.382,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1<>3,REF((最低+(最高-最低)*0.5)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM (2))),' 50% ↑'+NUMTOSTR(最低+(最高-最低)*0.5,2)),ColorFF8200;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.618)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.618↑'+NUMTOSTR(最低+(最高-最低)*0.618,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.809)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.809↑'+NUMTOSTR(最低+(最高-最低)*0.809,2)),COLORWHITE;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*1/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*1/4),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*3/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*5/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*7/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*3/4),LINEDOT,Color0095BC;
k3:=CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1);
STICKLINE(k3,HIGH,LOW,0.1,0),colorred;
STICKLINE(k3,OPEN,CLOSE,7,1),colorred;
STICKLINE(NOT(k3),HIGH,LOW,0.1,0),colorcyan;
STICKLINE(NOT(k3),CLOSE,OPEN,7,0),colorcyan;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*1/8)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 1/8↑'+NUMTOSTR(最低+(最高-最低)*1/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*1/4)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 1/4↑'+NUMTOSTR(最低+(最高-最低)*1/4,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*3/8)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 3/8↑'+NUMTOSTR(最低+(最高-最低)*3/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*5/8)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 5/8↑'+NUMTOSTR(最低+(最高-最低)*5/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*7/8)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 7/8↑'+NUMTOSTR(最低+(最高-最低)*7/8,2)),Color0095BC;
{www.gupang.com 股旁网_飞狐股票指标公式}
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=2,REF((最低+(最高-最低)*3/4)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'江恩 3/4↑'+NUMTOSTR(最低+(最高-最低)*3/4,2)),Color0095BC;
YB:=SYSPARAM(2);
a:=SYSPARAM(3);
P:=(a - YB);
S4:=SYSPARAM(4);
S5:=SYSPARAM(5);
HH:=HHVBARS(HIGH,(P + 1));
LL:=LLVBARS(LOW,(P + 1));
z:=(BARPOS = (a - HH[a]));
Y:=(BARPOS = (a - LL[a]));
K:=((S4 - S5) / (a - YB));
DRAWSL(z,HIGH,(0 - ((15 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((30 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((60 * K) / 60)),0,0),colorFFFF00;
DRAWSL(z,HIGH,(0 - ((85 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((120 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((165 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((240 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((360 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((600 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(Y,LOW,((10 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((30 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((60 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((90 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((120 * K) / 60),0,0),colorFF00FF;
DRAWSL(Y,LOW,((180 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((300 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((540 * K) / 60),0,0),POINTDOT,colorFF00FF;
DRAWSL(Y,LOW,((1020 * K) / 60),0,0),POINTDOT,colorFF00FF;
A:=SYSPARAM(1);
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift13;
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift21;
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift34;
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift55;
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift89;
VERTLINE(BARPOS=A),POINTDOT,Color0095BC,shift144;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'天数'),Color0095BC,align2;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'13'),Color0095BC,shift13;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'21'),Color0095BC,shift21;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'34'),Color0095BC,shift34;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'55'),Color0095BC,shift55;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'89'),Color0095BC,shift89;
DRAWTEXT(BARPOS=A,SYSPARAM(5),'144'),Color0095BC,shift144;

飞狐江恩角度+五线布林+黄金分割主图指标公式

 

相关文章