在线检测未来函数

飞狐蝉缠指标公式

来源:Internet,编辑:股旁网,2012-02-08

均价:=(2*C+(H-L)/2+L+O)/4;
p1:=if(STKTYPE=0,2,3);
价差:=SUM(均价-REF(均价,1),p1)/p1;
GG:=EMA(均价+价差,7),COLORWHITE;
MM:=EMA(均价+价差,21),COLORRED;
变盘线:=EMA(MM,52),COLOR9900FF;
金线:=(ema(MM,3)+EMA(MM,6)+EMA(MM,12)+EMA(MM,24))/4,COLORYELLOW,LINETHICK2;
庄线:=(ema(EMA(MM,63),3)+ema(EMA(MM,63),6)+EMA(EMA(MM,63),12)+EMA(EMA(MM,63),24))/4,COLOR0066FF,LINETHICK2;
缠1:=(ABS(GG-MM))/if(GG>MM,MIN(GG,MM),MAX(GG,MM))*100;
缠2:=(ABS(MM-金线))/if(金线>MM,MAX(金线,MM),MIN(金线,MM))*100;
缠3:=(ABS(GG-金线))/if(金线>gg,MAX(金线,gg),MIN(金线,gg))*100;
缠4:=(ABS(MM-庄线))/if(庄线>MM,MAX(庄线,mm),MIN(庄线,mm))*100;
缠5:=(ABS(金线-庄线))/if(庄线>金线,MAX(庄线,金线),MIN(庄线,金线))*100;
{www.gupang.com 股旁网_飞狐股票指标公式}
缠:(缠1+缠2+缠3+(缠2+缠4+缠5)/3)/4,COLORWHITE;
M:MA(缠,3),COLOR00bb00;
趋势:if(STKTYPE=0,MA((均价-庄线*0.333)/庄线*0.333,18)*50,MA((均价-庄线*0.333)/庄线*0.333,18)*100)/3,COLOR9900FF,LINETHICK2;
PARTLINE(趋势<REF(趋势,1),趋势),COLOR00AA99,LINETHICK2;
n:=IF(DATATYPE=5,36,IF(DATATYPE=6,18,IF(DATATYPE=7,9,72)));
up:REF(HHV(缠,3*N),N/3),COLORRED;
tP:REF(llV(缠,3*N),N/3),color9999FF;
OP:(up+TP)/2,COLORYELLOW;
FILLRGN(均价>金线 AND 缠>M,缠,M),COLOR330099;

飞狐蝉缠指标公式

 

相关文章