在线检测未来函数

通达信买卖金线+资金净流入主图指标公式

来源:Internet,编辑:股旁网,2012-02-08

VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
{DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),1);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),2);}
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'进 '),COLORFF00FF;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'出 '),COLOR3AFF00;
分界线:MA(CLOSE,21),COLORYELLOW;
STICKLINE(C>=分界线 AND C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=分界线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=分界线 AND C<O,C,O,5,1),COLORRED;
STICKLINE(C>=分界线 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=分界线 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<分界线 AND C>O,C,O,5,1),COLORFFFF00;
STICKLINE(C<分界线 AND C<=O,C,O,5,1),COLORFFFF00;
STICKLINE(C<分界线 AND C<=O,H,L,0,1),COLORFFFF00;
STICKLINE(C<分界线 AND C>O,C,H,0,1),COLORFFFF00;
STICKLINE(C<分界线 AND C>O,O,L,0,1),COLORFFFF00;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

通达信买卖金线+资金净流入主图指标公式

 

相关文章