在线检测未来函数

飞狐黑马组合指标公式

来源:Internet,编辑:股旁网,2012-02-10

N:=14;N1:=36;G:=15;Z:=5;
ROC:=100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12);
MAROC:=MA(ROC,6);
变动速率:=ROC/MAROC*Z;
P:=(HIGH+LOW+CLOSE)/3;
CCI1:=(P-MA(P,N))*1000/(G*AVEDEV(P,N)),colorred;
CCI2:=(P-MA(P,N1))*1000/(G*AVEDEV(P,N1)),colorgreen;
B1:=BARSLAST(CCI1=LLV(CCI1,60));
DD:=CLOSE<REF(CLOSE,B1) AND CCI1>REF(CCI1,B1);
背离:IF(DD,100,0),colorFF00FF;
MA10:=MA(C,10);
MA60:=MA(C,60);
超跌关注:if(C<MA60*0.75,100,0),LINETHICK2,colorwhite;
超跌建仓:if(C<MA60*0.75 AND MA10>REF(MA10,1),100,0),linethick2,colorwhite;
机会难得:IF(CROSS(CCI1,CCI2) AND REF(CCI1,1)=LLV(CCI1,70),100,0),LINETHICK2,coloryellow;
VAR6:="KDJ.J#WEEK"(9,3,3);
VAR8:="KDJ.J#MONTH"(9,3,3);
DEA7:="MACD.DEA#WEEK";
DIFF7:="MACD.DIFF#WEEK";
d7:=DIFF7-DEA7;
DEA8:="MACD.DEA#MONTH";
DIFF8:="MACD.DIFF#MONTH";
d8:=DIFF8-DEA8;
T:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
黑马抄底:if(CROSS(var6,0) AND D8>0 OR CROSS(var8,0) and d7>0,100,0),LINETHICK2,colorCC0000;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
KD:=CROSS(k,d);
选股:机会难得 and KD;
VERTLINE(机会难得 and KD),COLORYELLOW,LINEDOT;
A2:=MA(CLOSE,18);
A3:=(CLOSE-A2)/A2*100>=-9.9 AND CLOSE<A2;
美人如玉剑如虹:=A3 AND CLOSE/REF(CLOSE,1)>1.089;
美人如玉剑如虹:IF(美人如玉剑如虹,100,0),LINETHICK2,colorred;
腰线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
Q:=DATE<1091231;
KK:=EMA(CLOSE-LOW,5);
顶线:=MA((CLOSE+REF(CLOSE,1)+REF(CLOSE,1))/3+KK,5);
底线:=MA(REF(CLOSE,1)-KK,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
BB:=MA(CLOSE,2);
CC:=MA(CLOSE,10);
DD:=MA(CLOSE,20);
EE:=ANY(CROSS(BB,CC) AND CROSS(BB,DD),1);
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
明月:=IF(CAPITAL<1,MA(VOL,74),MA(SUM(J1-J2,22),3));
积雪:=IF(CAPITAL<1,WMA(明月,360),WMA(明月,21));
VAR3:=明月-积雪;
VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
PP:=EMA(SMA(RG,3,1),2);
QQ:=SMA(PP,3,1);
老钱庄明月战神:=腰线>OPEN AND OPEN>底线 AND CLOSE>顶线 AND CLOSE>MA20 AND CLOSE>腰线 AND EE AND CROSS(VAR4,VAR5)*Q AND CROSS(PP,QQ);
明月战神:if(老钱庄明月战神,100,0),LINETHICK2,colorFF00FF;
M:=IF((T > 0.35),6,65);
W:=((-((100)*(HHV(HIGH,M) - CLOSE))/(HHV(HIGH,M) - LLV(LOW,M))));
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
BB:=MA(SUM(J1-J2,22),3);
累加:=21*BB+20*REF(BB,1)+19*REF(BB,2)+18*REF(BB,3)+17*REF(BB,4)
+16*REF(BB,5)+15*REF(BB,6)+14*REF(BB,7)+13*REF(BB,8)+12*REF
(BB,9)+11*REF(BB,10)+10*REF(BB,11)+9*REF(BB,12)+8*REF(BB,13)
+7*REF(BB,14)+6*REF(BB,15)+5*REF(BB,16)+4*REF(BB,17)+3*REF
(BB,18)+2*REF(BB,19)+REF(BB,20);
aa:=累加/(21+1)/21*2;
CC:=aa;
VAR3:=(BB-CC);VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
KK:=EMA(SMA(RG,3,1),2),COLORFFFFFF;
DD:=SMA(KK,3,1),COLOR00FFFF;
FILLRGN(KK<DD,KK,DD),COLORgreen;
FILLRGN(KK>DD,KK,DD),COLORred;
天天涨停:if(CROSS(W,-2) AND CROSS(VAR4,VAR5) AND CROSS(KK,DD),100,0),LINETHICK2,colorgreen;
p:=27;
q:=5;
RSV1:=(LLV(LOW,p)-C)/(HHV(HIGH,p)-LLV(LOW,p))*100+50;{WR(27,3,3)+50}
K1:SMA(RSV1,3,1),colorwhite,LINETHICK3;
D1:=SMA(K1,3,1),coloryellow;
RSV2:=(CLOSE-LLV(LOW,p))/(HHV(HIGH,p)-LLV(LOW,p))*100-50;{KDJ(27,3,3)-50}
K2:SMA(RSV2,3,1),color00FFFF,LINETHICK3;
D2:=SMA(K2,3,1),coloryellow;
MMK:=(K1+K2)/2,COLORRED,LINETHICK3;
RSV3:=(CLOSE-LLV(LOW,q))/(HHV(HIGH,q)-LLV(LOW,q))*100;{正常kdj(5,3,3)}
短K:=SMA(RSV3,3,1),colorwhite;
短D:=SMA(短K,3,1),coloryellow;
短J:3*短K-2*短D,COLORgreen;
stickline(K2>ref(K2,1),K2,k2,8,0),colorred,linethick3;{K2变色红黄}
stickline(K1<ref(K1,1),K1,k1,8,0),colorgreen,linethick3;{K1变色白绿}
0,COLORFFA2AF,LINETHICK2;
50,COLORFFA2AF,POINTDOT;
100,COLORFFA2AF,POINTDOT;
Var1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
波:= Var3;
段:= Var4;
Var5:=CROSS(Var3,Var4) AND Var3<20;
{www.gupang.com 股旁网_飞狐股票指标公式}
DRAWTEXT(FILTER(var5,10)=1,40,'抄底'),colorred;
STICKLINE(FILTER(var5,10)=1,0,30,10,0),colorred;
Var9:=CROSS(Var4,Var3) AND Var3>80;
STICKLINE(FILTER(var9,5)=1,80,100,10,0),colorgreen;
DRAWTEXT(FILTER(var9,5)=1,70,'逃顶'),colorgreen;
Var8:=CROSS(Var2,Var3) AND Var3>80 AND Var3>Var4;
STICKLINE(var8,85,100,10,0),color0099ff;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
风险:80,ColorFF0068;
小心:87.5,Color00FF00;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:=DD,Color9198FF,Linethick2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
跟踪:10,Color0000FF;
亮剑目标一:IF((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)<REF(REF(股神,1),1)) AND (股神<跟踪),100,0),ColorFF98FF;
亮剑目标二:IF(CROSS(股海,90) AND (股神<40),100,0),ColorFFFF00;

飞狐黑马组合指标公式

 

相关文章