在线检测未来函数

飞狐买卖观注主图指标公式

来源:Internet,编辑:股旁网,2012-02-13

DRAWTEXT(sysparam(2)=BARPOS,c,'所属板块:'+BLKNAME),COLORccffff,ALIGN4;
MA5:EMA(CLOSE,5);
MA10:EMA(C,10);
MA20:EMA(CLOSE,20);
Var1:=(REF(HIGH,1)+REF(LOW,1))/2;
压力线:MA(CLOSE,20)+2*STD(CLOSE,20);
支撑线:MA(CLOSE,21)-2.2*STD(CLOSE,21),COLORFF0000;
Var2:=CROSS(Var1,压力线);
Var3:=REF(CLOSE,1);
Var4:=SMA(MAX(CLOSE-Var3,0),7,1)/SMA(ABS(CLOSE-Var3),7,1)*100;
Var5:=CROSS(79,Var4);
Var6:=FILTER(Var5,4);
DRAWICON(FILTER(Var6 OR Var2,5),HIGH*1.035,2);
DRAWTEXT(FILTER(Var6 OR Var2,5),HIGH*1.02,'卖观注'),COLORyellow;
Var7:=FILTER( MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5<MA10,5);
Var8:=FILTER(HHVBARS(H,13)/C>2 AND MA5>REF(MA5,1)AND MA5<MA10,7);
{www.gupang.com 股旁网_飞狐股票指标公式}
Var9:=REF(L,2)<支撑线 AND L>支撑线 AND C>O AND MA5>REF(MA5,1);
DRAWICON(FILTER(Var7 OR Var8 OR Var9,5)AND Var4<45,L,1);
DRAWTEXT(FILTER(Var7 OR Var8 OR Var9,5)AND Var4<45,L*0.98,'买观注'),COLORRED;
DRAWICON(CROSS(10,Var4),L,10);

飞狐买卖观注主图指标公式

 

相关文章