在线检测未来函数

大智慧量价增减2指标公式

来源:Internet,编辑:股旁网,2012-02-14

DRAWGBKlast(DATE>900101,strip(RGB(0,40,40),RGB(0,0,0),0));0,ColorFF9900;
JC:=(C-REF(C,1))/REF(C,1)*100;
JCM:EMA(SUM(JC,5),5),Color00FF00,LAYER4;
PARTLINE(JCM,(JCM>REF(JCM,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2,LAYER4;
STICKLINE(JC>0,JC,0,5,0),Color000055,LAYER7;
STICKLINE(JC>0,JC,0,4,0),Color000077,LAYER7;
STICKLINE(JC>0,JC,0,3,0),Color000099,LAYER7;
STICKLINE(JC>0,JC,0,2,0),Color0000CC,LAYER7;
STICKLINE(JC>0,JC,0,1,0),Color0000FF,LAYER7;
STICKLINE(JC<0,JC,0,5,0),Colorf1111f,LAYER7;
STICKLINE(JC<0,JC,0,4,0),Colorf3333f,LAYER7;
STICKLINE(JC<0,JC,0,3,0),Colorf5555f,LAYER7;
STICKLINE(JC<0,JC,0,2,0),Colorf7777f,LAYER7;
STICKLINE(JC<0,JC,0,1,0),Colorf9999f,LAYER7;
ZF:=(C-REF(C,1))/REF(C,1)*100;
DRAWTEXT(ZF>2 ,-2,''+NUMTOSTRN(ZF,0)+'' ),ALIGN1,color0077ff,linethick1,LAYER5;
DRAWTEXT(ZF<-2 ,2,''+NUMTOSTRN(ZF,0)+'' ),ALIGN1,color00ff00,linethick1,LAYER5;
x:=BARSLAST(DISPSTATUS=1)+1;
ah:=hhvall(hhv(h,x));
alP:=llvall(llv(l,X));
天:BARSLAST(L=LLV(LOW,X)),COLOR00FFFF,LINETHICK0,PRECIS0;
涨幅:(C-AlP)/AlP*100,COLOR00FF00,DOTLINE,LINETHICK0;
跌幅:(C-ah)/ah*100,COLOR00FF00,DOTLINE,LINETHICK0;
跌天:BARSLAST(L=LLV(LOW,X)),COLOR00FFFF,LINETHICK0,PRECIS0;
涨天:BARSLAST(H=hhv(HIGH,X)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTABS(450,3, '■'+NUMTOSTRN(X,0)+'天的最高点 ' +NUMTOSTRN(ah,2)+'元 至今天是第 ' +NUMTOSTRN(涨天,0)+'天 跌 ' +NUMTOSTRN(跌幅,2)+'%'),COLOR00FF00,LINETHICK3;
DRAWTEXTABS(450,20,'■'+NUMTOSTRN(X,0)+'天的最低点 ' +NUMTOSTRN(alp,2)+'元 至今天是第 ' +NUMTOSTRN(跌天,0)+'天 涨 ' +NUMTOSTRN(涨幅,2)+'%'),COLOR0088FF,LINETHICK3;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWRECTABS(3,0 ,315 ,110, rgb(40,0,60)),color0077FF,LINETHICK2,LAYER4;
量比:=vol/ma(v,5);
DRAWTEXTABS(0,5,'【量比】: ◢'+NUMTOSTRN(量比,2)+'◣ [>=1.2 ===强势]'),color00FFff,LINETHICK2,LAYER0;
MA5乖离:=(C-MA(C,5))/MA(C,5)*100;
DRAWTEXTABS(0,22,'【MA5乖离】: ◢'+NUMTOSTRN(MA5乖离,1)+'◣ [0→6.0===安全]'),color0000ff,LINETHICK2,LAYER0;
VAR9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
FAS9:=SMA(VAR9,3,1);
K9:=SMA(FAS9,3,1);
D9:=SMA(K9,3,1);
j9:=3*K9-2*D9;
DRAWTEXTABS(0,39,'【J(9.3.3)】: ◢'+NUMTOSTRN(j9,0)+'◣ [50→90===安全]'),color00ff00,LINETHICK2,LAYER0;
VAR27:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
FAS27:=SMA(VAR27,3,1);
K27:=SMA(FAS27,3,1);
D27:=SMA(K27,3,1);
j27:=3*K27-2*D27;
DRAWTEXTABS(0,56,'【J(27.3.3)】: ◢'+NUMTOSTRN(j27,0)+'◣ [50→90===安全]'),color00ffff,LINETHICK2,LAYER0;
DRAWTEXTABS(0,73,'【RSI1(14.)】: ◢'+NUMTOSTRN("RSI1.RSI",0)+'◣ [40→65===安全]'),Color00FF00,LINETHICK2;
DRAWTEXTABS(0,90,'【W&R(14.)】: ◢'+NUMTOSTRN("W&R.WR1",0)+'◣ [80→20===安全]'),Color0077FF,LINETHICK2;

大智慧量价增减2指标公式

 

相关文章