在线检测未来函数

通达信股海沉浮主图指标公式

来源:Internet,编辑:股旁网,2012-02-16

二分位:MIN(OPEN,CLOSE)+(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/2,COLORMAGENTA;
中阳:=CLOSE/REF(CLOSE,1)>=1.03;
AA:=BARSLAST(中阳);
均衡:=REF(OPEN,AA);
DRAWBAND(REF(二分位,1),RGB(155,50,50),均衡,RGB(50,50,50));
海平面:REF(二分位,1),COLORFF9900;
{3D K线}
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,3,0),COLOR000033;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,2.5,0),COLOR000044;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,2,0),COLOR000055;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,1.5,0),COLOR000066;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,1,0),COLOR000077;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,0.5,0),COLOR000088;
STICKLINE(CLOSE>=OPEN ,OPEN,CLOSE,0.2,0),COLOR000099;
STICKLINE(CLOSE>=OPEN ,L,H,0,0),COLOR000099;
{收阴}
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,3,0),COLORFF3300;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,2.6,0),COLORFF5500;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,2.2,0),COLORFF7700;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,1.7,0),COLORFF8800;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,1.2,0),COLORFF9900;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,0.8,0),COLORFFBB00;
STICKLINE(CLOSE<OPEN ,OPEN,CLOSE,0.5,0),COLORFFDD00;
STICKLINE(CLOSE<OPEN ,L,H,0,0),COLORFFDD00;
VARDQ:=((REF(CLOSE,1)=HHV(CLOSE,4)) AND (CLOSE<REF(CLOSE,2)) OR ((REF(CLOSE,2)=HHV(CLOSE,4)) AND (REF(CLOSE,1)>REF(CLOSE,3)) OR (REF(CLOSE,3)=HHV(CLOSE,4)) AND (REF(CLOSE,1)>REF(CLOSE,2))) AND (REF(CLOSE,2)>=REF(CLOSE,4)) AND (CLOSE<REF(CLOSE,1)));
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),3,0),COLOR003300;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),2.6,0),COLOR005500;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),2.2,0),COLOR007700;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),1.8,0),COLOR009900;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),1.2,0),COLOR00BB00;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),0.5,0),COLOR00DD00;
VARCQ:=((REF(CLOSE,1)=LLV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,2)) OR (REF(CLOSE,2)=LLV(CLOSE,4)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<REF(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1)));
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),3,0),COLOR005500;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),2.6,0),COLOR007700;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),2.2,0),COLOR009900;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),1.8,0),COLOR00BB00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),1.2,0),COLOR00DD00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),0.5,0),COLOR00FF00;
STICKLINE(LOW>REF(HIGH,1),REF(HIGH,1),LOW,5,0),COLOR555500;
STICKLINE(中阳,O,C,0.5,0),COLORYELLOW;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(CLOSE>0,二分位,二分位,1,0),COLOR00FF00;
{买卖点}
VAR1:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR2:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR3:=(100-MA(((100*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW*0.984),1);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH*1.035),2);
{攻防价位}
实体:=MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE);
攻防价位:(REF(实体*0.618+MIN(OPEN,CLOSE),1)),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,攻防价位,攻防价位,6,0),COLORYELLOW;
{中线多空线}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
空:MA(多,6),COLORGREEN;
MA60:MA(CLOSE,60),COLORYELLOW,POINTDOT;
MS:IF(多>=REF(多,1),多,DRAWNULL),COLORRED,LINETHICK2;
MM:IF(空>=REF(空,1),空,DRAWNULL),COLORYELLOW,LINETHICK2;
买:=CROSS(多,空);
卖:=CROSS(空,多);
DRAWICON(买,L*0.97,5);
{DRAWICON(卖,H*1.03,6);}

通达信股海沉浮主图指标公式

 

相关文章