在线检测未来函数

通达信MACD+成交量指标公式

来源:Internet,编辑:股旁网,2012-02-19

DE:=CONST(LLV(L,90));
JI:=CONST(HHV(H,90))-DE;
DE_K:=DE+JI/3*2;
JI_K:=JI/2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DE_A:=CONST(LLV(RSV,90));
DD_A:=CONST(HHV(RSV,90))-DE_A;
R:=(RSV-DE_A)/DD_A;
RSV1:=R*JI_K+DE_K;
DE_M:=DE+JI/3;
JI_M:=JI/2;
KDL:=CONST(LLV(EMA(C,26),90));
KDH:=CONST(HHV(EMA(C,26),90))-KDL;
R_K1:=(EMA(C,12)-KDL)/KDH;
R_K2:=(EMA(C,26)-KDL)/KDH;
DIF~:(R_K1-R_K2)*JI*1.5+DE_M;
DEA~:EMA(DIF~,9);
MACD~:=(DIF~-DEA~)*2+DE_M;
STICKLINE(MACD~>=DE_M,MACD~,DE_M,0,0),COLORLIBLUE;
D_1:=MACD~>H AND H>=DE_M AND DE_M>=L;
D_2:=MACD~>H AND H>=L AND L>DE_M;
{www.gupang.com 股旁网_通达信股票指标公式}
D_3:=H>MACD~ AND MACD~>=L AND L>DE_M;
D_4:=H>MACD~ AND MACD~>DE_M AND DE_M>=L;
STICKLINE(D_1>0,H,DE_M,0,0),COLORYELLOW;
STICKLINE(D_2,H,L,0,0),COLORYELLOW;
STICKLINE(D_3,MACD~,L,0,0),COLORYELLOW;
STICKLINE(D_4,MACD~,DE_M,0,0),COLORYELLOW;
D_5:=MACD~<L AND L<=DE_M AND DE_M<=H;
D_6:=MACD~<L AND H<DE_M;
D_7:=L<MACD~ AND MACD~<=H AND H<DE_M;
D_8:=L<MACD~ AND MACD~<DE_M AND DE_M<=H;
STICKLINE(MACD~<DE_M,DE_M,MACD~,0,0),COLORAA00AA;
STICKLINE(D_5,DE_M,L,0,0),COLORYELLOW;
STICKLINE(D_6,H,L,0,0),COLORYELLOW;
STICKLINE(D_7,H,MACD~,0,0),COLORYELLOW;
STICKLINE(D_8,DE_M,MACD~,0,0),COLORYELLOW;
L_00:DE_K;
L_20:JI_K/5+DE_K;
L_80:JI_K*4/5+DE_K;
L_100:JI_K+DE_K;
MAXV:=CONST(HHV(VOL,90));
MAXS:=CONST(HHV(HIGH,90));
BS:=MAXV/MAXS;
VOLUME:=VOL/BS*0.10;
ORIGIN:=CONST(LLV(LOW,0))-CONST(0.5*HHV(VOLUME,0)),;
STICKLINE(CLOSE>=OPEN,ORIGIN,ORIGIN+VOLUME,0.2,0),COLORRED;
STICKLINE(CLOSE<OPEN,ORIGIN,ORIGIN+VOLUME,0.2,0),COLORGREEN;

通达信MACD+成交量指标公式

 

相关文章