在线检测未来函数

通达信主力进撤指标公式

来源:Internet,编辑:股旁网,2012-02-17

R:=4;
V1:=(C*2+H+L+O)/5; {均价}
V2:=EMA(V1,13)-EMA(V1,34);{MACD.DIFF}
V3:=EMA(V2,5); {MACD.DEA}
V4:=(V2-V3)*100; {MACD.MACD}
主力撤:=IF(V4<=0,V4,0){,COLORBLUE个股};
主力进:=IF(V4>=0,V4,0){,COLORFF00FF个股};
V8:=(INDEXC*2+INDEXH+INDEXL+INDEXO)/5;{大盘均价}
V9:=EMA(V8,13)-EMA(V8,34); {INDEX.DIFF}
VA:=EMA(V9,5); {INDEX.DEA}
VB:=(V9-VA)/2; {INDEX.MACD}
V11:=3*SMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1)-2*SMA(SMA((C- LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1),3,1);{引用个股"KDJ.J"}
V12:=3*SMA((C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1)-2*SMA(SMA((C- LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1),3,1);{引用个股"KDJ.J"}
V13:=3*SMA((C-LLV(L,120))/(HHV(H,120)-LLV(L,120))*100,5,1)-2*SMA(SMA((C- LLV(L,120))/(HHV(H,120)-LLV(L,120))*100,5,1),3,1);{引用个股"KDJ.J"}
阳光:EMA(V11,3),COLORYELLOW,LINETHICK2;
空气:EMA(V12,3),COLORDD00FF;
雨露:EMA(V13,3),COLORWHITE;
DV11:=3*SMA((INDEXC-LLV(INDEXL,60))/(HHV(INDEXH,60)-LLV(INDEXL,60))*100,5,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,60))/(HHV(INDEXH,60)-LLV(INDEXL,60))*100,5,1),3,1);
自然环境:EMA(DV11,13),COLORCYAN,LINETHICK2;
稻草人:空气<=10,LINETHICK0,COLOREECC99;
STICKLINE(空气<=10,0,15,3,0),COLOREECC99;
麦田:空气<=10 AND (阳光<=10 OR 自然环境<=10),LINETHICK0,COLOR00EEAA;
STICKLINE(空气<=10 AND (阳光<=10 OR 自然环境<=10),0,20,2,0),COLOR00EEAA;
早熟:空气<=10 AND (阳光<=10 OR 自然环境<=10) AND 雨露<=10,LINETHICK0,COLORMAGENTA;
STICKLINE(空气<=10 AND (阳光<=10 OR 自然环境<=10) AND 雨露<=10,0,25,1,0),COLORMAGENTA;
光合作用:阳光<=10 AND 空气<=10 AND 自然环境<=10 AND 雨露<=10,LINETHICK0,COLORRED;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(阳光<=10 AND 空气<=10 AND 自然环境<=10 AND 雨露<=10,0,30,0.5,0),COLORRED;
AA:=FILTER((空气<=10),15);
XX:=FILTER(空气<=10 AND 自然环境<=10,15);
{DRAWTEXT (AA,30,'稻草人'),COLORCC9900;
DRAWTEXT (XX,40,'麦田'),COLOR00AAAA; }
BB:= (空气<=10 AND V12>10) AND FILTER((空气<=10 AND V12>10),10);
乌鸦:空气>=90 AND 空气>REF(空气,1),COLORFFFF00,LINETHICK0;
STICKLINE(乌鸦,100,95,15,1),COLORFFFF00;
暴风雨:空气>=90 AND 自然环境>=90,COLORGREEN,LINETHICK0;
STICKLINE(暴风雨,100,95,10,0),COLORGREEN;
收割:FILTER(空气>90 AND 空气<REF(空气,1) AND 主力进<REF(主力进,1),8);
DRAWTEXT( 收割,90,'收割'),COLORYELLOW;
IF(阳光<=10,阳光,DRAWNULL),LINETHICK3,COLOR0000FF;
IF(阳光>=90,阳光,DRAWNULL),LINETHICK3,COLORFF0000;
STICKLINE(自然环境<=10,100,95,10,0),COLORRED;
DRAWTEXT(FILTER(自然环境<=10,8),90,'农耕?'),COLORRED;

通达信主力进撤指标公式

 

相关文章