在线检测未来函数

飞狐超级MACD指标公式

来源:Internet,编辑:股旁网,2012-02-17

input:P(26,20,100),S(12,5,40),M(9,2,60),P1(19,1,120),P2(120,1,250),选股(-40,-100,0),抄底(-26,-100,0);DRAWGBK(CLOSE,COLORRGB(5,2,0),COLORRGB(5,2,0),1);
DIFF:(EMA(CLOSE,S) - EMA(CLOSE,P)),colorFF;
DEA:EMA(DIFF,M),colorFFFF;
MACD:(2 * (DIFF - DEA)),COLORSTICK,LINETHICK2;
STICKLINE(((MACD < REF(MACD,1)) AND (MACD > 0)),0,MACD,2,0),LINETHICK2,colorFFFF;
STICKLINE(((MACD > REF(MACD,1)) AND (MACD < 0)),0,MACD,2,0),LINETHICK2,colorFF00FF;
HH:=MA(CLOSE,10);
GG:=MA(CLOSE,12);
上:=FFT((MA(HIGH,3) * 1.05),30);
下:=FFT((MA(LOW,3) * 0.96),30);
决战:STICKLINE((((CROSS(DIFF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIFF < 0)),DIFF,0.4,3,0),colorFF;
DRAWICON((((CROSS(DIFF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIFF < 0)),0.4,0);
DRAWTEXT((((CROSS(DIFF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIFF <= 0)),0.4,'。DIFF金叉'),colorFF;
STICKLINE(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0,0.5,3,0),colorFF00;
DRAWICON(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0.5,0);
DRAWTEXT(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0.5,'。绝佳买入'),colorFF00;
VCF1:=LLV(LOW,5);
VCF2:=HHV(HIGH,5);
VCF3:=EMA((((CLOSE - VCF1) / (VCF2 - VCF1)) * 100),4);
VCF4:=EMA(((0.667 * REF(VCF3,1)) + (0.333 * VCF3)),2);
VCF5:=((HIGH + LOW) / 2);
VCF6:=DMA(VCF5,(VOL / SUM(VOL,MIN(5,BARSCOUNT(CLOSE)))));
VCF7:=DMA(VCF5,(VOL / SUM(VOL,MIN(13,BARSCOUNT(CLOSE)))));
VCF8:=DMA(VCF5,(VOL / SUM(VOL,MIN(34,BARSCOUNT(CLOSE)))));
VCF9:=DMA(VCF5,(VOL / SUM(VOL,MIN(75,BARSCOUNT(CLOSE)))));
VCFA:=EMA(WINNER((0.9 * CLOSE)),5);
VCFB:=(1 - EMA(WINNER((1.2 * CLOSE)),5));
VCFC:=EMA(WINNER(CLOSE),5);
VCFD:=((100 * (CLOSE - VCF6)) / VCF6);
VCFE:=((100 * (CLOSE - VCF7)) / VCF7);
VCFF:=((100 * (MIN(CLOSE,OPEN) - VCF8)) / VCF8);
VCF10:=BARSLAST(((VCF8 > VCF9) AND (REF(VCF8,1) <= REF(VCF9,1))));
VCF11:=((((COUNT(((WINNER(CLOSE) < 0.11) AND (EMA(WINNER(CLOSE),5) < 0.15)),2) > 0) OR (((1 - WINNER((1.2 * CLOSE))) >= 0.8) AND (WINNER(CLOSE) < 0.05))) AND (COUNT((VCFE < (0 - 16)),2) > 0)) AND (COUNT((VCFF < (0 - 20)),2) > 0));
VCF12:=((((COUNT((VCFD < (0 - 10)),2) > 0) AND (COUNT((VCFE < (0 - 15)),2) > 0)) AND (COUNT((VCFF < (0 - 15)),2) > 0)) AND (COUNT((VCFA > 0.8),VCF10) = 0));
VCF13:=(((COUNT((VCF11 OR VCF12),2) > 0) AND (VCF3 > REF(VCF3,1))) AND (((1 - WINNER((1.15 * CLOSE))) * 100) > 80));
出击1:=IF((VCF13 AND (COUNT(VCF13,3) <= 1)),0.1,0);
DRAWBKBMP((出击1 >= 0.1),'sun');
黑马出击:IF((VCF13 AND (COUNT(VCF13,3) <= 1)),0.37,0),LINETHICK3,colorFF;
DRAWICON((黑马出击 > 0),0.37,1);
DRAWTEXT((黑马出击 > 0),0.35,'.★黑马 '),colorFFFFFF;
DRAWTEXT((黑马出击 > 0),0.35,' 出击'),colorFF00;
VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
VAR28:=EMA(VAR27,9);
VAR29:=(2 * (VAR27 - VAR28));
STICKLINE(((VAR27 < (0 - 50)) AND (VAR26 > 7)),0,(0 - 0.1),5,0),colorFF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 < VAR28)),(0 - 0.08),'底'),colorFFFFFF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 >= VAR28)),(0 - 0.1),'追'),colorFFFFFF;
VAR1:=IF((DATE >= 99990600),0,1);
VAR2:=MA(CLOSE,18);
VAR3:=(((CLOSE - VAR2) / VAR2) * 100);
VAR4:=MA(VAR3,1);
升跌:=(VAR4 * VAR1);
VAR5:=BARSLAST((CROSS((0 - 10),VAR4) = 1));
VAR6:=BARSLAST((CROSS(VAR4,10) = 1));
VAR7:=((VAR4 < (0 - 10)) AND (VAR5 >= 5));
VAR8:=((VAR4 > 10) AND (VAR6 >= 5));
C1:(0.01 * (IF(((VAR4 < (0 - 10)) AND (VAR5 >= 5)),VAR4,0) * VAR1)),LINETHICK1,colorFF;
C2:=C1;
C3:=(IF(((VAR4 > 10) AND (VAR6 >= 5)),VAR4,0) * VAR1);
C4:=C3;
D1:=((((升跌 > REF(升跌,1)) AND VAR7) * 0.2) * VAR1);
中期底部:=LLV(CLOSE,30);
D:(FILTER(((((((升跌 > REF(升跌,1)) AND (LOW <= 中期底部)) AND (CLOSE > 中期底部)) AND VAR7) * 0.5) * VAR1),3) * 0.5),LINETHICK2,colorFF;
DRAWTEXT((D >= 0.25),D,'★-铁底'),colorFFFF;
STICKLINE(((CROSS(MACD,DIFF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),MACD,0.23,0,0),LINETHICK2,colorFFFF;
DRAWTEXT(((CROSS(MACD,DIFF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,'^MACD'),colorFF;
DRAWTEXT(((CROSS(MACD,DIFF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,' 金叉'),LINETHICK4,colorFFFFFF;
DRAWICON(((CROSS(MACD,DIFF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,1);
DIFF2:=(EMA(CLOSE,2) - EMA(OPEN,5));
操盘手:=DIFF2;
(0.4 * ((CROSS(操盘手,MACD) AND (MACD <= (0 - 0.11))) AND (LOW <= 下))),LINETHICK2,colorFFFFFF;
DRAWTEXT(((CROSS(操盘手,MACD) AND (LOW <= 下)) AND (MACD <= (0 - 0.11))),0.4,'-短线5%'),colorB7D16F;
PARTLINE((DIFF >= DEA),(DIFF AND (DIFF >= 0))),LINETHICK2,colorFF;
PARTLINE(((DIFF >= DEA) AND (DIFF <= 0)),DIFF),LINETHICK2,colorFF00FF;
PARTLINE(((DIFF <= 0) AND (DIFF <= DEA)),DIFF),LINETHICK1,colorFF00;
PARTLINE((DIFF >= 0),DIFF),LINETHICK2,colorFF;
PARTLINE((MACD >= 0),MACD),LINETHICK0,colorFF;
PARTLINE((MACD <= 0),MACD),LINETHICK0,colorFFFF00;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
BB:(0.7 * ((((((CROSS(DIFF,DEA) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)) AND CROSS(MACD,0)) AND (MACD >= 0)) AND (DIFF > 0)) AND (((HH - REF(HH,1)) > 0) AND (VOL > REF(VOL,1)))));
DRAWTEXT((((BB >= 0.7) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)),0.7,'。量价配合完美 '),colorFF00;
DRAWTEXT((((BB >= 0.7) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)),0.7,'。 (追)'),colorFF;
MA1:=MA(CLOSE,P1);
MA2:=MA(CLOSE,P2);
N15HIGH:=REF(HIGH,15);
N1LOW:=REF(LOW,1);
FF:=(((N15HIGH - N1LOW) / N1LOW) > 0.15);
STICKLINE(((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))),0,0.5,0,1),LINETHICK3,colorFF;
DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))),0.5,1);
DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))),0.5,'★^回头望月'),colorFF0000;
VAR10:=(((CLOSE - MA(CLOSE,58)) / MA(CLOSE,58)) * 100);
VAR11:=((((VAR10 > (1 * REF(VAR10,1))) AND (VAR10 < 选股)) AND (VAR10 > 抄底)) * 1.5);
VAR12:=((VOL / CAPITAL) * 100);
VAR13:=LLVBARS(LOW,50);
VAR14:=SUM(VOL,VAR13);
VAR15:=HHVBARS(HIGH,50);
VAR16:=SUM(VOL,VAR15);
VAR17:=(((CLOSE - REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);
VAR18:=((VAR16 / CAPITAL) * 100);
VAR19:=(((CLOSE - REF(OPEN,VAR13)) / REF(OPEN,VAR13)) * 100);
VAR20:=((VAR14 / CAPITAL) * 100);
VAR21:=MA(CLOSE,3);
VAR22:=(REF(CLOSE,2) * 0.865);
VAR23:=(REF(CLOSE,13) * 0.772);
VAR24:=MIN(VAR22,VAR23);
VAR25:=MA(CLOSE,13);
抄底王:(IF((((((CLOSE - VAR24) / CLOSE) < 0.03) AND (VAR17 < (0 - 35))) AND ((SUM(VAR12,5) / 5) < 1.8)),1,0) * 0.4),LINETHICK3,colorFF0000;
DRAWTEXT((抄底王 > 0),抄底王,'.★抄底王'),LINETHICK3,colorFFFFFF;
DRAWTEXT((抄底王 > 0),抄底王,' (成功率90%)'),LINETHICK3,colorFF00;
{www.gupang.com 股旁网_飞狐股票指标公式}
VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
VAR28:=EMA(VAR27,9);
VAR29:=(2 * (VAR27 - VAR28));
STICKLINE(((VAR27 < (0 - 50)) AND (VAR26 > 7)),0,(0 - 0.1),5,0),colorFF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 < VAR28)),(0 - 0.08),''),colorFFFFFF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 >= VAR28)),(0 - 0.1),''),colorFFFFFF;
VAC:=(LOW * 0.9);
VAB:=EMA(LLV(LOW,90),21);
VAD:=(((VAC * VOL) + (VAB * (CAPITAL - VOL))) / CAPITAL);
VAE:=EMA(VAD,30);
VAF:=(CLOSE - REF(CLOSE,1));
VA10:=MAX(VAF,0);
VA11:=ABS(VAF);
VA12:=((SMA(VA10,7,1) / SMA(VA11,7,1)) * 100);
VA13:=((SMA(VA10,13,1) / SMA(VA11,13,1)) * 100);
VA14:=((SMA(MAX(VAF,0),6,1) / SMA(ABS(VAF),6,1)) * 100);
VA15:=((((0 - 200) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 100);
VA16:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
VA17:=SMA(((SMA(VA16,4,1) - 50) * 2),3,1);
VA18:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
VA19:=SMA(VAR18,4,1);
VA1A:=SMA(VAR19,3,1);
VA1B:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
VA1C:=((((((((VAR14 <= 25) AND (VA15 < (0 - 95))) AND (VA1B > 20)) AND (VA17 < (0 - 30))) AND (VA1A < 30)) AND ((VAE - CLOSE) >= (0 - 0.25))) AND (VA12 < 22)) AND (VA13 < 28));
低买1:=STICKLINE(VA1C,0,0.1,1,1);
发射:STICKLINE(VA1C,0,0.7,2,0),LINETHICK2,colorFF;
DRAWTEXT((VA1C > 0),0.7,'^★发射'),colorFFFFFF;

飞狐超级MACD指标公式

 

相关文章