在线检测未来函数

通达信短线与中长线强弱分界大胜买卖指标公式

来源:Internet,编辑:股旁网,2012-02-18

F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
STICKLINE(A1 AND A2 ,0,50,3,0)COLORGREEN;
STICKLINE(A1 AND A2 ,0,30,3,0)COLORBLUE;
STICKLINE(A1 AND A2 AND A3,0,50,3,0)COLORYELLOW;
STICKLINE(A1 AND A2 AND A3,0,30,3,0)COLORFF00FF;
STICKLINE(A1 AND A2 AND A3,0,10,3,0)COLORBLUE;
DRAWTEXT(A3=1,4.8,'长攻!'),COLORSTICK;
智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG
(3,6),2),COLORWHITE,LINETHICK2;
DRAWTEXT(智勇出击=1,0.10,'突袭!'),COLORWHITE;
小获且退: ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG
(3,10),2),COLORYELLOW,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(小获且退=1,1.3,'退!'),COLORGREEN;
VAR5:=5;
顶:=IF(VAR5=2,2,0);
大胜:IF(顶>REF(顶,1),2,0),COLORRED,LINETHICK2;
DRAWTEXT(大胜=2,2,'撤!'),COLORRED;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3);
D:MA(K,3);
STICKLINE(K>D , K,D ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:85,COLORGREEN;
中轴线: 50,COLORRED;
抄底线:10,COLORGREEN;
DRAWICON(CROSS(K,D),12,1),COLORRED;
DRAWICON(CROSS(D,K),88,2),COLORGREEN;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
高抛: 80;
VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
SK: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13);
SD: EMA(SK,3);
低吸: 20;
强弱分界: 50;

通达信短线与中长线强弱分界大胜买卖指标公式

 

相关文章