在线检测未来函数

大智慧螺旋线指标公式

来源:Internet,编辑:股旁网,2012-02-20

A:=COUNT(C,0)=1;
B:=BARSLAST(A)/8;
螺旋线:SIN(B)*198,COLORRED;
STICKLINE( SIN(B)>=0.99, 0,198 ,10 , 0),colorff00ff;
STICKLINE( SIN(B)<-0.99, 0,-198 ,10 , 0),colorff00ff;
TYP:=(OPEN+HIGH + LOW + CLOSE)/4;
跌卦:(TYP-wMA(TYP,9))/(0.015*AVEDEV(TYP,9)),COLORff3399,linethick2;
{一一二五}A度:HIGH/1.0401; {二十二}B度:{一一二五}A度/1.0401; {三三七五}C度:{二十二}B度/1.0402; {四十五}D度:{三三七五}C度/1.0402; {五十六}E度:{四十五}D度/1.0403;
{六十七}F度:{五十六}E度/1.0403; {七十八}G度:{六十七}F度/1.0404; {九十}H度:{七十八}G度/1.0404; {一百十二}I度:{九十}H度/1.0405; 诱空:{一百十二}I度/1.0405;
STICKLINE(跌卦,0,跌卦*4/5,6,0),COLOR00DDFF;
STICKLINE(跌卦,0,跌卦*3/5,6,0),COLOR0099FF;
STICKLINE(跌卦,0,跌卦*2/5,6,0),COLOR0066FF;
STICKLINE(跌卦,0,跌卦*1/5,6,0),COLOR0000FF;
STICKLINE(跌卦<0,0,跌卦,6,0),COLORCCFFCC;
STICKLINE(跌卦<0,0,跌卦*4/5,6,0),COLOR99FF99;
STICKLINE(跌卦<0,0,跌卦*3/5,6,0),COLOR66CC66;
STICKLINE(跌卦<0,0,跌卦*2/5,6,0),COLOR339933;
100,POINTDOT,COLORyellow;
-100,POINTDOT,COLORyellow;
VAR4:=wMA(CLOSE,2);
VAR5:=wMA(CLOSE,13);
VAR6:=wMA(CLOSE,34);
VAR7:=wMA(CLOSE,60);
VAR8:=wMA(COST(90),2);
VAR9:=wMA(COST(13),2);
VARA:=(SUM(((CLOSE * VOL) * 100),4) / SUM((VOL * 100),4));
VARB:=(INTPART((VARA * 100)) / 100);
VARC:=(SUM(((CLOSE * VOL) * 100),7) / SUM((VOL * 100),7));
VARD:=(INTPART((VARC * 100)) / 100);
VARE:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));
{www.gupang.com 股旁网_大智慧股票指标公式}
VARF:=(INTPART((VARE * 100)) / 100);
VAR10:=((0 - ((100 * (HHV(CLOSE,2) - CLOSE)) / (HHV(CLOSE,2) - LLV(LOW,2)))) + 100);
VAR11:=((0 - ((100 * (HHV(CLOSE,13) - CLOSE)) / (HHV(CLOSE,13) - LLV(LOW,13)))) + 100);
VAR12:=((0 - ((100 * (HHV(CLOSE,34) - CLOSE)) / (HHV(CLOSE,34) - LLV(LOW,34)))) + 100);
VAR13:=((0 - ((100 * (HHV(CLOSE,60) - CLOSE)) / (HHV(CLOSE,60) - LLV(LOW,60)))) + 100);
短线趋势:=(wMA(CLOSE,2) - wMA(CLOSE,13));
中线趋势:=wMA(短线趋势,13);
VAR14:=REF(中线趋势,1);
VAR16:=(中线趋势 - VAR14);
VAR17:=REF(短线趋势,1);
VAR19:=(短线趋势 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
发现机构入场:IF((((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)),100,0),LINETHICK2,color66FF00;

大智慧螺旋线指标公式

 

相关文章