在线检测未来函数

通达信一手买卖主图指标公式

来源:Internet,编辑:股旁网,2012-02-21

M5:MA(CLOSE,5);
黄金线:EMA(C,18),POINTDOT,LINETHICK4,COLORYELLOW;
M30:MA(CLOSE,30);
M60:MA(CLOSE,60);
M90:MA(CLOSE,90);
{www.gupang.com 股旁网_通达信股票指标公式}
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
BUY:=ZIG(3,10);
SELL:=MA(BUY,2);
DRAWICON(CROSS(BUY,SELL),L-0.1,7);
DRAWICON(CROSS(SELL,BUY),H+0.1,8);
STICKLINE(BUY>SELL AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(BUY>SELL AND O>=C,L,H,0,0),COLORRED;
STICKLINE(BUY<SELL AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(BUY<SELL AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(BUY<SELL AND O<=C,C,H,0,1),COLORCYAN;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
LJB:=1/WINNER(CLOSE);
STICKLINE(LJB>10,L-0.45,L-0.4,-1,1),COLORYELLOW;
平均:=(L+H)/2;
KB:=ZIG(平均,10);
KS:=MA(KB,2);
DRAWICON(CROSS(KB,KS),L-0.2,1);
DRAWICON(CROSS(KS,KB),H+0.2,2);

通达信一手买卖主图指标公式

 

相关文章