在线检测未来函数

通达信信天翁动态量指标公式

来源:Internet,编辑:股旁网,2012-02-23

A股:CAPITAL/1000000,COLORWHITE;
换手:VOL/CAPITAL*100,POINTDOT;
外内比:DYNAINFO(51);
五换:SUM(换手,5);
十换:SUM(换手,10);
二十换:SUM(换手,20);
持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
获利比:WINNER(CLOSE)*100;
A:=PERIOD;
N:=IF(A=0,1,IF(A=1,5,IF(A=2,15,IF(A=3,30,IF(A=4,60,IF(A=5,240,DRAWNULL))))));
M:=IF(N=1,IF(MOD(FROMOPEN,1)=0,1,
MOD(FROMOPEN,1)),IF(N=5,IF(MOD(FROMOPEN,5)=0,5,
MOD(FROMOPEN,5)),IF(N=15,IF(MOD(FROMOPEN,15)=0,15,
MOD(FROMOPEN,15)),IF(N=30,IF(MOD(FROMOPEN,30)=0,30,
MOD(FROMOPEN,30)),IF(N=60,IF(MOD(FROMOPEN,60)=0,60,
MOD(FROMOPEN,60)),IF(N=240,FROMOPEN,DRAWNULL))))));
虚拟:IF(CURRBARSCOUNT=0,V*N/M,DRAWNULL),NODRAW,COLORWHITE;
STICKLINE(CURRBARSCOUNT=0 AND N,虚拟,0,6,-1),COLORFFFFFF;
现量:VOL,NODRAW;
放量:(VOL/REF(VOL,1)>=1.5 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1)
AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.5);
DRAWTEXT(放量,VOL*1.05,'放'),COLORWHITE;
倍量:=(VOL/REF(VOL,1)>=2.5 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1)
AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>2.5);
DRAWTEXT(倍量,VOL*1.15,'倍'),COLORGREEN;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED;
主卖:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,6,0),COLORCYAN;
STICKLINE(CLOSE>=REF(CLOSE,1) ,0,VOL,6,0),COLORRED;
STICKLINE(主买>0,0,主买,6,0),COLORRED;
STICKLINE(主卖<0 ,主买,主买,6,0),COLORGREEN;MA5:EMA(VOL,5),COLORWHITE,LINETHICK1;
MA10:EMA(VOL,10),COLORYELLOW,LINETHICK1;
MA20:EMA(VOL,20),COLORGRAY,LINETHICK2;
MA90:EMA(VOL,90),COLORBLUE,LINETHICK2;
MA3买:EMA(主买,3),COLORRED,LINETHICK1;
MA5买:EMA(主买,5),COLORMAGENTA,LINETHICK1;
MA10买:EMA(主买,10),COLORRED,LINETHICK1;
MA20买:EMA(主买,20),COLORYELLOW,LINETHICK2;
MA20买均:EMA(MA20买,2),COLORYELLOW,LINETHICK1;
MA5卖:EMA(ABS(主卖),5),COLORGREEN,LINETHICK1;
MA10卖:EMA(ABS(主卖),10),COLORCYAN,LINETHICK1;
MA20卖:EMA(ABS(主卖),20),COLORBLUE,LINETHICK3;
资金异动:VOL/EMA(VOL,60)*100,COLORYELLOW;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(资金异动>=227,0,VOL,2,0),COLORYELLOW;
DRAWTEXT(资金异动 AND (CROSS(VOL,MA90)) AND (MA5>MA10) AND (MA10>MA20) AND (MA20>MA90) AND (MA5买>MA5卖) AND (MA5买>MA10买)AND (MA10买>MA10卖) AND (MA20买>MA20卖),(VOL *1.3),'缩卖'),COLORYELLOW;
DRAWTEXT(倍量 AND (CROSS(VOL,MA90)) AND (MA5>MA10) AND (MA10>MA20) AND (MA10>MA90) AND (MA5买>MA5卖) AND (MA5买>MA10买) AND (MA10买>MA10卖) AND (MA20买>MA20卖),(VOL *1.3),'缩卖'),COLORGREEN;
DRAWTEXT(CROSS(MA5买,MA10买) AND (VOL>MA90) AND (CROSS(MA5买,MA20买)) AND (CROSS(MA10买,MA10卖)) AND (CROSS(MA10买,MA20卖)) AND (CROSS(MA20买,MA20卖)),(VOL *0.15),'买'),COLORWHITE;
DRAWTEXT(CROSS(MA3买,MA5买) AND (VOL>MA90) AND (CROSS(MA5买,MA20买)) AND (CROSS(MA10买,MA10卖)) AND (CROSS(MA10买,MA20卖)) AND (CROSS(MA20买,MA20卖)),(VOL *0.1),' 买'),COLORGREEN;
DRAWTEXT(CROSS(MA3买,MA10买) AND (VOL>MA90) AND (CROSS(MA5买,MA20买)) AND (CROSS(MA10买,MA10卖)) AND (CROSS(MA10买,MA20卖)) AND (CROSS(MA20买,MA20卖)),(VOL *0.05),'买'),COLORYELLOW;

通达信信天翁动态量指标公式

 

相关文章