在线检测未来函数

飞狐主买主卖指标公式

来源:Internet,编辑:股旁网,2012-02-29

input:n(27,1,30),n2(9,1,10),n3(3,1,5),n4(16,1,18);
Q:=1;
V1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,V1*(HIGH-LOW),IF(CLOSE<OPEN,V1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),Color6d0076,POINTDOT,LINETHICK0;
主卖:IF(CLOSE>OPEN,0-V1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-V1*(HIGH-LOW),0-VOL/2)),ColorFFD1BE,POINTDOT,LINETHICK0;
净买:主买+主卖,COLORRED,LINETHICK0;
STICKLINE(主买<(-主卖) , v,0,8,1) COLORCYAN;
STICKLINE(主买>=(-主卖) , v*1.01,0,8,1) colorred,LINETHICK2;
K5:=(VOL > (REF(HHV(VOL,10),1) * 2));
DRAWTEXT((K5 > 0),(VOL * 1.05),'关注'),COLORWHITE,ALIGN;
STICKLINE((K5 > 0),0,VOL,7,0),colorFFFF;
VAR1:=1;
VAR2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VAR3:=SMA(VAR2,3,1)*VAR1;
VAR4:=SMA(VAR3,N2,1)*VAR1;
VAR5:=3*VAR3-2*VAR4*VAR1;
VAR6:=VOL*VAR1;
STICKLINE(VOL AND VAR5>VAR4,0,VOL,3,0),COLORMAGENTA;
STICKLINE(VOL AND VAR5<VAR4,0,VOL,3,0),COLORGREEN;
STICKLINE(VOL AND VAR4<N4,-10,VOL*0.5,3,0),COLORBLUE;
MA60:MA(VOL,60),colorred,LINETHICK2;
V5: MA(VOL,5),COLORWHITE;
V34: MA(VOL,34),COLORYELLOW;
获利盘: WINNER(CLOSE)*100*VAR1;
量比: VOL/MA(VOL,5)*VAR1;
涨跌: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100*VAR1;
角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100*VAR1;
换手: VOL/CAPITAL*100*VAR1;
VAR7:=SUM(换手,30)*VAR1;
VAR8:=LLV(INDEXL,5)*VAR1;
VAR9:=HHV(INDEXH,5)*VAR1;
VARA:=EMA((INDEXC-VAR8)/(VAR9-VAR8)*100,4);
VARB:=MA(EMA(0.667*REF(VARA,1)+0.333*VARA,2),9);
VARC:=MA(VARB,30);
VARD:=EMA(获利盘,4)*VAR1;
振幅: (HIGH-LOW)/REF(CLOSE,1)*100;
VARE:=MA(V5,3);
VARF:=(涨跌>VARD AND 角度<-30 AND 涨跌>3)*VAR1;
abc:CROSS(VARB,VARC) AND VARC<29*VAR1;
当天换手:=(((VOL / CAPITAL) * 100) * Q);
AAA:=((SUM(VOL,5) / 3) * Q);
{www.gupang.com 股旁网_飞狐股票指标公式}
量能线:MA(AAA,3),COLORBROWN,LINETHICK2;
量能异动:(VOL > 量能线),COLORBROWN;
DRAWICON((VOL > 量能线),量能线,12);
DRAWICON(((CLOSE > REF(CLOSE,1)) AND (VOL > 量能线)),v*1.1,8);
VAR15:=((WINNER(CLOSE) * 100) * Q);
筹码穿透:CROSS(VAR15,50),LINETHICK0,colorFFFF;

飞狐主买主卖指标公式

 

相关文章