在线检测未来函数

通达信峰谷买卖指标公式

来源:Internet,编辑:股旁网,2012-02-29

AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3,COLORWHITE;
段: VAR4,COLORYELLOW;
VAR6:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR6,10)=1,40,'买'),LINETHICK1,COLOR00AAFF;
STICKLINE(FILTER(VAR6,10)=1,0,90,10,0),COLORRED;
VAR7:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR7,5)=1,0,90,10,0),COLORGREEN ;
DRAWTEXT(FILTER(VAR7,5)=1,70,'卖'),LINETHICK1,COLORFFCC66;
趋势:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORWHITE;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
VAR9:=CROSS(趋势,VAR2) AND 趋势<20 AND 趋势<段;
分批卖出:STICKLINE(VAR8,50,90,10,0),COLOR008360,LINETHICK3;
分批买入:STICKLINE(VAR9,40,0,10,0),COLOR000080,LINETHICK3;
90,COLORGREEN ;
0,COLORYELLOW ;
VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
资金入场:VAR02,COLORRED;
BAR1:=REF(LOW,1);
BAR2:=SMA(ABS(LOW-BAR1),13,1)/SMA(MAX(LOW-BAR1,0),13,1)*4;
BAR3:=EMA(BAR2,13);
BAR4:=LLV(LOW,34);
BAR5:=EMA(IF(LOW<=BAR4,BAR3,0),3);
BAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
BAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
BAR8:=BAR6<REF(BAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
散户:STICKLINE(BAR5>REF(BAR5,1),0,BAR5,5,0),COLORGREEN,LINETHICK1;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,0,18,5,0),COLORBLUE,LINETHICK3;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,18,36,5,0),COLORFF7700,LINETHICK3;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,36,60,10,0),COLORYELLOW;
DRAWTEXT(BAR8 AND COUNT(BAR8,30)=1,90,'主力进场★'),COLORYELLOW;
{www.gupang.com 股旁网_通达信股票指标公式}
RE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
R12:=(HIGH+LOW+CLOSE)/3;
R13:=(R12-MA(R12,14))/(0.015*AVEDEV(R12,14));
R14:=(R12-MA(R12,70))/(0.015*AVEDEV(R12,70));
R15:=IF(R13>=150 AND R13<200 AND R14>=150 AND R14<200,10,0);
R16:=IF(R13<=-150 AND R13>-200 AND R14<=-150 AND R14>-200,-10,R15);
R17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
R18:=100-ABS(R17);
R19:=IF(R18<90,R18,100);
R1A:=IF(RE>0,RE,0);
R1B:=IF(R14>=200 AND R13>=150,15,IF(R14<=-200 AND R13<=-150,-15,R16))+60;
R1C:=R1A>48 AND R1B>60 AND R19<100;
DRAWTEXT(R1C AND COUNT(R1C,25)=1,80,'分批出货'),LINETHICK1,COLORFFCC66;
STICKLINE(R1C AND COUNT(R1C,25)=1,90,60,5,0),COLORFFCC66;

通达信峰谷买卖指标公式

 

相关文章