在线检测未来函数

通达信漓江渔歌主图指标公式

来源:Internet,编辑:股旁网,2012-02-27

下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
底:=CONST(底部);
STICKLINE(ISLASTBAR ,压力位,压力位,25,0),LINETHICK2,COLORFFFFFF;
STICKLINE(ISLASTBAR ,底部位,底部位,20,0),LINETHICK2,COLOR00FFFF;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
VAR3:=IF(C<200 ,MA(COST(80),3),2500),NODRAW;
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),2330);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));
短买春:=R19,NODRAW,COLOR00DD00;
秋离场:=R1A,NODRAW,COLOR2288EE;
持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
阴观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,NODRAW,COLOR999999;
{www.gupang.com 股旁网_通达信股票指标公式}
急速超跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
离场:=IF(红持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
进:=IF(阴观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:=REF(明进场价,1),COLOR00FF00,NODRAW;
大雪:=MA((((HIGH + LOW) + CLOSE) / 3),8);
无痕:=MA((((HIGH + LOW) + CLOSE) / 3),21);
VAR111:=EMA(((OPEN + CLOSE) / 2),26);
VAR222:=IF(C<200 , MA(COST(30),3),2300),NODRAW;
天下有雪:=IF(C<200 ,MA(COST(50),3),2300);
严冬:=ISLASTBAR AND (VAR4 > 0.1),COLORFFFFFF,NODRAW;
早春:=ISLASTBAR AND (((((VAR4 < 天下有雪) AND (VAR4 > 无痕))
OR ((VAR4 < VAR5) AND (VAR4 > 无痕))) OR ((VAR4 > 无痕)
AND (VAR111 > 无痕)))),COLOR00FF00,NODRAW;
初夏:=ISLASTBAR AND ((((((VAR4 > 天下有雪) AND (VAR4 > VAR111))
AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))))),
COLOR0000FF,NODRAW;
深秋:=ISLASTBAR AND (((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕))
AND (VAR111 > REF(VAR111,1)))),COLOR00FFFF,NODRAW;
SAAA:=(3*C+H+L+O)/6;
SVAR1:=(8*SAAA+7*REF(SAAA,1)+6*REF(SAAA,2)
+5*REF(SAAA,3)+4*REF(SAAA,4)+3*REF(SAAA,5)+2*REF(SAAA,6)+REF(SAAA,8))/36;
SVAR2:=(HHV(SVAR1,5)+HHV(SVAR1,10)+HHV(SVAR1,20))/3;
SVAR3:=(LLV(SVAR1,5)+LLV(SVAR1,10)+LLV(SVAR1,20))/3;
SVAR4:=(HHV(SVAR2,5)+HHV(SVAR2,10)+HHV(SVAR2,20))/3;
SVAR5:=(LLV(SVAR3,5)+LLV(SVAR3,10)+LLV(SVAR3,20))/3;
SVAR6:=(LLV(SVAR1,2)+LLV(SVAR1,4)+LLV(SVAR1,6))/3;
Q1:=CONST(IF(短买春,0,IF(秋离场,150,IF(红持股,200,IF(急速超跌关注,150,100))))),NODRAW;
Q2:=CONST(IF(短买春,80,IF(秋离场,100,IF(红持股,0,IF(急速超跌关注,150,100))))),NODRAW;
Q3:=CONST(IF(短买春,0,IF(秋离场,20,IF(红持股,70,IF(急速超跌关注,150,100))))),NODRAW;

STICKLINE(ISLASTBAR AND (红持股 OR REF(红持股,1)=1),今离场价,今离场价,35,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (阴观望 OR REF(阴观望,1)=1),今进场价,今进场价,35,1),COLOR00FF00;
NN:=60;
最高:=CONST(HHV(H,NN));
最低:=CONST(LLV(L,NN));
RCC:=最高*0.9-(最高-最低);
RCC1:=最高-(最高-最低)/2;
RHL:=RCC;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
DI:=EMA(C,3)-EMA(C,13);
DE:=EMA(DI,9);
MACD1:=2*(DI-DE)*10;
DI2:=EMA(C,5)-EMA(C,26);
DEA2:=EMA(DI2,9);
MACD2:=2*(DI2-DEA2)*10;
DIFF3:=EMA(C,7)-EMA(C,89);
DEA3:=EMA(DIFF3,21);
MACD3:=2*(DIFF3-DEA3)*10;
MMACD5:=MA(MACD3,3);
M3:=IF(MACD3<0,-MACD3,DRAWNULL)LINETHICK4,COLOR646400,NODRAW;
M2:=IF(MACD2<0,-MACD2,DRAWNULL)LINETHICK4,COLOR333333;
M1:=IF(MACD1<0,-MACD1,DRAWNULL);
MM3:=IF(MACD3>0,MACD3,DRAWNULL),NODRAW;
MN1:=HHV(MM3,90);
MN2:=HHV(M3,90);
MMM:=CONST(MAX(MN1,MN2));
DRAWBAND((MMM)/5+RCC1,RGB(50,80,50),RCC-0.0*RCC,DRAWNULL);
DRAWBAND((MMM)/5+RCC1,RGB(Q1,Q2,Q3),0+RCC1,DRAWNULL);
DRAWBAND((M3)/5+RCC1,RGB(00,100,100),0+RCC1,DRAWNULL);
DRAWBAND((M2)/5+RCC1,RGB(100,100,100),0+RCC1,DRAWNULL);
DRAWBAND((M1)/5+RCC1,RGB(80,80,00),0+RCC1,DRAWNULL);
DRAWBAND((MM3)/5+RCC1,RGB(0,200,0),0+RCC1,DRAWNULL);
STICKLINE(MACD2>=0,+RCC1,(MACD2)/5+RCC1,4,0),COLOR009900;
STICKLINE(MACD1>=0,RCC1,(MACD1)/5+RCC1,4,0),COLOR006600;
MM:=-M3*0.3;
MMA:=IF(MACD3>=0,MACD3,-MACD3);
DRAWBAND((0+RCC1),RGB(0,50,0),(-MMA*0.3)/5+RCC1,DRAWNULL);
IF(MACD3>0,-3/5+RCC1,DRAWNULL),COLORFFFF00,POINTDOT;
IF(C>0,-2/5+RCC1,-2/5+RCC1),COLORFFFF00,POINTDOT;
小花买入:IF(MACD1>=0 AND REF(MACD1,1)<0,1/5+RCC1,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(MACD1>=0 AND REF(MACD1,1)<0,1/5+RCC1,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
白帆买入:STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,(MACD3*1.1)/7+RCC1,(MACD3*1.1-0.3)/7+RCC1,16,0),COLORLIRED;
STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,(MACD3*1.1+1.1)/7+RCC1,(MACD3*1.1+0.1)/7+RCC1,5,0),COLORCCCCCC;
MA(C,5);
MA(C,10);
MA(C,30),COLOR00DDDD;
MA(C,60),COLORDDDDDD;
FD:=(H-L)/3;
OPEN1:=O>FD*2+L;
OPEN3:=O<FD+L;
OPEN2:=NOT(OPEN1 OR OPEN3);
CLOSE1:=C>FD*2+L;
CLOSE3:=C<FD+L;
CLOSE2:=NOT(CLOSE1 OR CLOSE3);
DFZD:=CLOSE1 OR (OPEN3 AND CLOSE2);
WQS1:=OPEN2 AND CLOSE2;
KFZD:=NOT(DFZD OR WQS1);
ZD:=(H+L)/2;
QSXS:=ZD>REF(H,1);
QSXX:=ZD<REF(L,1);
WQS2:=NOT(QSXS OR QSXX);
ZTDL:=V>REF(V,1)*1.1;
FTDL:=V<REF(V,1)*0.7;
ZTDL2:=ZTDL AND FTDL<1;
FTDL2:=FTDL AND ZTDL<1;
MFI1:=(H-L)/(V/10000);
MFI2:=(H-L)/(V/1000000);
ZMFI1:=MFI1>REF(MFI1,1);
ZMFI2:=MFI2>REF(MFI2,1);
ZMFI:=ZMFI1 OR ZMFI2;
FMFI:=NOT(ZMFI);
LD:=ZTDL2 AND ZMFI;
ST:=FTDL2 AND FMFI;
WZ:=FTDL2 AND ZMFI;
QF:=ZTDL2 AND FMFI;
S1:=DFZD AND QSXS ;
S2:=KFZD AND QSXX ;
S3:=DFZD AND QSXX;
S4:=KFZD AND QSXS;
S5:=DFZD AND WQS2;
S6:=KFZD AND WQS2;
S7:=WQS1 AND (QSXS OR QSXX OR WQS2);
DRAWKLINE(H,O,L,C);
STICKLINE(S2 ,C ,O,3,0 ),COLORFF2020;
STICKLINE(S1,C,O,3 ,0 ),COLOR2020FF;
STICKLINE(S3,C,O,3,0),COLORYELLOW;
STICKLINE(S4,C,O,3,0),COLORFFCC66;
STICKLINE(S5,C,O,3,0),COLORFF00FF;
STICKLINE(S6,C,O,3,0),COLOR00FF00;
STICKLINE(S7,C,O,3,0),COLORGRAY;
STICKLINE(1,C,O,0,0),COLOREEEEEE;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
V最高:=CONST(HH);
V最低:=CONST(LL);
V最高2:=CONST(HHV(H,NN));
V最低2:=CONST(LLV(L,NN));
P:=(V最高-V最低)/(V最高2-V最低2)*2,NODRAW;
比:=TT;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
买卖差:=买盘-卖盘;
STICKLINE(C>=O,RCC,(买盘+卖盘)/P+RCC,2.8,1),COLORRED;
STICKLINE(C<O,RCC,(买盘+卖盘)/P+RCC,2.8,1),COLORFFFF00;
STICKLINE(买卖差>=0,RCC,买盘/P+RCC,2.5,0),COLORRED;
STICKLINE(买卖差>=0 AND C>=MA(C,30),RCC,买盘/P+RCC,3.0,0),COLORRED;
STICKLINE(买卖差>=0,RCC,卖盘/P+RCC,1.1,0),COLOR998800;
STICKLINE(买卖差>=0 AND C>=MA(C,30),RCC,卖盘/P+RCC,1.5,0),COLORDDCC00;
STICKLINE(买卖差<0,RCC,买盘/P+RCC,2.5,0),COLORRED;
STICKLINE(买卖差<0 AND C>=MA(C,30),RCC,买盘/P+RCC,3.0,0),COLORRED;
STICKLINE(买卖差<0,RCC,卖盘/P+RCC,1.1,0),COLOR998800;
STICKLINE(买卖差<0 AND C>=MA(C,30),RCC,卖盘/P+RCC,1.5,0),COLORDDCC00;
DRAWTEXT_FIX(1,0 ,0.06,0,' 红持股、灰持币、绿买黄卖在春秋。 '),COLORGREEN;
DRAWTEXT_FIX(1,0 ,0.16,0,' 青山难爬、南(兰)山观境、红花小舟话丰收。 '),COLORGREEN;

通达信漓江渔歌主图指标公式

 

相关文章