在线检测未来函数

通达信皮夹子主图指标公式

来源:Internet,编辑:股旁网,2012-02-28

MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
明日均线:=REF(C,2)*2-REF(C,5),LINETHICK0,COLOR550055 ;
后日均线:=REF(C,1)*2-REF(C,4),LINETHICK0,COLOR008800;
大后天均线:=C*2-REF(C,3),LINETHICK0,COLOR008888;
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:= - 100 * (趋势线 - CLOSE) / 趋势线;
AC:=(EMA(AA,5) );
SSL:=EMA(CLOSE,5);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=(IF(((DAY > 5) AND (DAY < 9)),MA(MMV,1),IF((DAY = 5),MA(MMV,4)
,IF((DAY = 4),MA(MMV,8),IF((DAY = 3),MA(MMV,16)
,IF((DAY = 2),MA(MMV,32),1))))) );
{STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),COLORRED;}
SA:=(MM * 0.985);
SS:=(MA(CLOSE,18));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
皮夹子:IF(((SSL>MM)),SS,SA),COLORFF00FF,LINETHICK2;
K1:=BACKSET(皮夹子<REF(皮夹子,1),2);
IF(K1,皮夹子,DRAWNULL),COLORFFFFCC,LINETHICK2;
VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) - (2 * VARAY));
VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));
DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.01),2),COLORFFFFFF;
{www.gupang.com 股旁网_通达信股票指标公式}
VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);
VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),4);
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
B:REF(A,1),POINTDOT,COLORYELLOW,LINETHICK4;
红包:A,COLORYELLOW,LINETHICK1;
STICKLINE(红包>皮夹子,红包,皮夹子,0.01,1),COLOR0000FF;
STICKLINE(红包<皮夹子,红包,皮夹子,0.01,1),COLORCYAN;
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(VA2,VA1),H+0.12,'止\N损')COLORYELLOW;
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 红包>REF(红包,1),VA1*0.98,'★买入'),COLOR00FF00;
选手A:=MA(上收,3);
箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);
T1:=MA(上收,20)>=REF(MA(上收,20),1);
T2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND T1;
T3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
选手:=MA(上收,2);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
IF(A>REF(A,1),A,DRAWNULL),COLORYELLOW,LINETHICK5;
IF(A<REF(A,1),A,DRAWNULL),COLORGREEN,LINETHICK1;

通达信皮夹子主图指标公式

 

相关文章