在线检测未来函数

通达信买量极限度指标公式

来源:Internet,编辑:股旁网,2012-03-01

N:=106;N1:=83;
AA:=IF(DATE<=1091231,1,0);
BB:=FLOOR(SUM(V/CAPITAL,0));
【手】:VOL,LINETHICK,COLOR00FFFF;
CC:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,CC,0,-1,-1),COLOR00C0C0;{虚拟成交}
额【亿】:AMOUNT/100000000,NODRAW;
CB:=IF(CAPITAL>1,AMOUNT/VOL/100,(HIGH+LOW+2*CLOSE)/4);
空1:=IF((HIGH-LOW)>0 AND CLOSE>CB, ((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CB)/(HIGH-LOW)*VOL) ,0);
{www.gupang.com 股旁网_通达信股票指标公式}
多1:=IF((HIGH-LOW)>0 AND CLOSE>CB, VOL-空1 ,0);
多2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, ((CLOSE-LOW)/(CB-LOW))*((CLOSE-LOW)/(CB-LOW))*((CB-LOW)/(HIGH-LOW)*VOL) ,0);
空2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, VOL-多2 ,0);
多3:=IF((HIGH-LOW)=0 AND CLOSE>REF(CLOSE,1), VOL,0);
空3:=IF((HIGH-LOW)=0 AND CLOSE<=REF(CLOSE,1), VOL,0);
多方量:=多1+多2+多3;
空方量:=空1+空2+空3;
买卖差:(多方量-空方量)/1000;
成交流通比:AMOUNT/CAPITAL/100,LINETHICK0;
内外比:DYNAINFO(51),NODRAW;
市盈率:DYNAINFO(39),COLORDDDD00,NODRAW;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
中点:=REFDATE(HHV(V,N)/2,DATE);
昨日换:REF(DYNAINFO(37),1)*AA,NODRAW, COLOR0000DD;
5日换:SUM(100*V/CAPITAL,5),LINETHICK0;
DRAWTEXT(CURRBARSCOUNT=N,中点*1.3,'量能饱和度:'),COLORDDDD00;
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱和,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和,0),COLOR00DDFF;
STICKLINE(CLOSE>0,【手】,0,3.6,0),COLOR00CC00;
STICKLINE(CLOSE>REF(CLOSE,1),【手】,0,2.6,0),COLOR003388;
STICKLINE(CLOSE>REF(CLOSE,1),【手】,0,1.8,0),COLOR00AADD;
STICKLINE(CLOSE<=REF(CLOSE,1),【手】,0,2.6,0),COLOR666600;
STICKLINE(CLOSE<=REF(CLOSE,1),【手】,0,1.8,0),COLOR999900;
STICKLINE(空方量,-【手】,O,3,0),COLOR005500;
STICKLINE(空方量,-【手】,O,2,0),COLOR007700;
STICKLINE(空方量,-【手】,O,1,0),COLOR009900;
STICKLINE(空方量,-【手】,0,0,0),COLOR00CC00;
STICKLINE(多方量,多方量,O,2.6,0),COLOR000099;
STICKLINE(多方量,多方量,O,2,0),COLOR0000AA;
STICKLINE(多方量,多方量,O,1,0),COLOR0000DD;
STICKLINE(多方量,多方量,O,0,0),COLORAA33DD;

通达信买量极限度指标公式

 

相关文章