在线检测未来函数

飞狐股海明灯主图指标公式

来源:Internet,编辑:股旁网,2012-03-03

ma3:ma(c,5),color000999;
ma10:ma(c,10),color008364;
ma21:ma(c,21),colorgray;
Var1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
Var2:=MA(Var1,5);
Var3:=MA(Var1,10);
股海明灯: DRAWTEXT(FILTER(MA(Var1,10)<Var2,1),Var3,'!'),colorwhite ;
空方敌机: DRAWTEXT(FILTER(MA(Var1,10)>=Var1,1),Var3,'~'),colorgreen ;
x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
stickline(x2>=x3,low,high,0.1,1),colorred;
stickline(x2>=x3,close,open,10,1),colorred;
stickline(x2>=x3,close,open,9,9),colore66878;
stickline(x2<x3,low,high,0.1,1),colorGREEN;
stickline(x2<x3,close,open,10,1),colorGREEN;
stickline(x2<x3,close,open,9,1),colorff937f;
{www.gupang.com 股旁网_飞狐股票指标公式}
stickline(CROSS(X2,X3),open,close,6,0),colorYELLOW;
stickline(CROSS(X3,X2),open,close,6,0),colorBLUE;
Var1:=REF(CLOSE,1);
Var2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
Var3:=(CLOSE-Var1)*Var2;
Var4:=SUM(Var3,0);
Var5:=SMA(Var4,5,1);
Var6:=SMA(Var4,8,1);
OSC:=Var5-Var6;
OSCMA:=MA(OSC,4);
VD:=SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;
VE:=SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34;
VARW:=(c/ref(c,1)-1)*100<=4;
drawtext(CROSS(OSC,VD) AND VARW,L-0.1,'∧\n加仓'),ALIGN0,COLORRED;
KOH:=L>REF(H,1);
KOL:=H<REF(L,1);
HIF:=L>REF(H,BARSLAST(KOH)+1);
NHIF:=L<=REF(H,BARSLAST(KOH)+1);
LIF:=H<REF(L,BARSLAST(KOL)+1);
NLIF:=H>=REF(L,BARSLAST(KOL)+1);
DRAWICON(HIF AND barslast(koh)<barslast(nhif) and BARSLAST(HIF)<BARSLAST(NHIF),REF(H,BARSLAST(KOH)+1),4),ALIGN0;
DRAWICON(LIF AND barslast(kol)<barslast(nlif) and BARSLAST(LIF)<BARSLAST(NLIF),REF(L,BARSLAST(KOL)+1),5),ALIGN0;

飞狐股海明灯主图指标公式

 

相关文章