在线检测未来函数

大智慧改进优化区间成本主图指标公式

来源:Internet,编辑:股旁网,2012-03-04

input:N(1,1,9999),M(1,1,9999);
A1:=BARSTATUS=2 ;
C1:=BACKSET(a1,n);
D1:=FILTER(C1,n-1);
VERTLINE( d1,1 );
A2:=BARSTATUS=2 ;
C2:=BACKSET(a2,m);
D2:=FILTER(C2,m-1);
VERTLINE( d2,1 );
周期:abs(n-m) + 1,linethick0;
结束点:=if(n>m,d2,d1);
成交额:=if(结束点,sum(amount,周期),0);
成交量:=if(结束点,sum(vol,周期),0);
区间均价:=if(CATEGORY=1, 成交额/成交量/100,ref(ma(c,abs(n-m)+1),min(m,n)-1));
区间换手和:=成交量/CAPITAL*100;
N1:=IF(DATATYPE=10,1.05,IF(DATATYPE=9,1.02,1.01));
N2:=IF(DATATYPE=10,0.95,IF(DATATYPE=9,0.98,0.99));
区间换手:REF(区间换手和,BARSLAST(结束点)),linethick0;
区间成本:REF(区间均价,BARSLAST(结束点));
{www.gupang.com 股旁网_大智慧股票指标公式}
上界:REF(区间均价*n1,BARSLAST(结束点)),DOTLINE;
下界:REF(区间均价*n2,BARSLAST(结束点)),DOTLINE;
DRAWTEXTABS(588,20,'成本区间:'+NUMTOSTRN(下界,2)+' - ' +NUMTOSTRN(区间成本,2)
+' - ' + NUMTOSTRN(上界,2)),LAYER0,ColorFFC000;
DRAWTEXTABS(588,40,'区间换手:'+NUMTOSTRN(区间换手,2)),LAYER0,ColorFFC000;

大智慧改进优化区间成本主图指标公式

 

相关文章