在线检测未来函数

大智慧多空轨道主图指标公式

来源:Internet,编辑:股旁网,2012-03-15

X1:=HHV(H,3);
X2:=LLV(L,3);
XX:=(X1+X2)/2;
XC:=C;
XH:=H;
XL:=L;
LYA1:=IF (XH>REF(X1,1) AND XC>REF(XC,1),X2,IF (XL<REF(X2,1) AND XC<REF(XC,1),X1,0));
LYA:=IF(LYA1=0,REF(LYA1,1),LYA1);
SNX2:=IF(LYA<H AND LYA>L,REF(LYA,1),LYA);
多空平衡:EMA(EMA(EMA(HIGH,7.23379625),7.23379625),1),COLORffffff;
强势回挡:多空平衡*0.9276620375,COLOR0080ff,LINETHICK1;
弱势反弹:多空平衡*0.868055,COLOR0000ff,LINETHICK1; {0.9}
最低安全:多空平衡*0.8263889,COLORff00ff,LINETHICK1;
高位止赢:多空平衡*1.12170138,COLOR00ff00,LINETHICK1;
获利了结:多空平衡*1.0723379625,COLORffff00,LINETHICK1;
超涨出货:多空平衡*1.1694444444,COLORff0000,LINETHICK1;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100 ;
STICKLINE(BIAS2<-6,H,L,0,0),COLORGREEN;
STICKLINE(BIAS2<-6,C,O,3,1),COLORGREEN;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(BARSTATUS=2,多空平衡,'平衡1.00'),COLORffffff;
DRAWTEXT(BARSTATUS=2,强势回挡,'回挡0.93'),COLOR0080ff;
DRAWTEXT(BARSTATUS=2,弱势反弹,'反弹0.87'),COLOR0000ff;
DRAWTEXT(BARSTATUS=2,最低安全,'安全0.83'),COLORff00ff;
DRAWTEXT(BARSTATUS=2,高位止赢,'止赢1.12'),COLOR00ff00;
DRAWTEXT(BARSTATUS=2,获利了结,'获利1.07'),COLORFFFF00;
DRAWTEXT(BARSTATUS=2,超涨出货,'超涨1.17'),COLORFF0000;
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0 ),COLOR000099;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0 ),COLOR0000bb;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0 ),COLOR0000dd;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0 ),COLOR0000ff;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,8,0 ),COLOR009900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,6,0 ),COLOR00bb00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,4,0 ),COLOR00dd00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2,0 ),COLOR00ff00;
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:=EMA(DMA(CLOSE,CQ1),2);
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
AMA2:=EMA(DMA(CLOSE,CQ2),2);
PARTLINE(AMA2,AMA2/REF(AMA2,1)>0.997 and AMA2/REF(AMA2,1)<1.001,RGB(0,255,255),AMA2/REF(AMA2,1)>1.001,RGB(255,255,0),1,rgb(255,255,255)),LINETHICK3;

大智慧多空轨道主图指标公式

 

相关文章