在线检测未来函数

通达信龙行凤影指标公式

来源:Internet,编辑:股旁网,2012-03-16

DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=1000* (2*(DIFF-DEA))/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
VAR1:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
准备:IF(VAR1<3.5,15,0),COLORCYAN,LINETHICK2;
DRAWTEXT(准备,10,'准备'),COLORCYAN;
VAR3:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND VAR1<20,5);
钱进:IF(VAR3,0,-20),COLORBROWN,LINETHICK3;
DRAWTEXT(VAR3,-10,'Ψ向“钱”进'), COLORBROWN;
VAR4:=CROSS(VAR1,90);
DRAWTEXT(VAR4,70,'凤舞ラ小心'),COLORCYAN;
RSV:=(CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
FASTK:=SMA(RSV,3,1);
龙K:=SMA(FASTK,2,1);
龙D:=SMA(龙K,5,1);
VAR5:=LLV(LOW,10);
VAR6:=HHV(H,25);
VAR7:=EMA((C-VAR5)/(VAR6-VAR5)*4,4);
DRAWTEXT(CROSS(3.5,VAR7),110,'急卖');
恭喜:STICKLINE(CROSS(VAR7,0.3),-50,-30,3,0), COLOR00AAFF,LINETHICK1;
STICKLINE(CROSS(VAR7,0.3),-40,-30,3,0),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(VAR7,0.3),-20,'恭喜'),COLORMAGENTA;
发财:STICKLINE(CROSS(3.5,VAR7),100,120,2,0), COLORRED,LINETHICK2;
STICKLINE(CROSS(3.5,VAR7),110,120,2,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(3.5,VAR7),90,'发财'),COLORYELLOW;
龙行凤影:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
龙飞凤舞:IF(龙行凤影<=10,-20,-40),COLOR0000FF,LINETHICK2;
DRAWTEXT(龙行凤影<=10,-25,'双'),COLORYELLOW;
DRAWTEXT(龙行凤影<=10,-35,'飞'),COLORYELLOW;
DD:=IF(MACD>=0,MACD,DRAWNULL);
LL:=IF(MACD<0,-MACD,DRAWNULL);
DRAWTEXT(CROSS( 0,MACD)AND VAR1>75,110,'☆高空'),COLORFFFFFF;
红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
花开:IF(CROSS(红红的天,2),70,-50),COLORLIMAGENTA;
DRAWTEXT(CROSS(红红的天,2),75,'花开了'),COLORMAGENTA;
IF(CROSS(红红的天,2),70,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
IF(CROSS(红红的天,2),70,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*200-60;
凤K:SMA(L1,3,1),COLORYELLOW;
凤D:SMA(凤K,3,1),COLORRED;
DRAWTEXT(CROSS(凤D,凤K)AND 凤K>78,100,'快卖');
{明天涨}
RSV9:=(((CLOSE - LLV(LOW,29)) / (HHV(HIGH,29) - LLV(LOW,29))) * 100);
KK9:=MA(RSV9,5);
D9:=MA(KK9,2);
J9:=((3 * KK9) - (2 * D9));
明天涨:IF((J9 < 5),50,0),COLORMAGENTA;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT((J9 < 5),53,'明天涨'),COLORMAGENTA;
{RSI选股}
R:=RSI;
MAR:=MA(R,3);
F:=100*(C-REF(C,1))/REF(C,1);
HHH:=EMA(R,25)+6,COLORBLUE;
GAODIAN:=REF(R,1)>REF(R,2) AND REF(R,1)>R;
DIDIAN:=(REF(R,1)<REF(R,2) AND REF(R,1)<R) OR (REF(R,1)=REF(R,2) AND REF(R,1)<R AND REF(R,2)<REF(R,3));
BIAOJI:=CROSS(HHH,R);
JIN:STICKLINE(REF(R,2)>REF(R,3) AND REF(R,2)>REF(R,1) AND R>REF(R,1)
AND MAR>REF(MAR,1)+1 AND REF(MAR,2)-REF(MAR,1)>-1
AND REF(R,1)<REF(MAR,1) AND REF(R,2)-REF(MAR,2)>-3
AND REF(R,1)<38 AND R<HHH AND F<8,10,50,1,0),COLORBROWN;
DRAWTEXT(JIN,50,'RSI'),COLORBROWN;

通达信龙行凤影指标公式

 

相关文章