在线检测未来函数

通达信精准顶底主图指标公式

来源:Internet,编辑:股旁网,2012-03-19

百分比:=5;右数峰序:=2;
T1:=CONST(O);
B1:=O=T1;
C1:=O=T1-0.01;
D1:=O=T1+0.01;
E1:=B1=0 AND C1=1;F1:=B1=0 AND D1=1;
B2:=C=T1;
C2:=C=T1-0.01;
D2:=C=T1+0.01;
E2:=B2=0 AND C2=1;F2:=B2=0 AND D2=1;
B3:=L=T1;
C3:=L=T1-0.01;
D3:=L=T1+0.01;
E3:=B3=0 AND C3=1;F3:=B3=0 AND D3=1;
B4:=H=T1;
C4:=H=T1-0.01;
D4:=H=T1+0.01;
E4:=B4=0 AND C4=1;F4:=B4=0 AND D4=1;
Q1:=B1 OR B2 OR B3 OR B4;
Q2:=C1 OR C2 OR C3 OR C4;
Q3:=D1 OR D2 OR D3 OR D4;
开盘严格精准:STICKLINE(Q1=1,T1,1.025*T1,1.25,1),COLORYELLOW;
开盘加值精准:STICKLINE(Q2=1 AND Q1=0,T1,1.025*T1,1.25,1),COLORMAGENTA;
开盘减值精准:STICKLINE(Q3=1 AND Q1=0,T1,1.025*T1,1.25,1),COLORGREEN;
开盘精准线:T1,COLORYELLOW;
{低价精准线}
TT1:=CONST(L);
BB1:=O=TT1;
CC1:=O=TT1-0.01;
DD1:=O=TT1+0.01;
EE1:=BB1=0 AND CC1=1;
FF1:=BB1=0 AND DD1=1;
BB2:=C=TT1;
CC2:=C=TT1-0.01;
DD2:=C=TT1+0.01;
EE2:=BB2=0 AND CC2=1;
FF2:=BB2=0 AND DD2=1;
BB3:=L=TT1;
CC3:=L=TT1-0.01;
DD3:=L=TT1+0.01;
EE3:=BB3=0 AND CC3=1;
FF3:=BB3=0 AND DD3=1;
BB4:=H=TT1;
CC4:=H=TT1-0.01;
DD4:=H=TT1+0.01;
EE4:=BB4=0 AND CC4=1;
FF4:=BB4=0 AND DD4=1;
QQ1:=BB1 OR BB2 OR BB3 OR BB4;
QQ2:=CC1 OR CC2 OR CC3 OR CC4;
QQ3:=DD1 OR DD2 OR DD3 OR DD4;
低价严格精准:STICKLINE(QQ1=1,TT1,0.975*TT1,1.25,1),COLORYELLOW;
低价加值精准:STICKLINE(QQ2=1 AND QQ1=0,TT1,0.975*TT1,1.25,1),COLORMAGENTA;
低价减值精准:STICKLINE(QQ3=1 AND QQ1=0,TT1,0.975*TT1,1.25,1),COLORGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
低价精准线:TT1, COLORGREEN;
MA6:MA(C,6);
MA18:MA(C,18);{WEN98编写}
MA24:MA(C,24);
波谷值: CONST(TROUGH(2,百分比,1)),NODRAW;{前M个ZIG转向波谷值}
波谷距离:= 1+CONST(TROUGHBARS(2,百分比,1)),NODRAW;{前M个ZIG转向波谷到当前距离}
{例如:TROUGH(2,5,2)表示%5最低价ZIG转向的前2个波谷到当前的周期数};
波峰值:= CONST(PEAK(1,百分比,右数峰序));
{例如:PEAK(1,5,1)表示%5最高价ZIG转向的上一个波峰的数值}
XG:= ABS(波峰值-波谷值)<=0.024 {AND BARSCOUNT(V)>60};
波峰距离:= 1+CONST(PEAKBARS(1,百分比,右数峰序)),NODRAW;
{PEAKBARS(K,N,M)表示之字转向ZIG(K,N)的前M个波峰到当前的周期数,M必须大于等于1}
距离:=CURRBARSCOUNT;
DRAWLINE(距离=波峰距离 AND XG,波谷值,距离=1,波谷值,1),COLORMAGENTA;
DRAWTEXT(距离=波谷距离 AND XG,L*0.98,' 峰谷线'),COLORYELLOW;
DRAWICON(距离=波峰距离,H*1.01,2);{波峰位置}
DRAWICON(距离=波谷距离,L*0.985,1);{波谷位置}
精准点:=(ABS(H-波谷值)<=0.024 OR ABS(L-波谷值)<=0.024) {AND 距离<=120};
STICKLINE(精准点,波谷值,波谷值,3,1),COLORYELLOW;
TY:=L;
A1:=REF(TY,10)=HHV(TY,2*10+1); B5:=FILTER(A1,10); C5:=BACKSET(B5,10+1); HD:=FILTER(C5,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B6:=FILTER(A2,10); C6:=BACKSET(B6,10+1); LD:=FILTER(C6,10);
前期低位:REF(L,BARSLAST(LD)),COLOR00FF00,POINTDOT;
STICKLINE(L,前期低位,前期低位,8,0),COLORRED;
TZ:=H;
A3:=REF(TY,10)=HHV(TY,2*10+1); B7:=FILTER(A1,10); C7:=BACKSET(B5,10+1); MD:=FILTER(C5,10);
A4:=REF(TY,10)=LLV(TY,2*10+1); B8:=FILTER(A2,10); C8:=BACKSET(B6,10+1); ND:=FILTER(C6,10);
前期高位:REF(H,BARSLAST(MD)),COLOR00FF00,POINTDOT;
STICKLINE(H,前期高位,前期高位,8,0),COLORGREEN;
N:=3;
L0:=0.00;{点位差参数}
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线首次:=L1 OR L2 OR L3 OR L4 OR L5;
精准左:=FILTER(精准线首次,N) ;
天数:=BARSLAST(精准左);
LTS:=REF(L,天数);
精准右:=ABS(L-LTS)<=L0;
STICKLINE(精准左,L,L,50,-1),COLOR8080FF;
G1:=ABS(H-REF(H,1))<=L0;
G2:=ABS(H-REF(H,2))<=L0;
G3:=ABS(H-REF(H,3))<=L0;
G4:=ABS(H-REF(H,4))<=L0;
G5:=ABS(H-REF(H,5))<=L0;
G6:=ABS(H-REF(H,6))<=L0;
G7:=ABS(H-REF(H,7))<=L0;
G8:=ABS(H-REF(H,8))<=L0;
精准线1首次:=G1 OR G2 OR G3 OR G4 OR G5 OR G6 OR G7 OR G8;
精准左1:=FILTER(精准线1首次,N) ;
天数1:=BARSLAST(精准左1);
GTS:=REF(L,天数1);
精准右1:=ABS(H-LTS)<=L0;
STICKLINE(精准左1,H,H,50,-1),COLOR00FF00;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORFF1CAE;

通达信精准顶底主图指标公式

 

相关文章