在线检测未来函数

通达信上班族短线主图指标公式

来源:Internet,编辑:股旁网,2012-03-19

KLC:=REF(C,1);
KRSI:=SMA(MAX(C-KLC,0),6,1)/SMA(ABS(C-KLC),6,1)*100;
KRSV1:=MA(100*EMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)),2),2);
KRSV2:=(C-LLV(L,25))/(HHV(H,25)-LLV(L,25))*100;
K0:=EMA(SLOPE(C,5)*20+C,34);
K1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K2:=SMA(K1,3,1);
K3:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-
EMA(L,20)))/(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
K4:=IF(EMA(C,2)>K0 AND K3>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));
K5:=IF(EMA(C,2)>K0 AND K3>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));
K6:=SMA(C,6.5,1);
K7:=SMA(C,14.5,1);
K8:=SMA(C,3,1);
K9:=SMA(C,8,1);
KA:=(2*C+H+L)/4;
KB:=MA(KA,5);
KC:=LLV((C+L)/2,21);
KC1:=LLV((C+L)/2,0);
KD:=HHV(KA,30)*1.01;
KE:=KB>=REF(KB,1);
KF:=MAX(MAX(K6,K9),K7);
KG:=MIN(MIN(K6,K9),K7);
KH:=EMA((KA-KC)/(KD-KC)*100,7);
KJ:=EMA(0.667*REF(KH,1)+0.333*KH,5);
KK:=1000*KB/K7<=1015 AND 1000*KB/K7>=975;
KL:=1000*K9/K7<=1020 AND K9/K7>=980;
KM:=1000*K6/K7<=1015 AND K6/K7>=985;
KN:=MA(C,89)-MA(C,10)/3;
KP:=SMA(KRSV2,3,1);
KQ:=SMA(KP,3,1);
KR:=3*KP-2*KQ;
KS:=(2*C+H+L)/3;
KT:=EMA(EMA(EMA(KS,4),4),4);
KU:=(KT-REF(KT,1))/REF(KT,1)*100;
KV:=MA(KU,3)+0.03;
KW:=MA(KU,1);
KX:=(C>O AND KF<C AND O<KG AND KE AND L>KC AND K8>K7 AND KR<90 AND CROSS(K8,KB)) OR
(C>O AND K6>K9 AND K9>K7 AND C>MA(C,K7) AND KB>=REF(C,KB) AND CROSS(K8,KB) AND
L>KC AND KR<90);
KY:=(CROSS(K8,KB) AND K8<K7 AND K8<K9 AND K8<K6 AND C>KC) OR
(IF(C<KN AND VOL/240>MA(VOL,5)/240 AND C>REF(C,1)*1.08
AND C<MA(C,13)*1.3,1,0));
KZ:=(CROSS(K8,KB) AND KK AND KL AND KM) OR
(CROSS(K8,K6) AND K8>KB) OR (CROSS(KW,KV)) OR
(IF(COUNT(C<REF(C,1),13)/13>6/10 AND COUNT(KH>KJ,6) AND
REF(L,5)=LLV(L,120) AND REF(C>=O,4) AND REF(C>O,3) AND REF(C>O,2) AND
REF(O>C,1) AND O>REF(C,1),1,0));
KI:=(COUNT(KD=REF(KD,1),3)=3 AND H>KD) OR
(REF(KD,2)<REF(KD,1) AND REF(KD,1)=KD AND REF(H,1)>KD);
KO:=(CROSS(82,KRSI) AND C<K8) OR (CROSS(KV,KW) AND KR>65) OR KI;
K20:=V*(O+C+H+L)/4;
K21:=IF(V>0,K20/V,(O+C+H+L)/4);
K22:=(K21-LLV(K21,3))/(HHV(K21,3)-LLV(K21,3));
K23:=SMA(K22,13,1);
K24:=SMA(K23,13,1);
K25:=3*K23-2*K24;
K26:=2*K25-0.5;
K27:=K21*(1-(K26-K24)/40);
K28:=CROSS(K21,K27) AND C/REF(C,1)<1.03 AND DYNAINFO(23)>=3000;
K29:=FILTER(K28,10);
K2A:=MA(C,80)-MA(C,13)/3;
K2B:=MA((C-K2A)/K2A,2);
K2C:=MA(K2B,2);
K2D:=REF(K2B,2)=LLV(K2B,20) AND REF(K2B,2)<0.071 AND REF(K2B,2)<REF(K2B,1) AND
NOT(REF(L,1)>REF(H,2) AND L>REF(H,1)) AND C>REF(C,1);
K2E:=CROSS(K2B,K2C) AND K2B<0.5;
K2F:=KRSV1>REF(KRSV1,1);
K2G:=KRSV1<=REF(KRSV1,1);
K2H:=C>O AND KB>K6 AND K6>K9 AND K9>K7 AND CROSS(K8,KB) AND L>KC AND KR<90;
K2I:=EMA(V*KA,21)/EMA(V,21);
K2J:=K2I-1.5*STD(K2I,34);
K2K:=K2I+2.0*STD(K2I,34);
K2L:=IF(C>=K2K OR H>=K2K,K2I+2*STD(K2I,55),DRAWNULL);
K2M:=COUNT(C<=K2J OR L<=K2J,3)>=2;
{www.gupang.com 股旁网_通达信股票指标公式}
K2N:=C>=K2K OR H>=K2K OR ((C>K2L OR K2K>K2L) AND NOT(K2L=DRAWNULL));
STICKLINE(KRSV1<=REF(KRSV1,1),KC,KD,5,0),COLOR224422;
STICKLINE(KRSV1> REF(KRSV1,1),KC,KD,5,0),COLOR221133;
升势:IF(KRSV1>REF(KRSV1,1),1,0),COLORCC33FF,NODRAW;
跌势:IF(KRSV1<=REF(KRSV1,1),1,0),COLOR88FF88,NODRAW;
箱顶:MA(KD,1),COLOR00FFFF;
箱底:MA(KC,1),COLOR22FF22;
DRAWICON(KO,KD*1.03,2);
DRAWTEXT(CROSS(K9,K8),KD*1.06,'洗跌'),COLORFF9999;
DRAWTEXT(CROSS(82,KRSI) AND C<K8,KD*1.09,'减'),COLORFF8888;
DRAWTEXT((CROSS(KV,KW) AND KR>65),KD*1.12,'抛'),COLORCYAN;
黄金线:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLOR6688FF;
DRAWTEXT(KX,KC*0.98,'拉升'),COLOR22FFFF;
DRAWTEXT(CROSS(K8,K9) AND K8>KB ,KC*0.95,'全进'),COLOR6600FF;
DRAWICON(FILTER((KY OR KZ) OR FILTER(K2D OR K2E,5) OR K29,5),KC*0.91,1);
顶背:IF(K2N AND NOT(K2M),箱顶*1.02,DRAWNULL),COLORFF00FF,LINETHICK3;
底背:IF(K2M AND NOT(K2N),箱底*0.98,DRAWNULL),COLOR44FF88,LINETHICK3;
DRAWTEXT(K2H,KC*0.83,'回调买'),COLORFFFFAA;
买进:IF(KY OR KZ,1,0),COLOR0000FF,NODRAW;
DRAWTEXT(KZ,KC*0.87,'买'),COLORCC66FF;
减抛:IF(KO AND NOT(KY OR KZ),1,0),COLORFFFF00,NODRAW;
DRAWKLINE(H,O,L,C);DRAWTEXT(C>0,L*0.7,'');

通达信上班族短线主图指标公式

 

相关文章