在线检测未来函数

大智慧资金状态指标公式

来源:Internet,编辑:股旁网,2012-03-20

VAR2:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR3:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=0-VAR3;
VAR5:=0-VAR2;
STICKLINE(VAR5< REF(VAR4,1),(-1)*VAR5,(-1)*VAR4,4,0),COLORRED;
VAR6:=MA(VAR4,3);
STICKLINE((-1)*VAR5>VAR6,(-1)*VAR5,(-1)*VAR4,4,0),COLORRED;
STICKLINE(VAR5>=REF(VAR4,1),(-1)*VAR5,(-1)*VAR4,4,0),COLORGREEN;
VAR7:=REF(LOW,1)*0.9;
VAR8:=LOW*0.9;
VAR9:=(VAR8*VOL+VAR7*(CAPITAL-VOL))/CAPITAL;
VARA:=EMA(VAR9,30);
VARB:=CLOSE-REF(CLOSE,1);
VARC:=MAX(VARB,0);
VARD:=ABS(VARB);
VARE:=SMA(VARC,7,1)/SMA(VARD,7,1)*100;
VARF:=SMA(VARC,13,1)/SMA(VARD,13,1)*100;
VAR10:=BARSCOUNT(CLOSE);
VAR11:=SMA(MAX(VARB,0),6,1)/SMA(ABS(VARB),6,1)*100;
VAR12:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR13:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR14:=SMA((SMA(VAR13,4,1)-50)*2,3,1);
VAR15:=(C-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100;
VAR16:=SMA(VAR15,4,1);
VAR17:=SMA(VAR16,3,1);
VAR18:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR19:=VAR11<=25 AND VAR12<-95 AND VAR18>20 AND VAR14<-30 AND VAR17<30 AND VARA-CLOSE>=-0.25 AND VARE<22 AND VARF<28 AND VAR10>50;
VAR1A:=(HIGH+LOW+CLOSE)/3;
VAR1B:=(VAR1A-MA(VAR1A,14))/(0.015*AVEDEV(VAR1A,14));
VAR1C:=(VAR1A-MA(VAR1A,70))/(0.015*AVEDEV(VAR1A,70));
VAR1D:=IF(VAR1B>=150 AND VAR1B<200 AND VAR1C>=150 AND VAR1C<200,10,0);
VAR1E:=IF(VAR1B<=-150 AND VAR1B>-200 AND VAR1C<=-150 AND VAR1C>-200,-10,VAR1D);
VAR1F:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
VAR22:=SMA(VAR21,3,1);
VAR23:=SMA(VAR22,3,1);
VAR24:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR25:=SMA(VAR24,5,1);
VAR26:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100;
VAR27:=SMA(VAR26,5,1);
VAR28:=SMA(VAR27,5,1);
VAR29:=COST(10);
VAR2A:=(CLOSE-VAR29)/VAR29*100;
VAR2B:=COUNT(VAR2A<-2.05,3);
增量: IF(VAR2B>=3,10,0), COLORFFCC66;
持续增仓: IF(CROSS(5,增量),20,0),COLORRED;
VAR2C:=IF(CROSS(VAR19,0.5),60,0);
{www.gupang.com 股旁网_大智慧股票指标公式}
多头: IF(CROSS(SMA(VAR28,5,1),85),75,0), COLORWHITE;
VAR2D:=CROSS(SMA(MAX(CLOSE-(CLOSE+REF(CLOSE,1))/2,0),5,1)/SMA(ABS(CLOSE-(CLOSE+REF(CLOSE,1))/2),5,1)*100,(CLOSE+REF(CLOSE,1))/2) AND (CLOSE-REF(CLOSE,36))/REF(CLOSE,36)*100<-10 AND HHV(HIGH,40)*0.8>LLV(LOW,5) AND SMA((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)>80;
VAR2E:=(CLOSE-OPEN)/OPEN*100;
VAR2F:=REF(CLOSE,1);
VAR30:=SMA(MAX(CLOSE-VAR2F,0),6,1)/SMA(ABS(CLOSE-VAR2F),6,1)*100;
VAR31:=COUNT(VAR30<20,20)>=1;
VAR32:=IF(VAR2E>9 AND VAR31,60,0);
持仓资金: IF(VAR2C OR VAR32 OR VAR2D*60,60,0) ,COLORYELLOW;
VAR33:=IF("RSI.RSI1"(6,12,24)>78 AND "ROC.ROC"(12,6)< REF("ROC.ROC"(12,6),1) OR "BIAS.BIAS3"(6,12,24)>20,80,100);
VAR34:=IF(CROSS(VAR23,VAR22) AND VAR23>75,80,100);
DRAWTEXT(CROSS(VAR19,0.5) AND COUNT(VAR19=1,10)=1,35,'★'), COLORRED;
沽压资金: IF(VAR33<100 OR VAR34<100,80,100), COLOR00FF00;
VAR301:=(2*CLOSE+HIGH+LOW)/4;
VAR311:=LLV(LOW,34);
VAR321:=HHV(HIGH,34);
A:EMA((VAR301-VAR311)/(VAR321-VAR311)*100,13),COLORFF00FF ;

大智慧资金状态指标公式

 

相关文章