在线检测未来函数

大智慧开高低收指标公式

来源:Internet,编辑:股旁网,2012-03-20

N:=1;
开:SMA(MAX(O-REF(O,N),0),6,1)/SMA(ABS(O-REF(O,1)),6,1)*100 ,linethick0;
高:SMA(MAX(H-REF(H,N),0),6,1)/SMA(ABS(H-REF(H,1)),6,1)*100 ,linethick0;
低:SMA(MAX(L-REF(L,N),0),6,1)/SMA(ABS(L-REF(L,1)),6,1)*100 ,linethick0;
收:SMA(MAX(C-REF(C,N),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100 ,linethick0;
PARTLINE(C,20);PARTLINE(C,80);PARTLINE(C,90); PARTLINE(C,50);
M5:MA(收,5),colorwhite;M13:MA(收,13),coloryellow;
STICKLINE(收>开,开,高,0,0),colorred;
STICKLINE(收>开,收,开,7,0),colorred;
STICKLINE(收<开,开,高,0,0),COLORgreen;
STICKLINE(收<开,收,开,7,0),COLORgreen;
50,pointdot;
DRAWTEXT(abs(max(高,低)-开)<14 and (开-收)>17 and REF(收,1)>60 ,80,'★光头开阴'),Color00FF00;
DRAWTEXT(filter(Min(高,低)<20 and Min(REF(高,1),REF(低,1))<20 and Min(REF(高,2),REF(低,2))<20 and 收>REF(收,1) and c>ma(c,120),5),50,'★买'),colorred;
DRAWTEXT(filter(Min(高,低)<20 and 收>REF(收,1) and c>ma(c,120),5),低,'★买');
DRAWTEXT((收-低)>25,低-5,'★火箭发射'),colorred;
DRAWTEXT(MAX(高,低)>89 and 收<90 and REF(收,1)>90 and REF(收,2)>90,10,'★逃顶'),colorgreen;
DRAWTEXT(MAX(高,低)>79 and 收<80 and REF(收,1)>80 and REF(收,2)>80 ,10,'★透顶');
DRAWTEXT(收<90 and 开>90 and REF(收,1)>90 and REF(收,2)>90 ,30,'★天顶'),colorgreen;
DRAWTEXT(收<90 and 开>90 and REF(收,1)>REF(收,3),高+5,'★瀑布');
{DRAWTEXT(高>50 and 高<80 and (高-MAX(收,开))/(高-低)>0.667 and (ref(高,1)-MAX(ref(收,1),ref(开,1)))/(ref(高,1)-ref(低,1))>0.567 and 高>ref(高,1),高+15,'★调整');
DRAWLINE(收< 开 ,低,ISLASTbar,低,1),COLORYELLOW,POINTDOT;}
DRAWTEXT((Min(高,低)-abs(收-开))/abs(高-低)>0.667 and 收<80 and REF(收,1)>80 ,100,'★逃');
Vars1:=REF(CLOSE,1);
Vars2:=SUM(IF(CLOSE> REF(CLOSE,1),VOL,IF(CLOSE< REF(CLOSE,1),0-VOL,0)),0);
Vars3:= REF(Vars2,1);
Vars4:=SMA(MAX(CLOSE-Vars1,0),7,1)/SMA(ABS(CLOSE-Vars1),7,1)*100;
Vars5:=SMA(MAX(CLOSE-Vars1,0),13,1)/SMA(ABS(CLOSE-Vars1),13,1)*100;
Vars6:=SMA(MAX(Vars2-Vars3,0),26,1)/SMA(ABS(Vars2-Vars3),26,1)*100;
Vars7:=1;
底部: IF(Vars4<15 AND Vars5<20 AND Vars6<50 AND BARSCOUNT(CLOSE)>25,-100,0),stick;
顶部: IF(Vars4>85 AND Vars5>80 AND Vars6>50 AND BARSCOUNT(CLOSE)>25 ,100,0),stick,linethick2;
DRAWTEXT(filter(底部=-100,5),20,'底'),linethick2,POINTDOT,colorwhite;
DRAWTEXT(filter(顶部=100,5),80,'顶'),linethick2,POINTDOT,colorwhite;
Varm1:=(REF(HIGH,1)+REF(LOW,1))/2;
Varm2:=MA(CLOSE,20)+2*STD(CLOSE,20);
Varm3:=REF(CLOSE,1);
Varm4:=SMA(MAX(CLOSE-Varm3,0),7,1)/SMA(ABS(CLOSE-Varm3),7,1)*100;
Varm5:=CROSS(79,Varm4);
Varm6:=FILTER(Varm5,4);
卖出:=if(CROSS(Varm1,Varm2),1,0);
{www.gupang.com 股旁网_大智慧股票指标公式}
STICKLINE(卖出=1,90,100,10,1),COLORblue,LINETHICK3;
{DRAWTEXT(卖出1=1,90,'→卖1'),COLORWHITE,LINETHICK3;}
mcb:=if(Varm6,1,0);
STICKLINE(mcb=1,90,100,10,1),COLORWHITE,LINETHICK3;
{DRAWTEXT(卖出2=1,90,'→卖2'),COLORCYAN,LINETHICK3;}
Var1:=VOL/CAPITAL;
Var2:=VOL/700000000;
Var3:=IF(Var1=0,Var2,Var1);
Var4:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
Var5:=2.5*MAX(Var3,Var4);
Var6:=DMA(CLOSE,Var5);
Var7:=SMA(20*(Var6/REF(Var6,1)-1),2,1);
Var8:=EMA(Var7,2);
白观望:STICKLINE(Var8>=0.003 and ma(c,34)>ref(ma(c,34),1) and ma(c,8)<ref(ma(c,8),1),0.0,10,10,0),linethick4 ,colorwhite ;
红进:STICKLINE(Var8>=0.003 and ma(c,34)>ref(ma(c,34),1) and ma(c,8)>ref(ma(c,8),1),0.0,10,4,1),linethick5 ,colorred ;
红进进:STICKLINE(Var8>=0.003 and ma(c,34)<ref(ma(c,34),1) and ma(c,8)>ref(ma(c,8),1),0.0,5,10,0),linethick4;
STICKLINE(BETWEEN(Var8,0.003,-0.003),0.0,5,6,0),linethick4,colorwhite ;
绿退:STICKLINE(Var8<=-0.003,0.0,0,10,0),linethick3 ,colorgreen;

大智慧开高低收指标公式

 

相关文章