在线检测未来函数

通达信明日支撑MACD指标公式

来源:Internet,编辑:股旁网,2012-03-20

高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
中轴:REFDATE(H3,DATE),POINTDOT,COLORLIGRAY,LINETHICK3;
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=B1-B2;
WDIF:EMA(EMA(EMA(C,3),3),3)+B3;
WDEA:EMA(WDIF,9);
MACD:=2*(WDIF-WDEA);
STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORRED;
STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR00BBFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR0011BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORBB11BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORFFBB11;
VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
趋势:= VARC, COLOR33FFFF;
顶背: STICKLINE(VARC>90,OPEN,CLOSE,1,0) , COLORRED;
VAR26:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR27:=MA(VAR26,5);
VAR28:=MA(VAR26,10);
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L)+0.03;
明日支撑:=L+(C-GJ)+0.01;
阻力:REF(明日阻力 , 1),NODRAW;
支撑:REF(明日支撑 , 1),NODRAW;
KLH:=IF( PERIOD=5,0.015,0);
前天均价:=REF(AMOUNT,1)/REF(VOL*100,1),LINETHICK0;
STICKLINE(CURRBARSCOUNT=1,阻力+KLH,阻力,6,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,支撑,支撑-KLH,6,0),COLORRED;
{www.gupang.com 股旁网_通达信股票指标公式}
涨家:INDEXADV,COLOR0066FF,NODRAW;
跌家:INDEXDEC,COLOR99FF99,NODRAW;
TT2:=DMA((((HIGH+LOW)+(CLOSE*2))/4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);
日线止损:(LC*1.0035*97+0.2)/99.65,COLOR03B4EC,NODRAW;

通达信明日支撑MACD指标公式

 

相关文章