在线检测未来函数

通达信RSI涨幅指标公式

来源:Internet,编辑:股旁网,2012-03-21

N:=5;N1:=23;N2:=25;
VAR1A:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2A:=EMA(VAR1A,9);
VAR3A:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4A:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5A:=SMA(VAR4A,13,8);
VAR6A:=SMA(VAR3A,21,8);
VAR7A:=MA(C,80)-MA(C,10)/7;
VAR8A:=EMA(C,5);
VAR9A:=MA((LLV(C,9))*1.1,14);
VAR10A:=2*VAR9A-VAR8A-C*0.1;
VAR11A:=IF(((VAR8A-VAR10A)*5>0),(POW((VAR8A-VAR10A)*5,2))/10,(-1*(POW((VAR8A-VAR10A)*(5),2)))/(10));
VAR12A:=IF((VAR11A>0),VAR11A-0,12);
VAR13A:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
趋势:CEILING(SMA(VAR5A,13,8)),LINETHICK2,COLOR0000FF;
看底:IF((趋势-VAR6A<(-65)),1,6),COLOR00FF00;
顶峰:IF((趋势-VAR6A>85),95,100),COLORF0F000;
{www.gupang.com 股旁网_通达信股票指标公式}
黄金区: DRAWICON(IF(VAR13A<15,15,0),13,12),COLORYELLOW;
操盘线: MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORBLUE;
{RSI涨幅}
AA1:="RSI.RSI1"(3,14,24),LINETHICK2,COLOR6295D6;
BB1:=REF("RSI.RSI1"(3,14,24),1),LINETHICK2,COLORFF9800;
上涨幅度RSI:IF((AA1-BB1)/BB1>N1/10,45,0),,LINETHICK2,COLORRED ;
DRAWICON((AA1-BB1)/BB1>N1/10,45,5);
DRAWTEXT((AA1-BB1)/BB1>N1/10,40,'RSI出击'),COLORF00FF0;
{AA-100%}
VAR3:=INDEXC;
VAR4:=MA(VAR3,8);
VAR5:=MA(VAR3,22);
VAR6:=MA(VAR3,28);
VAR7:=MA(VAR3,73);
VAR8:=MA(VAR3,106);
VAR9:=VAR7<REF(VAR7,1) AND VAR8<REF(VAR8,1) AND VAR7<VAR8*0.98;
VARA:=VAR6>VAR4*1.11 AND VAR5>VAR4*1.095;
VARB:=VAR4>VAR3*0.95;
VARC:=VAR9 AND VARA AND VARB AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
百分之百: IF(VARC*6,60,0),COLORYELLOW;
DRAWICON(VARC*6>0,60,6);
DRAWTEXT(VARA*6>0,40,'100%获利'),COLORRED;
{RSI二线差}
AA:="RSI.RSI1"(3,14,24);
BB:="RSI.RSI2"(3,14,24);
二线差RSI:IF((BB-AA)/AA>N,50,0),STICK,LINETHICK2,COLOR00FF00;

通达信RSI涨幅指标公式

 

相关文章