在线检测未来函数

飞狐机构K线指标公式

来源:Internet,编辑:股旁网,2012-03-23

均价:=(2*C+(H-L)/2+L+o)/4;
价差:=SUM(均价-REF(均价,1),2)/2;
高低:=(均价+价差);
实价:=(高低+均价)/2;
M24:=SMA(FORCAST(实价,32),32,2);
M26:=SMA(FORCAST(均价,32),32,2);
VAR1:=(M24+M26)/2;
开:=(O-VAR1);高:=(H-VAR1);
低:=(L-VAR1);收:(C-VAR1);
JG:=(2*收+(高-低)/2+低+开)/4,COLORMAGENTA;
jgc:=SUM(JG-REF(JG,1),2)/2;
jgs:=((JG+JGc)+jg)/2;
m8:=sMA(FORCAST(jgs,8),8,2),COLORYELLOW,LINETHICK1,PRECISION2;
m9:=sMA(FORCAST(JG,8),8,2);
子线:=(M8+M9)/2,COLORWHITE,LINETHICK1,PRECISION2;
M14:=SMA(FORCAST(jgs,16),16,2);
M16:=SMA(FORCAST(JG,16),16,2);
子午线:(M14+M16)/2,COLORWHITE,LINETHICK1,PRECISION2;
MJ24:=SMA(FORCAST(jgs,32),32,2);
MJ26:=SMA(FORCAST(JG,32),32,2);
命运线:(MJ24+MJ26)/2,COLORYELLOW;
STICKLINE(MJ24<MJ26,MJ26,MJ24,10,0),COLORCYAN;
STICKLINE(命运线<收,MJ26,MJ24,10,0),COLORYELLOW;
STICKLINE(MJ24>MJ26,MJ26,MJ24,10,0),COLORMAGENTA;
STICKLINE(命运线>收 AND MJ24>MJ26,MJ26,MJ24,10,0),COLORAAAA00;
MID:=命运线;
UPPER:=MID+2*STD(JG,20);
LOWER:=MID-2*STD(JG,20);
V1:=(JG-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;B:=V2>V4;D:=V5>10;
E:=V3<=10 OR V2<=V4 OR V5<=10;
MM:=EMA(JGs,56),COLORCYAN;
I0:=(Ema(MM,3)+Ema(MM,6)+EMA(MM,12)+EMA(MM,24))/4;
xm:=EMA(jg,56);
I1:=(Ema(xm,3)+Ema(xm,6)+EMA(xm,12)+EMA(xm,24))/4;
牛熊线:(I0+I1)/2,LINETHICK0,COLORRED;
STICKLINE(i0<i1,i1,i0,10,0),COLOR00bb00;
STICKLINE(I0>=I1,I1,I0,10,0),COLORRED;
季均价:REF(jg,BARSLAST(MOD(MONTH,3)=0)-1),COLORYELLOW,CROSSDOT,PRECISION2;
半年均价:REF(jg,BARSLAST(MOD(MONTH,6)=0)-1),COLORWHITE,LINETHICK1,CROSSDOT,PRECISION2;
年均价:REF(jg,BARSLAST(MOD(MONTH,12)=0)-1),COLORGREEN,LINETHICK1,CROSSDOT,PRECISION2;
PARTLINE(半年均价=年均价,年均价),CIRCLEDOT,COLORWHITE;
{www.gupang.com 股旁网_飞狐股票指标公式}
STICKLINE(收>=开 AND E,高,低,0,0), COLORRED;
STICKLINE(收>=开 AND E,收,开,5,0) ,COLORRED;
STICKLINE(收< 开 AND E,高,低,0,0) ,COLORCYAN;
STICKLINE(收< 开 AND E,收,开,5,0) ,COLORCYAN;
STICKLINE(开> 收 AND A ,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND A ,收,开,5,0),COLORGREEN;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,5,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,5,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,5,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORCYAN;
STICKLINE(开> 收 AND D,收,开,5,0),COLORCYAN;
STICKLINE(开<=收 AND D,收,开,5,1),COLORCYAN;
{K线卖提示}
KSD:=IF(o>c ,o,c);
VAR12:=IF(TROUGHBARS(KSD,10,1)=1,1,0);
VAR1:=IF(PEAKBARS(KSD,10,1)=1,1,0);
STICKLINE(VAR1,收 ,开,8,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(VAR1,收 ,开,5,0),COLORGRAY,LINETHICK2;{高位黄色}
STICKLINE(VAR1,高,低,1,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(VAR12,收 ,开,8,0),COLOR9900FF,LINETHICK2;{底位红色}
STICKLINE(VAR12,收 ,开,5,0),COLORWHITE,LINETHICK2;{底位红色}
STICKLINE(VAR12,高,低,1,0),COLORRED,LINETHICK2;{底位红色}
穿越:CROSS(子午线,牛熊线)AND ANY(CROSS(收,牛熊线),13),LINETHICK;
穿越1:CROSS(子午线,命运线)AND ANY(CROSS(收,命运线),13),LINETHICK;
穿越2:CROSS(子午线,年均价)AND 年均价=半年均价 AND COUNT((年均价=REF(年均价,1)),5)>=3 AND ANY(CROSS(收,年均价),13),LINETHICK;
DRAWTEXT(穿越=1,子午线*0.98,'★'),COLORYELLOW,ALIGN0;
DRAWTEXT(穿越1=1,子午线*0.98,'★'),COLORRED,ALIGN0;
DRAWICON(穿越2=1,子午线*0.98,1),ALIGN0;

飞狐机构K线指标公式

 

相关文章