在线检测未来函数

大智慧财富侦探指标公式

来源:Internet,编辑:股旁网,2012-03-24

横向参数: CLOSE/MA(CLOSE,13)-INDEXC/MA(INDEXC,13), COLORCYAN;
Var1:=EMA(MA(IF(CLOSE>OPEN,(CLOSE-OPEN)*VOL,IF(CLOSE<OPEN,(CLOSE-OPEN)*VOL,0)),5),1);
Var2:=EMA(MA(IF(CLOSE>REF(CLOSE,1),(CLOSE-REF(CLOSE,1))*VOL,IF(CLOSE<REF(CLOSE,1),(CLOSE-REF(CLOSE,1))*VOL,0)),5),1);
Var3:=EMA(MA(IF(OPEN>REF(CLOSE,1),(OPEN-REF(CLOSE,1))*VOL,IF(OPEN<REF(CLOSE,1),(OPEN-REF(CLOSE,1))*VOL,0)),5),1);
Var4:=EMA(MA(IF(CLOSE<OPEN,(OPEN-CLOSE)*VOL,IF(CLOSE>OPEN,(OPEN-CLOSE)*VOL,0)),10),1);
Var5:=EMA(MA(IF(CLOSE<REF(CLOSE,1),(REF(CLOSE,1)-CLOSE)*VOL,IF(CLOSE>REF(CLOSE,1),(REF(CLOSE,1)-CLOSE)*VOL,0)),10),1);
Var6:=EMA(MA(IF(OPEN<REF(CLOSE,1),(REF(CLOSE,1)-OPEN)*VOL,IF(OPEN>REF(CLOSE,1),(REF(CLOSE,1)-OPEN)*VOL,0)),10),1);
Var7:=CLOSE>OPEN;
Var8:=CLOSE>REF(CLOSE,1);
Var9:=OPEN>REF(CLOSE,1);
VarA:=Var7 OR Var8 OR Var9;
VarB:=(Var1+Var2+Var3)/3/100;
VarC:=(Var4+Var5+Var6)/3/100;
VarD:=EMA((COUNT(Var8,12)/12+COUNT(Var7,12)/12+COUNT(Var9,12)/12)/3*MA(VarB,5)*2*1.1,2);
VarE:=VarC>0 OR VarB<VarD;
VarF:=VarC>0 AND VarB>VarD;
Var10:=VarC<0 AND CROSS(VarB,VarD);
Var11:=VarC>0 AND CROSS(VarB,VarD);
Var12:=VarC<0 AND VarB>VarD AND (CLOSE+OPEN)/2>MA(CLOSE,5);
Var13:=VarE AND (CLOSE+OPEN)/2<MA(CLOSE,5) OR CLOSE<MA(CLOSE,30);
Var14:=Var12 AND Var13;
Var15:=ABS(VarB-VarC);
Var16:=ABS(VarD-VarC);
Var17:=ABS(0-VarC);
Var18:=ABS(0-VarD);
Var19:=IF(VarC<0 AND VarB>VarD AND (CLOSE+OPEN)/2>MA(CLOSE,5),ABS(VarB-VarC),0);
Var1A:=IF(VarE AND (CLOSE+OPEN)/2<MA(CLOSE,5) OR CLOSE<MA(CLOSE,30),ABS(VarD-VarC),0);
Var1B:=IF(NOT(Var14),ABS(VarD-VarC),0);
Var1C:=MAX(Var1B,MAX(Var19,Var1A));
Var1D:=MAX(Var15,MAX(Var16,MAX(Var17,Var18)));
Var1E:=MIN(Var15,MIN(Var16,MIN(Var17,Var18)));
Var1F:=MAX(VarB,MAX(VarC,VarD));
Var20:=MIN(VarB,MIN(VarC,VarD));
Var21:=(VarB+VarC+VarD)/3;
Var22:=Var15 OR Var17 OR Var18;
Var23:=Var16 OR Var17;
Var24:=Var16;
Var25:=VarC<0 AND VarB>VarD AND (CLOSE+OPEN)/2>MA(CLOSE,5);
Var26:=VarE AND (CLOSE+OPEN)/2<MA(CLOSE,5) OR CLOSE<MA(CLOSE,30);
Var27:=IF(VarC<0 AND VarB>VarD AND (CLOSE+OPEN)/2>MA(CLOSE,5) AND REF(Var26,1),ABS(VarB-VarC),0);
Var28:=REF(Var1A,1)<>0 OR REF(Var1B,1)<>0;
Var29:=REF(Var1A,1)<>0 AND REF(Var1B,1)<>0;
Var2A:=Var1B=Var1C AND REF(Var19,1)<>0;
Var2B:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
Var2C:=(15*Var2B+14*REF(Var2B,1)+13*REF(Var2B,2)+12*REF(Var2B,3)+11*REF(Var2B,4)+10*REF(Var2B,5)+9*REF(Var2B,6)+8*REF(Var2B,7)+7*REF(Var2B,8)+6*REF(Var2B,9)+5*REF(Var2B,10)+4*REF(Var2B,11)+3*REF(Var2B,12)+2*REF(Var2B,13)+REF(Var2B,14))/120;
Var2D:=(20*Var2C+19*REF(Var2C,1)+18*REF(Var2C,2)+17*REF(Var2C,3)+16*REF(Var2C,4)+15*REF(Var2C,5)+14*REF(Var2C,6)+13*REF(Var2C,7)+12*REF(Var2C,8)+11*REF(Var2C,9)+10*REF(Var2C,10)+9*REF(Var2C,11)+8*REF(Var2C,12)+7*REF(Var2C,13)+6*REF(Var2C,14)+5*REF(Var2C,15)+4*REF(Var2C,16)+3*REF(Var2C,17)+2*REF(Var2C,18)*REF(Var2C,19))/210;
Var2E:=3*Var2C-2*Var2D;
Var2F:=(5*Var2E+4*REF(Var2E,1)+3*REF(Var2E,2)+2*REF(Var2E,3)+REF(Var2E,4))/15/50+4-3;
多空量能: Var2F,POINTDOT ,LINETHICK0, colorwhite;
Var30:=EMA(0.667*REF(Var2F,1)+0.333*Var2F,2);
Var31:=Var2F*1;
Var32:=Var30*1;
Var33:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),10);
Var34:=HIGH-REF(HIGH,1);
Var35:=REF(LOW,1)-LOW;
Var36:=SUM(IF(Var34>0 AND Var34>Var35,Var34,0),10);
Var37:=SUM(IF(Var35>0 AND Var35>Var34,Var35,0),10);
Var38:=Var36*100/Var33;
Var39:=Var37*100/Var33;
Var3A:=(Var38-Var39)/30;
Var3B:=CLOSE/REF(EMA(CLOSE,30),30);
Var3C:=INDEXC/REF(EMA(INDEXC,30),30);
相对强度: Var3B/Var3C*10-10, COLORGRAY;
STICKLINE(Var3A>=0,Var3A-5,-5,3,0),LINETHICK1 ,colorred;
STICKLINE(Var3A<0,REVERSE(Var3A)-5,-5,3,0), LINETHICK1, COLORCYAN ;
Var3D:=(HIGH+LOW)/2;
Var3E:=SMA(Var3D,5,1)-SMA(Var3D,34,1);
Var3F:=SMA(Var3E-SMA(Var3E,5,1),5,1);
{www.gupang.com 股旁网_大智慧股票指标公式}
Var40:=Var3E>REF(Var3E,1) AND Var3F>REF(Var3F,1);
Var41:=Var3E<REF(Var3E,1) AND Var3F<REF(Var3F,1);
Var42:=Var3E>REF(Var3E,1) AND Var3F<REF(Var3F,1);
Var43:=Var3E<REF(Var3E,1) AND Var3F>REF(Var3F,1);
混沌多空: STICKLINE(Var40,Var2F,Var2F*1.1,2,0),LINETHICK2 ,colorred ;
STICKLINE(Var41,Var2F,Var2F*1.1,2,0),LINETHICK2 ,COLORGREEN;
STICKLINE(Var42,Var2F,Var2F*1.2,2,0),LINETHICK2,colorYELLOW;
STICKLINE(Var43,Var2F,Var2F*1.1,2,0),LINETHICK2 ,COLORCYAN ;
STICKLINE(横向参数>=0,REVERSE(横向参数)*30+5,5,3,0),LINETHICK1 ,colorred ;
STICKLINE(横向参数<0,横向参数*30+5,5,3,0),LINETHICK1 ,COLORCYAN ;
STICKLINE(Var25,VarB/50,VarC/50,3,0),LINETHICK1,coloryellow;
STICKLINE(NOT(Var14),VarD/50,VarC/50,3,0), LINETHICK1,colorred ;
STICKLINE(Var26,VarD/50,VarC/50,3,0),LINETHICK1 ,colorFFB61B;
STICKLINE(Var26 AND NOT(Var14) AND REF(Var19,1),VarD/50,VarC/50,3,0),colorred ,LINETHICK1;
STICKLINE(Var12 AND CLOSE>MA(CLOSE,5),0,VarC/50,3,0),LINETHICK1 ,colorred ;
STICKLINE(VarF,0,VarD/50,3,0), LINETHICK1,colorFFB61B;
STICKLINE(Var2A,Var1F/50,Var20/50,3,0),LINETHICK1 , colorgreen;

大智慧财富侦探指标公式

 

相关文章