在线检测未来函数

通达信飞翔长牛指标公式

来源:Internet,编辑:股旁网,2012-03-24

A0:=SMA(C,3,1);
A1:=(55*A0+34*REF(A0,1)+21*REF(A0,2)+13*REF(A0,3)+8*REF(A0,4)+5*REF(A0,5)
+3*REF(A0,6)+2*REF(A0,7)+REF(A0,8)+REF(A0,9))/143;
A2:=REF(A1,1);
MA1:=0.5*(A1+A2);
ZD0:=SMA(C,5,1);
ZD1:=(55*ZD0+34*REF(ZD0,1)+21*REF(ZD0,2)+13*REF(ZD0,3)+8*REF(ZD0,4)+5*REF(ZD0,5)
+3*REF(ZD0,6)+2*REF(ZD0,7)+REF(ZD0,8)+REF(ZD0,9))/143;
ZD2:=REF(ZD1,1);
MA2:=0.5*(ZD1+ZD2);
H0:=SMA(C,8,1);
H1:=(55*H0+34*REF(H0,1)+21*REF(H0,2)+13*REF(H0,3)+8*REF(H0,4)+5*REF(H0,5)
+3*REF(H0,6)+2*REF(H0,7)+REF(H0,8)+REF(H0,9))/143;
H2:=REF(H1,1);
MA3:=0.5*(H1+H2);
DZ0:=SMA(C,13,1);
DZ1:=(55*DZ0+34*REF(DZ0,1)+21*REF(DZ0,2)+13*REF(DZ0,3)+8*REF(DZ0,4)+5*REF(DZ0,5)
+3*REF(DZ0,6)+2*REF(DZ0,7)+REF(DZ0,8)+REF(DZ0,9))/143;
DZ2:=REF(DZ1,1);
MA5:=0.5*(DZ1+DZ2);
ZX0:=SMA(C,21,1);
ZX1:=(55*ZX0+34*REF(ZX0,1)+21*REF(ZX0,2)+13*REF(ZX0,3)+8*REF(ZX0,4)+5*REF(ZX0,5)
+3*REF(ZX0,6)+2*REF(ZX0,7)+REF(ZX0,8)+REF(ZX0,9))/143;
ZX2:=REF(ZX1,1);
MA6:=0.5*(ZX1+ZX2);
I0:=SMA(C,34,1);
I1:=(55*I0+34*REF(I0,1)+21*REF(I0,2)+13*REF(I0,3)+8*REF(I0,4)+5*REF(I0,5)
+3*REF(I0,6)+2*REF(I0,7)+REF(I0,8)+REF(I0,9))/143;
I2:=REF(I1,1);
MA7:=0.5*(I1+I2);
CX0:=SMA(C,55,1);
CX1:=(55*CX0+34*REF(CX0,1)+21*REF(CX0,2)+13*REF(CX0,3)+8*REF(CX0,4)+5*REF(CX0,5)
+3*REF(CX0,6)+2*REF(CX0,7)+REF(CX0,8)+REF(CX0,9))/143;
CX2:=REF(CX1,1);
MA8:=0.5*(CX1+CX2);
CC0:=SMA(C,89,1);
CC1:=(55*CC0+34*REF(CC0,1)+21*REF(CC0,2)+13*REF(CC0,3)+8*REF(CC0,4)+5*REF(CC0,5)
+3*REF(CC0,6)+2*REF(CC0,7)+REF(CC0,8)+REF(CC0,9))/143;
CC2:=REF(CC1,1);
MA9:=0.5*(CC1+CC2);
TC0:=SMA(C,144,1);
TC1:=(55*TC0+34*REF(TC0,1)+21*REF(TC0,2)+13*REF(TC0,3)+8*REF(TC0,4)+5*REF(TC0,5)
+3*REF(TC0,6)+2*REF(TC0,7)+REF(TC0,8)+REF(TC0,9))/143;
TC2:=REF(TC1,1);
MA10:=0.5*(TC1+TC2);
SC0:=SMA(C,243,1);
SC1:=(55*SC0+34*REF(SC0,1)+21*REF(SC0,2)+13*REF(SC0,3)+8*REF(SC0,4)+5*REF(SC0,5)
+3*REF(SC0,6)+2*REF(SC0,7)+REF(SC0,8)+REF(SC0,9))/143;
SC2:=REF(SC1,1);
MA11:=0.5*(SC1+SC2);
N:=8; S:=1;
DG:=MAX(MAX(MA8,MA9),MAX(MA9,MA10));
ZG:=MAX(MAX(DG,MA10),MAX(MA10,MA11));
DD:=MIN(MIN(MA8,MA9),MIN(MA9,MA10));
ZD:=MIN(MIN(DD,MA10),MIN(MA10,MA11));
粘合:(ZG/ZD-1)*100<N,COLORFFFFFF,NODRAW;
高粘:(ZG/ZD-1)*100<N AND ZD>MA11,COLOR00FFFF,NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
穿MA8:(粘合 AND CROSS(C,MA8))*0.5,COLORFF00FF;
穿MA9:(粘合 AND CROSS(C,MA9))*1,COLOR00FF00;
穿MA10:(粘合 AND CROSS(C,MA10))*2,COLORAAAAAA;
穿MA11:(粘合 AND CROSS(C,MA11))*3,COLORFF8000;
FLSZ:=(C/REF(C,1)-1)*100>=2 AND V>REF(V,1);
飞翔长牛:(((穿MA8/0.5)+穿MA9+(穿MA10/2)+(穿MA11/3))>=2)*3,STICK,COLORRED,LINETHICK4;
STICKLINE(粘合,-0.2,0,4,0),COLORMAGENTA;
STICKLINE(高粘,0.2,0,4,0),COLORRED;
DRAWTEXT(NOT(REF(粘合,1)=1)AND 粘合=1,0,'长线开始关注'),COLORYELLOW;

通达信飞翔长牛指标公式

 

相关文章