在线检测未来函数

同花顺平滑图主图指标公式

来源:Internet,编辑:股旁网,2012-03-26

ED1:=(-2*REF(C,2)+REF(C,1)+2*C);
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
ED3:=(-0.8*REF(C,4)-0.8*REF(C,3)-0.2*REF(C,2)+0.8*REF(C,1)+2*C);
CC:=(-2*REF(C,3)+3*REF(C,2)+6*REF(C,1)+7*C)/14;
JF1:=SMA(SMA(ED1,3,1),3,1);
JF2:=SMA(SMA(ED2,4,1),3,1);
JF3:=SMA(SMA(ED3,4,1),4,1);
M5:=SMA(JF1,5,2);
PARTLINE(M5,M5>REF(M5,1),RGB(250,10,250),M5<=REF(M5,1),RGB
(250,250,10)),LINETHICK2;
M8:SMA(JF1,8,2),ColorFFFFFF;
M13:SMA(JF1,13,2),ColorFFFF1A;
M21:SMA(JF1,21,2),Color1AFF1A;
M55:SMA(JF1,55,2),Color1EFFFF;
M89:SMA(JF1,89,2),Color6C00D9;
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
JF2:=SMA(SMA(ED2,4,1),3,1);
CROSS(ED2,JF2);
MA6:=MA(C,6);
X1:=REF(EMA(C,6),1);
X2:=(EMA(C,6)-X1)/X1*100;
N1:=BARSLAST(CROSS(X2,0));
N2:=BARSLAST(CROSS(0,X2));
X3:=CROSS(X2,0) OR CROSS(0,X2);
STICKLINE(N1<N2,REF(MA6,N1),REF(MA6,N1),8,1),ColorFF15FF;
STICKLINE(N2<N1,REF(MA6,N2),REF(MA6,N2),8,1),ColorFF8B17;
qs1:=IF(C>MA(C,4),1,0);
qs2:=IF(C<MA(C,4),-1,0);
qs3:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
qs4:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
qs:=qs1+qs2+qs3+qs4;
STICKLINE((qs=-2 AND C<O),H,L,0,0),Color00FF00;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,10,0),Color009500;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,8,0),Color00AA00;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,6,0),Color00BF00;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,4,0),Color00D500;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,2,0),Color00EA00;//绿
STICKLINE((qs=-2 AND C>O),H,L,0,0),ColorFF00FF;
STICKLINE((qs=-2 AND C>O),O,C,10,0),ColorBB00BB;
STICKLINE((qs=-2 AND C>O),O,C,8,1),colorFF5BFF;
STICKLINE((qs=-2 AND C>O),O,C,4,0),colorF900F9;
STICKLINE((qs=-2 AND C>O),O,C,2,0),ColorFF11FF;//桔
STICKLINE((qs=0 AND C<O),H,L,0,0),ColorFFFFFF;
STICKLINE((qs=0 AND C<O),O,C,10,0),ColorCCCCCC;
STICKLINE((qs=0 AND C<O),O,C,8,1),ColorDEDEDE;
STICKLINE((qs=0 AND C<O),O,C,4,0),ColorF6F6F6;
STICKLINE((qs=0 AND C<O),O,C,2,0),ColorFFFFFF;//白
STICKLINE((qs=0 AND C>O),H,L,0,0),Color009FFF;
STICKLINE((qs=0 AND C>O),O,C,10,0),Color009FFF;
STICKLINE((qs=0 AND C>O),O,C,8,1),Color00B5FF;
STICKLINE((qs=0 AND C>O),O,C,4,0),Color00E4FF;
STICKLINE((qs=0 AND C>O),O,C,2,0),Color00FFFF;//黄
//{www.gUPaNg.com 股旁网_同花顺股票指标公式}
STICKLINE((qs=2 AND C<O),H,L,0,0),ColorFFFF00;
STICKLINE((qs=2 AND C<O),O,C,10,0),ColorAAAA00;
STICKLINE((qs=2 AND C<O),O,C,8,1),ColorBFBF00;
STICKLINE((qs=2 AND C<O),O,C,4,0),ColorD5D500;
STICKLINE((qs=2 AND C<O),O,C,2,0),ColorEAEA00;//青
STICKLINE((qs=2 AND C>O),H,L,0,0),Color0000FF;
STICKLINE((qs=2 AND C>O),O,C,10,0),Color0000AA;
STICKLINE((qs=2 AND C>O),O,C,8,0),Color0000BF;
STICKLINE((qs=2 AND C>O),O,C,6,0),Color0000D5;
STICKLINE((qs=2 AND C>O),O,C,4,0),Color0000EA;//红
STICKLINE((qs=2 AND C>O),O,C,2,0),Color0000FF;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,4),4)/EMA(EMA(ABS(MTM),4),4);
低吸:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA
(DX,2)),1,0);
DRAWTEXT(FILTER(低吸=1,5),LOW-0.19,'▲'),ColorFFFFFF;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) *
100);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'▼'),Color00E1E1;

同花顺平滑图主图指标公式

 

相关文章