在线检测未来函数

通达信RSI+KDJ+MACD共振指标公式

来源:Internet,编辑:股旁网,2012-03-27

N1:=6;N2:=12;N3:=24;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK2,COLORWHITE;
D:SMA(K,3,1),LINETHICK2,COLORYELLOW;
J:3*K-2*D,LINETHICK2,COLORRED;
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2,COLORGREEN;
DEA :EMA(DIFF,9),LINETHICK2,COLORBLUE;
MACD:2*(DIFF-DEA),LINETHICK2,COLORRED;
RSV1:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*101;
KK:=SMA(RSV1,3,1);
DD:=SMA(KK,3,1);
JJ:=3*KK-2*DD;
买卖:=IF(JJ>=100,100,IF(JJ<=0,0,JJ));
明天买:IF(买卖=100,0-10,0),COLOR00CCCC;
明天卖:IF(买卖=0,90,100),COLOR00FF00;
TYP:=(HIGH+LOW+CLOSE)/3;
STICKLINE(DIFF>REF(DIFF,1),20,20,2,0),COLORRED;
STICKLINE(DIFF<REF(DIFF,1),20,20,2,0),COLORGREEN;
STICKLINE(K>=REF(K,1) OR K>D AND DIFF>REF(DIFF,1),80,80,2,1),COLORRED;
STICKLINE(K<REF(K,1),80,80,2,1),COLORGREEN;
MACD金叉:=CROSS(MACD,DIFF) AND MACD>=(0-0.05) AND MACD<=0.02;
DRAWTEXT(MACD金叉,40,'▲MACD金叉'),COLORRED;
XX:=EMA(MA(LOW,3)*0.96,30);
DIFF金叉:=IF(CROSS(DIFF,DEA) AND XX-REF(XX,1)>0 AND MACD>=REF(MACD,1) AND DIFF<=0,1,0);
DRAWTEXT(DIFF金叉=1,35,'▲DIFF金叉'),COLORRED;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,25,'▲低位金叉'),COLORRED;
DIFDEA:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(DIFDEA=2,21)=1;
DRAWTEXT(二次金叉,20,'▲二次金叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
MACD底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
DRAWTEXT(MACD底背离,30,'▲MACD底背离'),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
MACD顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(FILTER(MACD顶背离,5),100,'▼MACD顶背离') ;
周DIFF:='MACD.DIFF#WEEK';
周DEA:='MACD.DEA#WEEK';
周MACD:='MACD.MACD#WEEK';
DIF周金叉:=CROSS(周DIFF,周DEA);
DRAWTEXT(DIF周金叉,45,'▲DIFF周金叉'),COLORRED;
DRAWTEXT(CROSS(周DEA,周DIFF),110,'▼DIFF周死叉') ;
MACD周金叉:=CROSS(周MACD,周DIFF) AND 周MACD>=(0-0.05) AND 周MACD<=0.02;
DRAWTEXT(MACD周金叉,50,'▲MACD周金叉'),COLORRED;
月DIFF:='MACD.DIFF#MONTH';
月DEA:='MACD.DEA#MONTH';
月MACD:='MACD.MACD#MONTH';
DIF月金叉:=CROSS(月DIFF,月DEA);
DRAWTEXT(DIF月金叉,55,'▲DIFF月金叉'),COLORRED ;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(CROSS(月DEA,月DIFF),105,'▼DIFF月死叉') ;
MACD月金叉:=CROSS(月MACD,月DIFF) AND 月MACD>=(0-0.05) AND 月MACD<=0.02;
DRAWTEXT(MACD月金叉,60,'▲MACD月金叉'),COLORRED;
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周J:="KDJ.J#WEEK"(9,3,3);
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
月J:="KDJ.J#MONTH"(9,3,3);
KD月金叉:=CROSS(月K,月D);
KD周金叉:=CROSS(周K,周D);
KD日金叉:=FILTER(CROSS(K,D) AND D<50,4);
KD低位金叉:=FILTER(CROSS(K,D) AND D<20,4);
DRAWTEXT(KD月金叉,0,'▲KD月金叉'),COLORRED;
DRAWTEXT(KD周金叉,-5,'▲KD周金叉'),COLORRED ;
DRAWTEXT(KD日金叉,-10,'▲KD日金叉'),COLORRED ;
DRAWTEXT(KD低位金叉,5,'▲KD低位金叉'),COLORRED;
KD1:=COUNT(CROSS(K,D),BARSLAST(D>=50));
KD二次金叉:=CROSS(K,D) AND D<50 AND COUNT(KD1=2,21)=1;
DRAWTEXT(KD二次金叉,10,'▲KD二次金叉'),COLORRED ;
KD2:=COUNT(CROSS(D,K),BARSLAST(D<=50));
KD二次死叉:=CROSS(D,K) AND D>50 AND COUNT(KD2=2,21)=1;
DRAWTEXT(KD二次死叉,95,'▼KD二次死叉') ;
KD日死叉:=FILTER(CROSS(D,K) AND D>80,4);
DRAWTEXT(KD日死叉,80,'▼KD日死叉') ;
DRAWTEXT(CROSS(周D,周K),85,'KD周死叉') ;
DRAWTEXT(CROSS(月D,月K),90,'KD月死叉') ;
KDB:=BARSLAST(REF(CROSS(K,D),1));
KDDB:=REF(CLOSE,KDB+1)>CLOSE AND REF(K,KDB+1)<K AND CROSS(K,D);
KDJ底背离:=IF(FILTER(KDDB>0,5),1,0);
DRAWTEXT(KDJ底背离=1,15,'▲KDJ底背离'),COLORRED;
KDD:=BARSLAST(REF(CROSS(D,K),1));
KDJ顶背离:=REF(CLOSE,KDD+1)<CLOSE AND REF(K,KDD+1)>K AND CROSS(D,K);
DRAWTEXT(FILTER(KDJ顶背离>0,5),120,'▼KDJ顶背离') ;
RSI周金:DRAWTEXT(CROSS("RSI.RSI1#WEEK"(N1,N2,N3),"RSI.RSI2#WEEK"(N1,N2,N3)) ,65,'▲RSI周金'),COLORRED;
RSI周死:DRAWTEXT(CROSS("RSI.RSI2#WEEK"(N1,N2,N3),"RSI.RSI1#WEEK"(N1,N2,N3)) ,130,'▼RSI周死') ;
RSI月金:DRAWTEXT(CROSS("RSI.RSI1#MONTH"(N1,N2,N3),"RSI.RSI2#MONTH"(N1,N2,N3)) ,70,'▲RSI月金'),COLORRED;
RSI月死:DRAWTEXT(CROSS("RSI.RSI2#MONTH"(N1,N2,N3),"RSI.RSI1#MONTH"(N1,N2,N3)) ,115,'▼RSI月死') ;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
DRAWTEXT(RSI底背离,75,'▲RSI底背离'),COLORRED;
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
DRAWTEXT(RSI顶背离,125,'▼RSI顶背离') ;
{预涨}
AZ:=DYNAINFO(7);
AC1:=REF(C,1);
ZF1:=(AZ-AC1)/AC1*100;
BZ:=DYNAINFO(8);
BV1:=REF(VOL,1);
ZF2:=BZ/BV1*100;
DZ:=REF(CLOSE,1)-REF(OPEN,1);
EZ:=DYNAINFO(23)-DYNAINFO(22);
FZ:=REF(VOL,1)-REF(VOL,2);
预涨:=ZF1>1 AND ZF1<5 AND ZF2>30 AND DZ>0 AND EZ>0 AND FZ>0 AND D>REF(D,1);
DRAWTEXT(预涨,D*0.6,'预\N涨'),COLOR00CC00;
KX:=250;
KH:=HHV(K,KX);
DH:=HHV(D,KX);
JH:=HHV(J,KX);
KL:=LLV(K,KX);
DL:=LLV(D,KX);
JL:=LLV(J,KX);
HKMAX:=MAX(KH,MAX(DH,JH));
LKMIN:=MIN(KL,MIN(DL,JL));
KHLB:=(HKMAX+LKMIN)/2;
KHLC:=HKMAX-LKMIN;
MHF:=HHV(DIFF,KX);
MHD:=HHV(DEA,KX);
MHM:=HHV(MACD,KX);
MLF:=LLV(DIFF,KX);
MLD:=LLV(DEA,KX);
MLM:=LLV(MACD,KX);
HMAX:=MAX(MHF,MAX(MHD,MHM));
LMIN:=MIN(MLF,MIN(MLD,MLM));
FHLB:=(HMAX-LMIN)/100;
FHLC:=HMAX-LMIN;
SH:=(0-FHLB)*(KHLC/FHLC)+KHLB;
DIFFA:=(DIFF-FHLB)*(KHLC/FHLC)+KHLB;
DEAA:=(DEA-FHLB)*(KHLC/FHLC)+KHLB;
MACDA:=(MACD-FHLB)*(KHLC/FHLC)+KHLB;
MD1:=MA(CLOSE,80)-MA(CLOSE,13)/3;
MD2:=MA((CLOSE-MD1)/MD1,3);
买点1:=CROSS(MD2,0) AND LOW/REF(HIGH,1)<1.012 AND J<75 AND J>REF(J,1);
MA12:=MA(CLOSE,12);
佳点:=IF(FILTER(MACD>=REF(MACD,5) AND OPEN<=REF(CLOSE,1) AND XX-REF(XX,1)>0 AND MACD<=0 AND MA12-REF(MA12,1)>=0,3) AND J<80 AND J>REF(J,1) AND D>REF(D,1) AND (DIFF>=REF(DIFF,1) OR DEA>=REF(DEA,1)),1,0);
DRAWTEXT(佳点=1,MACDA*0.98,'佳点'),COLOR00CC00;
DX0:=EMA(CLOSE,2)-EMA(OPEN,5);
DX1:=IF(CROSS(DX0,MACD) AND LOW<=XX AND MACD<=(0-0.11) AND (J<20 OR K<20),1,0);
DRAWTEXT(FILTER(DX1,3),0,'短10%'),COLOR00CC00;{短线}
MA10:=MA(CLOSE,10); SS:=EMA(MA(HIGH,3)*1.05,30);
LQS:=IF(FILTER(0.7*(CROSS(DIFF,DEA) AND CLOSE<SS AND XX-REF(XX,1)>0 AND CROSS(MACD,0) AND MACD>=0 AND DIFF>0 AND MA10-REF(MA10,1)>0 AND VOL>REF(VOL,1))>=0.7 AND (CLOSE<SS AND XX-REF(XX,1)>0),5) AND J<80,1,0);
DRAWTEXT(LQS=1,MACDA*0.98,'量价齐上'),COLOR00CC00;{量价齐上}
最佳点:=IF(COUNT(MD2>REF(MD2,1),3)=3 AND COUNT(MD2<0,10)=10 AND REF(MD2,3)=LLV(MD2,10) AND J<80 AND J>REF(J,1),1,0);
DRAWTEXT(最佳点=1,J,'最佳点'),COLOR00CC00;
买点2:=REF(MD2,2)=LLV(MD2,20) AND REF(MD2,2)<0.071 AND REF(MD2,2)<REF(MD2,1) AND
NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1) AND J<75 AND J>REF(J,1);
DRAWTEXT(买点1 OR 买点2,D-1,'买'),COLOR00CC00;

通达信RSI+KDJ+MACD共振指标公式

 

相关文章